aboutsummaryrefslogtreecommitdiff
path: root/textproc/scim
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2004-08-12 07:14:44 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2004-08-12 07:14:44 +0000
commitdbd08195c748c878161571e1b9e3d09b96bd15b3 (patch)
treee81704df25542482f32e87c0c4b59172d22fcc2e /textproc/scim
parentf3a4d01c12dcb2d993a4b41ca52ef8f5265845ab (diff)
downloadports-dbd08195c748c878161571e1b9e3d09b96bd15b3.tar.gz
ports-dbd08195c748c878161571e1b9e3d09b96bd15b3.zip
Notes
Diffstat (limited to 'textproc/scim')
-rw-r--r--textproc/scim/Makefile22
-rw-r--r--textproc/scim/files/extra-patch-4-stable95
-rw-r--r--textproc/scim/pkg-plist2
3 files changed, 111 insertions, 8 deletions
diff --git a/textproc/scim/Makefile b/textproc/scim/Makefile
index 70fb40367841..35b3e07a7489 100644
--- a/textproc/scim/Makefile
+++ b/textproc/scim/Makefile
@@ -7,9 +7,11 @@
PORTNAME= scim
PORTVERSION= 0.99.5
+PORTREVISION= 1
CATEGORIES= textproc
-MASTER_SITES= http://freedesktop.org/~suzhe/sources/
-
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://freedesktop.org/~suzhe/sources/
+MASTER_SITE_SUBDIR=scim
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= Smart Common Input Method platform
@@ -21,15 +23,21 @@ USE_GMAKE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
- LDFLAGS="-L${LOCALBASE}/lib -lintl" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
+CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} <= 499999
-BROKEN= "4.x lacks C99 compliant wctypes implementation"
+.if ${OSVERSION} < 500035
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+RUN_DEPENDS+= ${LOCALBASE}/lib/libstlport_gcc.so:${PORTSDIR}/devel/stlport
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/stlport" \
+ LDFLAGS="-L${LOCALBASE}/lib -lstlport_gcc -lintl ${PTHREAD_LIBS}"
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-4-stable
+PLIST_SUB= NOSTABLE="@comment "
+.else
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include -D__STDC_ISO_10646__" \
+ LDFLAGS="-L${LOCALBASE}/lib -lintl"
.endif
post-configure:
diff --git a/textproc/scim/files/extra-patch-4-stable b/textproc/scim/files/extra-patch-4-stable
new file mode 100644
index 000000000000..d77e85da0efd
--- /dev/null
+++ b/textproc/scim/files/extra-patch-4-stable
@@ -0,0 +1,95 @@
+--- src/scim_event.cpp.orig Wed Aug 4 19:20:29 2004
++++ src/scim_event.cpp Wed Aug 4 19:20:49 2004
+@@ -25,6 +25,7 @@
+ #define Uses_SCIM_EVENT
+ #include "scim_private.h"
+ #include "scim.h"
++#include <cstdio>
+
+ namespace scim {
+
+--- src/scim_global_config.cpp.orig Wed Aug 4 19:22:06 2004
++++ src/scim_global_config.cpp Wed Aug 4 19:22:10 2004
+@@ -32,6 +32,7 @@
+ #include <sys/stat.h>
+ #include <sys/types.h>
+ #include <unistd.h>
++#include <cstdio>
+
+ #include "scim_private.h"
+ #include "scim.h"
+--- modules/IMEngine/scim_socket_imengine.cpp.orig Wed Aug 4 19:25:53 2004
++++ modules/IMEngine/scim_socket_imengine.cpp Wed Aug 4 19:26:50 2004
+@@ -39,6 +39,7 @@
+ #include "scim.h"
+ #include "scim_socket_imengine.h"
+ #include <unistd.h>
++#include <cstdio>
+
+ #define scim_module_init socket_LTX_scim_module_init
+ #define scim_module_exit socket_LTX_scim_module_exit
+--- modules/Config/scim_gconf_config.cpp.orig Wed Aug 4 19:42:16 2004
++++ modules/Config/scim_gconf_config.cpp Wed Aug 4 19:49:22 2004
+@@ -34,6 +34,7 @@
+ #include "scim_private.h"
+ #include "scim.h"
+ #include "scim_gconf_config.h"
++#include <cstdio>
+
+ #define scim_module_init gconf_LTX_scim_module_init
+ #define scim_module_exit gconf_LTX_scim_module_exit
+@@ -496,11 +498,11 @@
+ std::vector <String> strs;
+ if (scim_split_string_list (strs, str, ':') == 2) {
+ time_t sec = (time_t) strtol (strs [0].c_str (), 0, 10);
+- suseconds_t usec = (suseconds_t) strtol (strs [1].c_str (), 0, 10);
++ long usec = (long) strtol (strs [1].c_str (), 0, 10);
+ // The config file is newer, so load it.
+ if (m_update_timestamp.tv_sec < sec || (m_update_timestamp.tv_sec == sec && m_update_timestamp.tv_usec < usec)) {
+ m_update_timestamp.tv_sec = (time_t) sec;
+- m_update_timestamp.tv_usec = (suseconds_t) usec;
++ m_update_timestamp.tv_usec = (long) usec;
+ m_need_reload = true;
+ }
+ }
+--- modules/Config/scim_simple_config.cpp.orig Wed Aug 4 19:50:05 2004
++++ modules/Config/scim_simple_config.cpp Wed Aug 4 19:50:46 2004
+@@ -596,13 +596,13 @@
+ std::vector <String> strs;
+ if (scim_split_string_list (strs, it->second, ':') == 2) {
+ time_t sec = (time_t) strtol (strs [0].c_str (), 0, 10);
+- suseconds_t usec = (suseconds_t) strtol (strs [1].c_str (), 0, 10);
++ long usec = (long) strtol (strs [1].c_str (), 0, 10);
+
+ // The config file is newer, so load it.
+ if (m_update_timestamp.tv_sec < sec || (m_update_timestamp.tv_sec == sec && m_update_timestamp.tv_usec < usec)) {
+ m_config.swap (config);
+ m_update_timestamp.tv_sec = (time_t) sec;
+- m_update_timestamp.tv_usec = (suseconds_t) usec;
++ m_update_timestamp.tv_usec = (long) usec;
+ return true;
+ }
+ }
+--- modules/Config/scim_socket_config.cpp.orig Wed Aug 4 19:51:15 2004
++++ modules/Config/scim_socket_config.cpp Wed Aug 4 19:51:44 2004
+@@ -581,7 +581,7 @@
+ std::vector <String> strs;
+ if (scim_split_string_list (strs, str, ':') == 2) {
+ time_t sec = (time_t) strtol (strs [0].c_str (), 0, 10);
+- suseconds_t usec = (suseconds_t) strtol (strs [1].c_str (), 0, 10);
++ long usec = (long) strtol (strs [1].c_str (), 0, 10);
+
+ // The config file is newer, so load it.
+ if (m_update_timestamp.tv_sec < sec ||
+--- modules/IMEngine/Makefile.in.orig Thu Aug 5 16:55:50 2004
++++ modules/IMEngine/Makefile.in Thu Aug 5 16:57:34 2004
+@@ -74,8 +74,7 @@
+ libgenerictable.la
+ am_table_la_OBJECTS = scim_table_imengine.lo
+ table_la_OBJECTS = $(am_table_la_OBJECTS)
+-@SCIM_BUILD_IMENGINE_TABLE_TRUE@am__EXEEXT_1 = \
+-@SCIM_BUILD_IMENGINE_TABLE_TRUE@ scim-make-table$(EXEEXT)
++@SCIM_BUILD_IMENGINE_TABLE_TRUE@am__EXEEXT_1 =
+ binPROGRAMS_INSTALL = $(INSTALL_PROGRAM)
+ PROGRAMS = $(bin_PROGRAMS)
+ am_scim_make_table_OBJECTS = scim_make_table.$(OBJEXT)
diff --git a/textproc/scim/pkg-plist b/textproc/scim/pkg-plist
index c335b2c324bf..4880109568d2 100644
--- a/textproc/scim/pkg-plist
+++ b/textproc/scim/pkg-plist
@@ -1,6 +1,6 @@
bin/scim
bin/scim-config-agent
-bin/scim-make-table
+%%NOSTABLE%%bin/scim-make-table
bin/scim-setup
@unexec env GCONF_CONFIG_SOURCE=xml::%D/etc/gconf/gconf.xml.defaults gconftool-2 --makefile-uninstall-rule %D/etc/gconf/schemas/scim.schemas >/dev/null || /usr/bin/true
etc/gconf/schemas/scim.schemas