aboutsummaryrefslogtreecommitdiff
path: root/textproc/sgmlformat
diff options
context:
space:
mode:
authorDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-08-31 20:02:45 +0000
committerDavid W. Chapman Jr. <dwcjr@FreeBSD.org>2001-08-31 20:02:45 +0000
commit76f3684ac68af335989513826981bf84d94e0625 (patch)
tree0efb88a65f208f81e9db1262fd62cc0f781cc683 /textproc/sgmlformat
parent927e93e1ec790d46e0d85e016aedc7e1e92d474e (diff)
downloadports-76f3684ac68af335989513826981bf84d94e0625.tar.gz
ports-76f3684ac68af335989513826981bf84d94e0625.zip
Notes
Diffstat (limited to 'textproc/sgmlformat')
-rw-r--r--textproc/sgmlformat/Makefile1
-rw-r--r--textproc/sgmlformat/files/patch-sgmlfmt.pl25
2 files changed, 26 insertions, 0 deletions
diff --git a/textproc/sgmlformat/Makefile b/textproc/sgmlformat/Makefile
index 95aca3def15b..5cd298c4e1be 100644
--- a/textproc/sgmlformat/Makefile
+++ b/textproc/sgmlformat/Makefile
@@ -7,6 +7,7 @@
PORTNAME= sgmlformat
PORTVERSION= 1.7
+PORTREVISION= 1
CATEGORIES= textproc print
MASTER_SITES= http://fallout.campusview.indiana.edu/ports/distfiles/
diff --git a/textproc/sgmlformat/files/patch-sgmlfmt.pl b/textproc/sgmlformat/files/patch-sgmlfmt.pl
new file mode 100644
index 000000000000..2970292586af
--- /dev/null
+++ b/textproc/sgmlformat/files/patch-sgmlfmt.pl
@@ -0,0 +1,25 @@
+--- sgmlfmt/sgmlfmt.pl.orig Tue Sep 15 23:05:47 1998
++++ sgmlfmt/sgmlfmt.pl Thu Jun 14 15:37:50 2001
+@@ -151,19 +151,14 @@
+ open (outfile, ">$fileroot.trf");
+ &sgmlparse(infile, "roff");
+ while (<infile>) {
++ s,\\\(ru,_,g if /^\.GET[HP]N/;
+ print outfile;
+ }
+ close(infile);
+ close(outfile);
++ system("groff -z -rRef=1 -T ${driver} -t ${fileroot}.trf 2>&1 | egrep '^\\.' > ${fileroot}.qrf");
+ system("groff -T ${driver} -t ${fileroot}.trf ${postproc} > ${fileroot}.${driver}");
+-
+- # If foo.tmp has been created, then there are cross references
+- # in the file and we need a second pass to resolve them correctly.
+-
+- if (stat("${fileroot}.tmp")) {
+- system("groff -T ${driver} -t ${fileroot}.trf ${postproc} > ${fileroot}.${driver}");
+- unlink("${fileroot}.qrf");
+- }
++ unlink("${fileroot}.qrf");
+ unlink("${fileroot}.trf");
+ }
+