aboutsummaryrefslogtreecommitdiff
path: root/textproc/sigil
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2012-11-03 07:47:51 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2012-11-03 07:47:51 +0000
commit6d90bd9abfab5a0a7c6c8d20ac81048a0e9c18a9 (patch)
treeed2d6e3cbc284d662f8cfc7d5ef419d66f430f92 /textproc/sigil
parent0efdb453daed1a60a3faa5384962861536511550 (diff)
Notes
Diffstat (limited to 'textproc/sigil')
-rw-r--r--textproc/sigil/Makefile37
-rw-r--r--textproc/sigil/distinfo4
-rw-r--r--textproc/sigil/files/patch-ZipArchive44
-rw-r--r--textproc/sigil/files/patch-src_minizip_ioapi.h17
-rw-r--r--textproc/sigil/pkg-plist47
5 files changed, 62 insertions, 87 deletions
diff --git a/textproc/sigil/Makefile b/textproc/sigil/Makefile
index 509e83dcc8ab..34abb44132e3 100644
--- a/textproc/sigil/Makefile
+++ b/textproc/sigil/Makefile
@@ -1,13 +1,8 @@
-# New ports collection makefile for: sigil
-# Date created: 2010-09-07
-# Whom: Jonathan Chen <jonc@chen.org.nz>
-#
+# Created by: Jonathan Chen <jonc@chen.org.nz>
# $FreeBSD$
-#
PORTNAME= sigil
-PORTVERSION= 0.5.3
-PORTREVISION= 1
+PORTVERSION= 0.6.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= Sigil-${PORTVERSION}-Code
@@ -15,31 +10,25 @@ DISTNAME= Sigil-${PORTVERSION}-Code
MAINTAINER= jonc@chen.org.nz
COMMENT= WYSIWYG ePub editor
-LIB_DEPENDS= boost_thread.4:${PORTSDIR}/devel/boost-libs \
- xerces-c.3:${PORTSDIR}/textproc/xerces-c3 \
- hunspell-1.3.0:${PORTSDIR}/textproc/hunspell \
- pcre.1:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
+ xerces-c:${PORTSDIR}/textproc/xerces-c3 \
+ hunspell-1:${PORTSDIR}/textproc/hunspell \
+ pcre:${PORTSDIR}/devel/pcre
+
+LICENCE= GPLv3
USE_ZIP= yes
USE_CMAKE= yes
USE_DOS2UNIX= CMakeLists.txt DirEnumerator.cpp ZipFile_stl.cpp ZipPlatform_lnx.cpp
NO_WRKSUBDIR= yes
USE_QT4= qmake gui svg webkit xml moc uic rcc imageformats linguist
-
-DESKTOP_ENTRIES="Sigil Editor" \
- "${COMMENT}" \
- "${PREFIX}/share/pixmaps/sigil.png" \
- "sigil" \
- "Application;" \
- ${FALSE}
+USE_GNOME= desktopfileutils
+USE_PKGCONFIG= build
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' ${WRKSRC}/CMakeLists.txt
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700000
-BROKEN= does not compile on 6.X
-.endif
+post-install:
+ @-update-desktop-database > /dev/null
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/sigil/distinfo b/textproc/sigil/distinfo
index 7fe1fceb03ce..7077ff8f1766 100644
--- a/textproc/sigil/distinfo
+++ b/textproc/sigil/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Sigil-0.5.3-Code.zip) = 9525ac3885e7d3962a85e491b271fd857e8a9430e92868e1772c3bcaeb9bc778
-SIZE (Sigil-0.5.3-Code.zip) = 12843490
+SHA256 (Sigil-0.6.0-Code.zip) = 02b95d3d1d5ad8a186212c6c60ae76fa17a98da83a748965db9546ff51903308
+SIZE (Sigil-0.6.0-Code.zip) = 12907949
diff --git a/textproc/sigil/files/patch-ZipArchive b/textproc/sigil/files/patch-ZipArchive
deleted file mode 100644
index 4d01d73f7dc3..000000000000
--- a/textproc/sigil/files/patch-ZipArchive
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -ruN /tmp/Sigil-0.2.4-Code/src/ZipArchive/DirEnumerator.cpp ./src/ZipArchive/DirEnumerator.cpp
---- /tmp/Sigil-0.2.4-Code/src/ZipArchive/DirEnumerator.cpp 2010-08-12 17:50:52.000000000 +1200
-+++ ./src/ZipArchive/DirEnumerator.cpp 2010-09-07 22:01:02.000000000 +1200
-@@ -73,7 +73,7 @@
- if (!entry)
- break;
- CZipString path(m_szCurrentDirectory + entry->d_name);
-- #if !defined __APPLE__ && !defined __CYGWIN__ && !defined __NetBSD__
-+ #if !defined __APPLE__ && !defined __CYGWIN__ && !defined __NetBSD__ && !defined __FreeBSD__
- struct stat64 sStats;
- if (stat64(path, &sStats) == -1)
- #else
-diff -ruN /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipFile_stl.cpp ./src/ZipArchive/ZipFile_stl.cpp
---- /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipFile_stl.cpp 2010-08-12 17:50:52.000000000 +1200
-+++ ./src/ZipArchive/ZipFile_stl.cpp 2010-09-07 22:01:02.000000000 +1200
-@@ -16,7 +16,7 @@
-
- #if (defined _ZIP_IMPL_STL && (!defined _ZIP_FILE_IMPLEMENTATION || _ZIP_FILE_IMPLEMENTATION == ZIP_ZFI_DEFAULT)) || _ZIP_FILE_IMPLEMENTATION == ZIP_ZFI_STL
-
--#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__
-+#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__ || defined __FreeBSD__
- #define FILE_FUNCTIONS_64B_BY_DEFAULT
- #else
- #undef FILE_FUNCTIONS_64B_BY_DEFAULT
-diff -ruN /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipPlatform_lnx.cpp ./src/ZipArchive/ZipPlatform_lnx.cpp
---- /tmp/Sigil-0.2.4-Code/src/ZipArchive/ZipPlatform_lnx.cpp 2010-08-12 17:50:52.000000000 +1200
-+++ ./src/ZipArchive/ZipPlatform_lnx.cpp 2010-09-07 22:01:02.000000000 +1200
-@@ -16,7 +16,7 @@
-
- #ifdef _ZIP_SYSTEM_LINUX
-
--#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__
-+#if defined __APPLE__ || defined __CYGWIN__ || defined __NetBSD__ || defined __FreeBSD__
- #define FILE_FUNCTIONS_64B_BY_DEFAULT
- #else
- #undef FILE_FUNCTIONS_64B_BY_DEFAULT
-@@ -34,7 +34,7 @@
-
- #include <sys/types.h>
-
--#if defined (__FreeBSD__) || defined (__APPLE__) || defined (__NetBSD__)
-+#if defined (__FreeBSD__) || defined (__APPLE__) || defined (__NetBSD__) || defined (__FreeBSD__)
- #include <sys/param.h>
- #include <sys/mount.h>
diff --git a/textproc/sigil/files/patch-src_minizip_ioapi.h b/textproc/sigil/files/patch-src_minizip_ioapi.h
new file mode 100644
index 000000000000..b383ef5c9627
--- /dev/null
+++ b/textproc/sigil/files/patch-src_minizip_ioapi.h
@@ -0,0 +1,17 @@
+--- src/minizip/ioapi.h.orig 2012-10-27 20:24:40.000000000 +0400
++++ src/minizip/ioapi.h 2012-11-02 19:04:46.652602414 +0400
+@@ -44,7 +44,13 @@
+ #include <stdlib.h>
+ #include "zlib.h"
+
+-#if defined(USE_FILE32API)
++#if defined(__FreeBSD__)
++ #define FILE_FUNCTIONS_64B_BY_DEFAULT
++#else
++ #undef FILE_FUNCTIONS_64B_BY_DEFAULT
++#endif
++
++#if defined(USE_FILE32API) || defined(FILE_FUNCTIONS_64B_BY_DEFAULT)
+ #define fopen64 fopen
+ #define ftello64 ftell
+ #define fseeko64 fseek
diff --git a/textproc/sigil/pkg-plist b/textproc/sigil/pkg-plist
index 9c8722e0c6a4..c0436dd1ba10 100644
--- a/textproc/sigil/pkg-plist
+++ b/textproc/sigil/pkg-plist
@@ -1,37 +1,50 @@
bin/sigil
+share/applications/sigil.desktop
share/pixmaps/sigil.png
-share/sigil/dictionaries/About.txt
-share/sigil/dictionaries/de_DE.aff
-share/sigil/dictionaries/de_DE.dic
-share/sigil/dictionaries/en_GB.aff
-share/sigil/dictionaries/en_GB.dic
-share/sigil/dictionaries/en_US.aff
-share/sigil/dictionaries/en_US.dic
-share/sigil/dictionaries/es.aff
-share/sigil/dictionaries/es.dic
-share/sigil/dictionaries/fr.aff
-share/sigil/dictionaries/fr.dic
-share/sigil/dictionaries/hyph_de_DE.dic
-share/sigil/dictionaries/hyph_en_GB.dic
-share/sigil/dictionaries/hyph_en_US.dic
-share/sigil/dictionaries/hyph_es.dic
-share/sigil/dictionaries/hyph_fr.dic
+share/sigil/examples/clip_entries.ini
+share/sigil/examples/search_entries.ini
+share/sigil/hunspell_dictionaries/About.txt
+share/sigil/hunspell_dictionaries/de_DE.aff
+share/sigil/hunspell_dictionaries/de_DE.dic
+share/sigil/hunspell_dictionaries/en_GB.aff
+share/sigil/hunspell_dictionaries/en_GB.dic
+share/sigil/hunspell_dictionaries/en_US.aff
+share/sigil/hunspell_dictionaries/en_US.dic
+share/sigil/hunspell_dictionaries/es.aff
+share/sigil/hunspell_dictionaries/es.dic
+share/sigil/hunspell_dictionaries/fr.aff
+share/sigil/hunspell_dictionaries/fr.dic
+share/sigil/hunspell_dictionaries/hyph_de_DE.dic
+share/sigil/hunspell_dictionaries/hyph_en_GB.dic
+share/sigil/hunspell_dictionaries/hyph_en_US.dic
+share/sigil/hunspell_dictionaries/hyph_es.dic
+share/sigil/hunspell_dictionaries/hyph_fr.dic
share/sigil/translations/sigil_cs.qm
share/sigil/translations/sigil_da_DK.qm
share/sigil/translations/sigil_de.qm
+share/sigil/translations/sigil_el_GR.qm
share/sigil/translations/sigil_en.qm
share/sigil/translations/sigil_es_ES.qm
share/sigil/translations/sigil_fr.qm
+share/sigil/translations/sigil_gl.qm
+share/sigil/translations/sigil_id_ID.qm
share/sigil/translations/sigil_it.qm
share/sigil/translations/sigil_ja.qm
+share/sigil/translations/sigil_km.qm
+share/sigil/translations/sigil_ko.qm
share/sigil/translations/sigil_nl.qm
share/sigil/translations/sigil_pl.qm
share/sigil/translations/sigil_pt_BR.qm
+share/sigil/translations/sigil_ro_RO.qm
share/sigil/translations/sigil_ru.qm
share/sigil/translations/sigil_sk.qm
share/sigil/translations/sigil_tr_TR.qm
+share/sigil/translations/sigil_ug.qm
share/sigil/translations/sigil_zh_CN.qm
share/sigil/translations/sigil_zh_TW.qm
@dirrm share/sigil/translations
-@dirrm share/sigil/dictionaries
+@dirrm share/sigil/hunspell_dictionaries
+@dirrm share/sigil/examples
@dirrm share/sigil
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || :
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || :