aboutsummaryrefslogtreecommitdiff
path: root/textproc/skim
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-08-09 17:56:59 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-08-09 17:56:59 +0000
commitacd8f434602ba885f77b585ea727af35dc624714 (patch)
treeab55db0ba665ee03b97153179050df643e9f9cf3 /textproc/skim
parentd333ea0903bcc1265c7072db41dc5176b4f61fa5 (diff)
downloadports-acd8f434602ba885f77b585ea727af35dc624714.tar.gz
ports-acd8f434602ba885f77b585ea727af35dc624714.zip
Notes
Diffstat (limited to 'textproc/skim')
-rw-r--r--textproc/skim/Makefile7
-rw-r--r--textproc/skim/distinfo4
-rw-r--r--textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp23
3 files changed, 6 insertions, 28 deletions
diff --git a/textproc/skim/Makefile b/textproc/skim/Makefile
index a9efd7b8195f..4d14e35f597b 100644
--- a/textproc/skim/Makefile
+++ b/textproc/skim/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= skim
-PORTVERSION= 0.9.3
-PORTREVISION= 1
+PORTVERSION= 0.9.4
CATEGORIES= textproc kde
-MASTER_SITES= http://freedesktop.org/~cougar/skim/downloads/
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://freedesktop.org/~cougar/skim/downloads/
+MASTER_SITE_SUBDIR= scim
MAINTAINER= gaoj@cpsc.ucalgary.ca
COMMENT= An input method platform based on SCIM library and KDE/QT
diff --git a/textproc/skim/distinfo b/textproc/skim/distinfo
index 5345cd8a5a45..33b0b74e7bef 100644
--- a/textproc/skim/distinfo
+++ b/textproc/skim/distinfo
@@ -1,2 +1,2 @@
-MD5 (skim-0.9.3.tar.gz) = e3dd8d58262fdd379e9921ab384051b0
-SIZE (skim-0.9.3.tar.gz) = 876274
+MD5 (skim-0.9.4.tar.gz) = b871c1feabb99fabcb0f1bd4e2846ba9
+SIZE (skim-0.9.4.tar.gz) = 879325
diff --git a/textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp b/textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp
deleted file mode 100644
index 41dcd96d59e1..000000000000
--- a/textproc/skim/files/patch-plugins-scimlauncher-scimlauncher.cpp
+++ /dev/null
@@ -1,23 +0,0 @@
---- plugins/scimlauncher/scimlauncher.cpp~ Sun Jul 11 06:19:13 2004
-+++ plugins/scimlauncher/scimlauncher.cpp Wed Jul 21 15:32:13 2004
-@@ -31,6 +31,20 @@
- K_EXPORT_COMPONENT_FACTORY( skimplugin_scim,
- KGenericFactory<ScimLauncher>( "skimplugin_scim" ) );
-
-+char* mystrndup (const char* s, size_t n){
-+ size_t len=strlen(s);
-+ if(len>n)
-+ len=n;
-+ char* newc=(char*)malloc(len+1);
-+
-+ if (newc==NULL)
-+ return NULL;
-+
-+ newc[len] = '\0';
-+ return (char *)memcpy(newc, s, len);
-+}
-+#define strndup mystrndup
-+
- ScimThread::ScimThread(QString _args)
- {
- args = "skim " + _args;