aboutsummaryrefslogtreecommitdiff
path: root/textproc/skribe/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-12-30 09:03:05 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-12-30 09:03:05 +0000
commitc7ec907e8ba7fc47f819f644e0c685e60a5d7468 (patch)
treea90b8a2ce70a19741b3694deab56aeeb6ca87ff0 /textproc/skribe/Makefile
parent58f23dcd2031e6ae608c7582cea2409dc3c9e622 (diff)
Notes
Diffstat (limited to 'textproc/skribe/Makefile')
-rw-r--r--textproc/skribe/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/textproc/skribe/Makefile b/textproc/skribe/Makefile
new file mode 100644
index 000000000000..bff595d7a9a2
--- /dev/null
+++ b/textproc/skribe/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Skribe
+# Date created: 19 December 2003
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= skribe
+PORTVERSION= 1.0a
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp-sop.inria.fr/mimosa/fp/Skribe/
+DISTNAME= ${PORTNAME}${PORTVERSION}
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= A highly programmable document processing system
+
+BUILD_DEPENDS= bigloo:${PORTSDIR}/lang/bigloo
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_REINPLACE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= --with-bigloo --prefix=${PREFIX} --docdir=${DOCSDIR}
+USE_GMAKE= yes
+PLIST_SUB= VERSION="${PORTVERSION}"
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|^function ||' ${WRKSRC}/etc/skribe-config.in
+ ${REINPLACE_CMD} -e 's|$$prefix/doc/skribe-$$release|${DOCSDIR}|' \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's|.*prcs.*|beta=|' ${WRKSRC}/etc/bigloo/configure
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e 's/= doc/=/' ${WRKSRC}/Makefile
+.endif
+
+post-build:
+ ${CHMOD} a+r ${WRKSRC}/doc/html/img/*.gif
+
+post-install:
+ ${TOUCH} ${DATADIR}/extensions/.keep_me
+
+.include <bsd.port.mk>