aboutsummaryrefslogtreecommitdiff
path: root/textproc/smartdoc
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-02-05 03:45:32 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-02-05 03:45:32 +0000
commit9dce94ea1ca6f8b2f71aa29048464d8f1d0f5870 (patch)
treed479d7f38556248e2ab65e9bfbabae32025156e0 /textproc/smartdoc
parent200b9a17a40593cfcdd77ad64ceceac04737ecc9 (diff)
downloadports-9dce94ea1ca6f8b2f71aa29048464d8f1d0f5870.tar.gz
ports-9dce94ea1ca6f8b2f71aa29048464d8f1d0f5870.zip
Notes
Diffstat (limited to 'textproc/smartdoc')
-rw-r--r--textproc/smartdoc/Makefile40
-rw-r--r--textproc/smartdoc/files/sdoc.in12
-rw-r--r--textproc/smartdoc/files/sdoc.sh.in5
-rw-r--r--textproc/smartdoc/pkg-plist244
-rw-r--r--textproc/smartdoc/scripts/configure5
5 files changed, 35 insertions, 271 deletions
diff --git a/textproc/smartdoc/Makefile b/textproc/smartdoc/Makefile
index 972f29646c4f..1fb0a308663f 100644
--- a/textproc/smartdoc/Makefile
+++ b/textproc/smartdoc/Makefile
@@ -17,50 +17,48 @@ COMMENT= XML utility to create various documents
BUILD_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog \
- javavm:${PORTSDIR}/java/javavmwrapper
+ java:${PORTSDIR}/java/javavmwrapper
-SCRIPTS_ENV= JAVALIBDIR=${JAVALIBDIR}
WRKSRC= ${WRKDIR}/sdoc
NO_BUILD= yes
USE_ZIP= yes
-USE_PERL5_BUILD=yes
-USE_JAVA= 1.2+
-JAVA_EXTRACT= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+JAVA_EXTRACT= jre
+JAVA_RUN= jre
EXTRACT_CMD= ${JAVA}
EXTRACT_BEFORE_ARGS= -jar ${DISTDIR}/${DIST_SUBDIR}/${DISTFILES} \
-batch -bindir:${WRKSRC}/bin -installbasedir:${WRKSRC}
EXTRACT_AFTER_ARGS= #
-JAVALIBDIR= ${PREFIX}/share/java
XMLDIR= ${PREFIX}/share/xml
EMACSLISPDIR= ${LOCALBASE}/share/emacs/site-lisp
XEMACSLISPDIR= ${LOCALBASE}/lib/xemacs/site-lisp
DTDDIR= ${XMLDIR}/${PORTNAME}
MKCATALOG= ${LOCALBASE}/sbin/mkcatalog
-DOCS= COPYING.txt OroLICENSE.txt README README.sdoc \
+.if !defined(NOPORTDOCS)
+PORTDOCS= COPYING.txt OroLICENSE.txt README README.sdoc \
README_en.html README_ja.html \
- XalanLICENSE.txt XercesLICENSE.txt
+ XalanLICENSE.txt XercesLICENSE.txt doc
+.endif
JARS= SmartDoc.jar
ELISPS= sdoc-helper.el sdoc-mode.el
-post-extract:
- ${MKDIR} ${WRKSRC}/bin
- ${CP} ${FILESDIR}/sdoc.in ${WRKSRC}/bin/sdoc
+SUB_FILES= sdoc.sh
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/bin/sdoc ${PREFIX}/bin
- ${MKDIR} ${JAVALIBDIR}/classes
+ ${INSTALL_SCRIPT} ${WRKDIR}/sdoc.sh ${PREFIX}/bin/sdoc
+ ${MKDIR} ${JAVAJARDIR}
.for jar in ${JARS}
- ${INSTALL_DATA} ${WRKSRC}/${jar} ${JAVALIBDIR}/classes
+ ${INSTALL_DATA} ${WRKSRC}/${jar} ${JAVAJARDIR}
.endfor
- ${MKDIR} ${EXAMPLESDIR}
- ${CP} -R ${WRKSRC}/etc/* ${EXAMPLESDIR}
+ cd ${WRKSRC}/etc \
+ && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} \;
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for doc in ${DOCS}
- ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
-.endfor
- ${CP} -R ${WRKSRC}/doc ${DOCSDIR}
+ cd ${WRKSRC} \
+ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \; \
+ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
.endif
${MKDIR} ${DTDDIR} ${EMACSLISPDIR} ${XEMACSLISPDIR}
${INSTALL_DATA} ${FILESDIR}/catalog ${DTDDIR}
diff --git a/textproc/smartdoc/files/sdoc.in b/textproc/smartdoc/files/sdoc.in
deleted file mode 100644
index 048013019a1b..000000000000
--- a/textproc/smartdoc/files/sdoc.in
+++ /dev/null
@@ -1,12 +0,0 @@
-#! /bin/sh
-
-INSTALLDIR=%%JAVALIBDIR%%/classes
-JAVA_VERSION=`javavm -version 2>&1 | grep "^java.* version" | sed -e 's/^.* version "\([0-9]*\.[0-9]*\)\..*"$/\1/'`
-
-if [ "$JAVA_VERSION" = '1.1' ]; then
- echo "SmartDoc requires Java newer than 1.2."
- echo "Fix %%LOCALBASE%%/etc/javavms properly, or set the environment variable JAVAVM to a correct JavaVM."
- exit 1
-fi
-
-exec javavm -jar $INSTALLDIR/SmartDoc.jar $*
diff --git a/textproc/smartdoc/files/sdoc.sh.in b/textproc/smartdoc/files/sdoc.sh.in
new file mode 100644
index 000000000000..575899322bf1
--- /dev/null
+++ b/textproc/smartdoc/files/sdoc.sh.in
@@ -0,0 +1,5 @@
+#! /bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="1.2+" "%%LOCALBASE%%/bin/java" -jar "%%JAVAJARDIR%%/SmartDoc.jar" "$@"
diff --git a/textproc/smartdoc/pkg-plist b/textproc/smartdoc/pkg-plist
index b15a0d9a9088..1b51618dbc73 100644
--- a/textproc/smartdoc/pkg-plist
+++ b/textproc/smartdoc/pkg-plist
@@ -3,242 +3,20 @@ lib/xemacs/site-lisp/sdoc-helper.el
lib/xemacs/site-lisp/sdoc-mode.el
share/emacs/site-lisp/sdoc-helper.el
share/emacs/site-lisp/sdoc-mode.el
-share/java/classes/SmartDoc.jar
-%%PORTDOCS%%share/doc/smartdoc/COPYING.txt
-%%PORTDOCS%%share/doc/smartdoc/OroLICENSE.txt
-%%PORTDOCS%%share/doc/smartdoc/README
-%%PORTDOCS%%share/doc/smartdoc/README.sdoc
-%%PORTDOCS%%share/doc/smartdoc/README_en.html
-%%PORTDOCS%%share/doc/smartdoc/README_ja.html
-%%PORTDOCS%%share/doc/smartdoc/XalanLICENSE.txt
-%%PORTDOCS%%share/doc/smartdoc/XercesLICENSE.txt
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/Dl.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/Figure.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/HelloWorld.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/HelloWorld_ja.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/NaturalP.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/Ol.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/P.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/Sample.java
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/Sample.java.cdata
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/Sample.java.escape
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/SmartDoc.properties
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/TableBasic.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/TableCSV.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/TreeTable.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/Ul.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/figure.eps
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/figure.gif
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/quick.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/quick/sample.console
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/README.euc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/README.sjis
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/SmartDoc.properties
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/adapter.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/bibElement.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/command.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/commonAttr.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/documentElement.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/html3.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/html4.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/index.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/javahelp.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/latex2e.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/normalizer.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/plain.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/pure.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/revised.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/autoimage.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/bean/sample.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/csv.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/intro.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/jdbc/jdbc.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/none.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/sdoc.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/stable.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/text.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/xslt/conv.xsl
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/xslt/data.xml
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/adapter/xslt/sample.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/article.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/author.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/bibliography.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/bibliopole.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/book.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/edition.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/editor.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/journal.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/month.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/number.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/pages.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/publisher.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/subtitle.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/title.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/uri.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/volume.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/bib/year.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/command/locale.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/command/localeEn.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/command/localeJa.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/adapter.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/class.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/format.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/id.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/idref.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/key.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/locale.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/normalizer.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/src.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/style.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/title.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/xmllang.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/commonAttr/xmlspace.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/a.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/abbr.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/acronym.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/appendix.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/attribute.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/b.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/blockquote.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/body.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/chapter.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/cite.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/code.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/col.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/colgroup.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/console.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dd.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dfn.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/div.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dl.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/doc.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/dt.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/em.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/equation.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/figure.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/fyi.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/head.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/head2.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/i.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/img.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/index.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/kbd.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/li.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/native.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/note.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/ol.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/p.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/part.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/pre.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/program.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/q.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/samp.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/section.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/span.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/strong.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/subsection.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/subsubsection.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/table.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tbody.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/td.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tfoot.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/th.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/thead.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/title.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tnote.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tr.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/tt.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/ul.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/element/var.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/hello/HelloWorld.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/hello/HelloWorld_ja.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/intro/demo.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/console.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/csv.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/href.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/image.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/javasrc.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/line.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/natural.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/naturallabel.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/none.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/program.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/regex.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/space.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/tag.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/normalizer/tex.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/plain/sample.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/plain/sample_ascii.txt
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/plain/sample_jis.txt
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/attr.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/block.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/framework.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/head.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/image.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/index.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/link.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/list.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/logical.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/math.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/note.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/program.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/quote.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/special.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/table.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/src/structure/text.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/refman/structure.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/Sample.java
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/SmartDoc.properties.dvi2ps
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/SmartDoc.properties.dvips
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/figure.eps
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/figure.gif
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/html.html
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/latex.tex
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/sample.console
-%%PORTDOCS%%share/doc/smartdoc/doc/sample/sample.sdoc
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/Sample.java
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/SmartDoc.properties.dvi2ps
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/SmartDoc.properties.dvips
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/data.csv
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/figure.eps
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/figure.gif
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/html.html
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/latex.tex
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/sample.console
-%%PORTDOCS%%share/doc/smartdoc/doc/sampleI18N/sample.sdoc
-share/examples/smartdoc/html4/article.css
-share/examples/smartdoc/pure/PureSmartDoc.dtd
-share/examples/smartdoc/pure/PureSmartDoc.rlx
-share/examples/smartdoc/pure/article.css
-share/examples/smartdoc/sdoc-helper.el
-share/examples/smartdoc/sdoc-mode.el
-share/examples/smartdoc/sdoc2html.xsl
+%%JAVAJARDIR%%/SmartDoc.jar
+%%EXAMPLESDIR%%/html4/article.css
+%%EXAMPLESDIR%%/pure/PureSmartDoc.dtd
+%%EXAMPLESDIR%%/pure/PureSmartDoc.rlx
+%%EXAMPLESDIR%%/pure/article.css
+%%EXAMPLESDIR%%/sdoc-helper.el
+%%EXAMPLESDIR%%/sdoc-mode.el
+%%EXAMPLESDIR%%/sdoc2html.xsl
share/xml/catalog
share/xml/smartdoc/PureSmartDoc.dtd
share/xml/smartdoc/catalog
@unexec rmdir %D/lib/xemacs/site-lisp 2>/dev/null || true
@unexec rmdir %D/lib/xemacs 2>/dev/null || true
@dirrm share/xml/smartdoc
-@dirrm share/examples/smartdoc/pure
-@dirrm share/examples/smartdoc/html4
-@dirrm share/examples/smartdoc
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/sampleI18N
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/sample
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/structure
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/plain
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/normalizer
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/intro
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/hello
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/element
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/commonAttr
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/command
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/bib
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter/xslt
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter/jdbc
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter/bean
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src/adapter
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman/src
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/refman
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc/quick
-%%PORTDOCS%%@dirrm share/doc/smartdoc/doc
-%%PORTDOCS%%@dirrm share/doc/smartdoc
+@dirrm %%EXAMPLESDIR%%/pure
+@dirrm %%EXAMPLESDIR%%/html4
+@dirrm %%EXAMPLESDIR%%
diff --git a/textproc/smartdoc/scripts/configure b/textproc/smartdoc/scripts/configure
deleted file mode 100644
index a2703a536bda..000000000000
--- a/textproc/smartdoc/scripts/configure
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-
-export JAVALIBDIR
-
-perl -pi -e 's|%%JAVALIBDIR%%|$ENV{JAVALIBDIR}|g;s|%%LOCALBASE%%|$ENV{LOCALBASE}|g;' ${WRKSRC}/bin/sdoc