aboutsummaryrefslogtreecommitdiff
path: root/textproc/source-highlight
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2009-01-03 14:53:14 +0000
committerKevin Lo <kevlo@FreeBSD.org>2009-01-03 14:53:14 +0000
commit79c6e2ccda6d61040687684ac2758ec7746f973d (patch)
treec2cdaf24f39a527c2392169fe978cff83e00cab3 /textproc/source-highlight
parente54c3adf4ceadcb116771eb2c2b3765dce01fc1d (diff)
downloadports-79c6e2ccda6d61040687684ac2758ec7746f973d.tar.gz
ports-79c6e2ccda6d61040687684ac2758ec7746f973d.zip
Notes
Diffstat (limited to 'textproc/source-highlight')
-rw-r--r--textproc/source-highlight/Makefile15
-rw-r--r--textproc/source-highlight/distinfo6
-rw-r--r--textproc/source-highlight/pkg-plist9
3 files changed, 24 insertions, 6 deletions
diff --git a/textproc/source-highlight/Makefile b/textproc/source-highlight/Makefile
index c815250d4ca1..bd2d54f2472a 100644
--- a/textproc/source-highlight/Makefile
+++ b/textproc/source-highlight/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= source-highlight
-PORTVERSION= 2.10
+PORTVERSION= 2.11.1
PORTREVISION= 0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -19,7 +19,7 @@ BUILD_DEPENDS= exctags:${PORTSDIR}/devel/ctags
LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= LDFLAGS=-L${LOCALBASE}/lib CPPFLAGS=-I${LOCALBASE}/include
+CONFIGURE_ARGS= LDFLAGS=-L${LOCALBASE}/lib CPPFLAGS=-I${LOCALBASE}/include
.if defined(NOPORTDOCS)
MAKE_ENV+= NOPORTDOCS="${NOPORTDOCS}"
.endif
@@ -29,6 +29,8 @@ USE_GMAKE= yes
MAN1= source-highlight.1 check-regexp.1
INFO= source-highlight
+OPTIONS= BASH "Support Bash completion" Off
+
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700042
@@ -37,4 +39,13 @@ BROKEN= Does not compile with GCC 4.2
.endif
.endif
+.if defined(WITH_BASH)
+RUN_DEPENDS+= ${LOCALBASE}/etc/bash_completion:${PORTSDIR}/shells/bash-completion
+CONFIGURE_ARGS+= --with-bash-completion
+PLIST_SUB+= BASH=""
+.else
+CONFIGURE_ARGS+= --without-bash-completion
+PLIST_SUB+= BASH="@comment "
+.endif
+
.include <bsd.port.post.mk>
diff --git a/textproc/source-highlight/distinfo b/textproc/source-highlight/distinfo
index 8ad89c535f7c..556001a2ea3f 100644
--- a/textproc/source-highlight/distinfo
+++ b/textproc/source-highlight/distinfo
@@ -1,3 +1,3 @@
-MD5 (source-highlight-2.10.tar.gz) = 03e9cf03580873b76ca0a89f0468b146
-SHA256 (source-highlight-2.10.tar.gz) = 68043250d6fb9761545d5f09b7899b25436fcd38f4b81c63b0ab2a3a6e3fe6a6
-SIZE (source-highlight-2.10.tar.gz) = 1202087
+MD5 (source-highlight-2.11.1.tar.gz) = f6e332317413f247ce248c52df0ddade
+SHA256 (source-highlight-2.11.1.tar.gz) = 5a18c2e8d1baf3aadd7abe51d646351f99f80ce8ed8dd132128467eb925a9a47
+SIZE (source-highlight-2.11.1.tar.gz) = 1282485
diff --git a/textproc/source-highlight/pkg-plist b/textproc/source-highlight/pkg-plist
index 20ef10fc892b..cb2201628d14 100644
--- a/textproc/source-highlight/pkg-plist
+++ b/textproc/source-highlight/pkg-plist
@@ -3,6 +3,7 @@ bin/cpp2html
bin/java2html
bin/source-highlight
bin/src-hilite-lesspipe.sh
+%%BASH%%etc/bash_completion.d/source-highlight-bash-completion
%%DOCSDIR%%/COPYING
%%DOCSDIR%%/CREDITS
%%DOCSDIR%%/ChangeLog
@@ -32,8 +33,8 @@ bin/src-hilite-lesspipe.sh
%%DOCSDIR%%/UsageExample.java
%%DOCSDIR%%/access.log.html
%%DOCSDIR%%/auth.log.html
-%%DOCSDIR%%/cmdline.h.html
%%DOCSDIR%%/c.lang.html
+%%DOCSDIR%%/cmdline.h.html
%%DOCSDIR%%/colors.html
%%DOCSDIR%%/cpp2html.css
%%DOCSDIR%%/default.css
@@ -103,9 +104,11 @@ bin/src-hilite-lesspipe.sh
%%DOCSDIR%%/test.py.html
%%DOCSDIR%%/test.rb.html
%%DOCSDIR%%/test.sml.html
+%%DOCSDIR%%/test_linerange_sep.html
%%DOCSDIR%%/test_refs.cpp.html
%%DOCSDIR%%/test_refs.h.html
%%DOCSDIR%%/xhtml.css
+%%DATADIR%%/ada.lang
%%DATADIR%%/bib.lang
%%DATADIR%%/bison.lang
%%DATADIR%%/c.lang
@@ -113,6 +116,7 @@ bin/src-hilite-lesspipe.sh
%%DATADIR%%/c_string.lang
%%DATADIR%%/caml.lang
%%DATADIR%%/changelog.lang
+%%DATADIR%%/clike_vardeclaration.lang
%%DATADIR%%/cpp.lang
%%DATADIR%%/csharp.lang
%%DATADIR%%/css.lang
@@ -170,6 +174,7 @@ bin/src-hilite-lesspipe.sh
%%DATADIR%%/properties.lang
%%DATADIR%%/python.lang
%%DATADIR%%/ruby.lang
+%%DATADIR%%/scala.lang
%%DATADIR%%/script_comment.lang
%%DATADIR%%/sh.lang
%%DATADIR%%/slang.lang
@@ -191,5 +196,7 @@ bin/src-hilite-lesspipe.sh
%%DATADIR%%/xhtmlcss.outlang
%%DATADIR%%/xhtmltable.outlang
%%DATADIR%%/xml.lang
+%%DATADIR%%/xorg.lang
@dirrm %%DATADIR%%
@dirrm %%DOCSDIR%%
+%%BASH%%@dirrmtry etc/bash_completion.d