aboutsummaryrefslogtreecommitdiff
path: root/textproc/sp
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2004-02-08 11:20:10 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2004-02-08 11:20:10 +0000
commit1fd2e41e3c00fd9ab2280054bd1275047e63f5fa (patch)
tree82c8b39c316eac5581ffcfb5158ffa66e055b146 /textproc/sp
parent597ef208e925ef1b1e2b47ca40c68c8ed7a0818d (diff)
Notes
Diffstat (limited to 'textproc/sp')
-rw-r--r--textproc/sp/Makefile29
-rw-r--r--textproc/sp/pkg-plist22
2 files changed, 17 insertions, 34 deletions
diff --git a/textproc/sp/Makefile b/textproc/sp/Makefile
index cc59acd9b38c..82635e05eac2 100644
--- a/textproc/sp/Makefile
+++ b/textproc/sp/Makefile
@@ -13,24 +13,29 @@ MASTER_SITES= ftp://ftp.jclark.com/pub/sp/
MAINTAINER= ports@FreeBSD.org
COMMENT= An object-oriented toolkit for SGML parsing and entity management
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
.if ${MACHINE_ARCH} == sparc64
BROKEN= does not compile on ${MACHINE_ARCH}
.endif
USE_SUBMAKE= yes
INSTALLS_SHLIB= yes
+USE_GCC= 2.95
+USE_REINPLACE= yes
+PORTDOCS= Makefile archform.htm build.htm catalog catalog.htm \
+ charset.htm features.htm generic.htm ideas.htm index.htm \
+ new.htm nsgmls.htm sgmldecl.htm sgmlnorm.htm sgmlsout.htm \
+ spam.htm spent.htm sx.htm sysdecl.htm sysid.htm xml.htm
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,=/usr/local,=${PREFIX},g' ${WRKSRC}/Makefile*
post-install:
- $(MKDIR) $(PREFIX)/include/sp
- $(MKDIR) $(PREFIX)/share/doc/sp
- $(RM) -f $(WRKSRC)/include/*.orig
- for file in $(WRKSRC)/include/*;do $(INSTALL_DATA) $$file $(PREFIX)/include/sp;done
- for file in $(WRKSRC)/doc/*;do $(INSTALL_DATA) $$file $(PREFIX)/share/doc/sp;done
+ ${MKDIR} ${PREFIX}/include/sp
+ ${RM} -f ${WRKSRC}/include/*.orig
+ for f in ${WRKSRC}/include/*;do ${INSTALL_DATA} $$f ${PREFIX}/include/sp;done
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC}/doc && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/sp/pkg-plist b/textproc/sp/pkg-plist
index 65a9c3711ee0..ea55cf09db27 100644
--- a/textproc/sp/pkg-plist
+++ b/textproc/sp/pkg-plist
@@ -142,26 +142,4 @@ include/sp/xnew.h
lib/libsp.a
lib/libsp.so.1
@comment lib/libsp.so.1.4
-share/doc/sp/Makefile
-share/doc/sp/archform.htm
-share/doc/sp/build.htm
-share/doc/sp/catalog
-share/doc/sp/catalog.htm
-share/doc/sp/charset.htm
-share/doc/sp/features.htm
-share/doc/sp/generic.htm
-share/doc/sp/ideas.htm
-share/doc/sp/index.htm
-share/doc/sp/new.htm
-share/doc/sp/nsgmls.htm
-share/doc/sp/sgmldecl.htm
-share/doc/sp/sgmlnorm.htm
-share/doc/sp/sgmlsout.htm
-share/doc/sp/spam.htm
-share/doc/sp/spent.htm
-share/doc/sp/sx.htm
-share/doc/sp/sysdecl.htm
-share/doc/sp/sysid.htm
-share/doc/sp/xml.htm
@dirrm include/sp
-@dirrm share/doc/sp