aboutsummaryrefslogtreecommitdiff
path: root/textproc/sphinxsearch
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-07-16 13:31:51 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-07-16 13:31:51 +0000
commit08f4cb8b20e35ff75cdbb9215cd72d83e0ace2aa (patch)
tree774a3b0389b083a81fe52f52dccfcce696887a58 /textproc/sphinxsearch
parent15b84a382d0beda76802a14d67104c5c57d7469f (diff)
downloadports-08f4cb8b20e35ff75cdbb9215cd72d83e0ace2aa.tar.gz
ports-08f4cb8b20e35ff75cdbb9215cd72d83e0ace2aa.zip
Notes
Diffstat (limited to 'textproc/sphinxsearch')
-rw-r--r--textproc/sphinxsearch/Makefile21
-rw-r--r--textproc/sphinxsearch/distinfo6
-rw-r--r--textproc/sphinxsearch/files/patch-src-sphinxsearch.h13
-rw-r--r--textproc/sphinxsearch/pkg-plist5
4 files changed, 19 insertions, 26 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index bbeace4fc5c5..b2e453c57155 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -8,8 +8,7 @@
# this port. You need a patched version of mysql server for that.
PORTNAME= sphinxsearch
-PORTVERSION= 0.9.7
-PORTREVISION= 1
+PORTVERSION= 0.9.8
CATEGORIES= textproc databases
MASTER_SITES= http://www.sphinxsearch.com/downloads/
DISTNAME= sphinx-${PORTVERSION}
@@ -21,6 +20,7 @@ CONFLICTS= sphinxsearch-devel-[0-9]*
OPTIONS= MYSQL "MySQL support" on \
PGSQL "PostgreSQL support" off \
+ ICONV "Iconv support" on \
OPTIMIZED_CFLAGS "Use compiler optimization (-O3)" off
SPHINX_USR?= _sphinx
@@ -50,8 +50,12 @@ SUB_LIST+= PORTNAME=${PORTNAME} \
SPHINX_LOG=${SPHINX_LOG}
SUB_FILES+= pkg-install pkg-deinstall
+.if !defined(NOPORTEXAMPLES)
+EXAMPLES= example.sql api
+PORTEXAMPLES= *
+.endif
+
.if !defined(NOPORTDOCS)
-EXAMPLES= example.sql api/sphinxapi.php api/test.php api/test2.php
DOCS= doc/sphinx.css doc/sphinx.html doc/sphinx.txt doc/sphinx.xml
.endif
@@ -74,6 +78,13 @@ USE_PGSQL= yes
CONFIGURE_ARGS+= --without-pgsql
.endif
+.if defined(WITH_ICONV) && !defined(WITHOUT_ICONV)
+CONFIGURE_ARGS+= --with-iconv
+USE_ICONV= yes
+.else
+CONFIGURE_ARGS+= --without-iconv
+.endif
+
.if defined(WITH_OPTIMIZED_CFLAGS)
CXXFLAGS+= -O3 -fomit-frame-pointer
.endif
@@ -108,10 +119,10 @@ install-docs:
.endif
install-examples:
-.if !defined(NOPORTDOCS)
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
.for example in ${EXAMPLES}
- ${INSTALL_DATA} ${WRKSRC}/${example} ${EXAMPLESDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} ${example} ${EXAMPLESDIR}
.endfor
.endif
diff --git a/textproc/sphinxsearch/distinfo b/textproc/sphinxsearch/distinfo
index 95e6db3a44f0..c5d07cec6aba 100644
--- a/textproc/sphinxsearch/distinfo
+++ b/textproc/sphinxsearch/distinfo
@@ -1,3 +1,3 @@
-MD5 (sphinx-0.9.7.tar.gz) = 32f2b7e98d8485c86108851d52c5cef4
-SHA256 (sphinx-0.9.7.tar.gz) = 6c841b9042f880394858dd0373a1e3343c30e815422671ba3872691326c1c0a4
-SIZE (sphinx-0.9.7.tar.gz) = 344500
+MD5 (sphinx-0.9.8.tar.gz) = 347e547b79b733778d7553ede34e0aac
+SHA256 (sphinx-0.9.8.tar.gz) = 86de861550fc7b119b3cbe63a34bad32ac771f44c930d229775ac124c83571d9
+SIZE (sphinx-0.9.8.tar.gz) = 728864
diff --git a/textproc/sphinxsearch/files/patch-src-sphinxsearch.h b/textproc/sphinxsearch/files/patch-src-sphinxsearch.h
deleted file mode 100644
index b1da5d68c74f..000000000000
--- a/textproc/sphinxsearch/files/patch-src-sphinxsearch.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/sphinxstd.h.orig Tue May 29 19:50:47 2007
-+++ src/sphinxstd.h Tue May 29 19:52:23 2007
-@@ -57,9 +57,7 @@
- #error "Internal 64-bit integer macros already defined."
- #endif
-
--#if __STDC_VERSION__>=199901L || __STDC_VERSION>=199901L || defined(_STDINT_H) || defined(_STDINT_H_)
--#include <stdint.h>
--#else // no stdint.h
-+#if !HAVE_STDINT_H
-
- #if defined(_MSC_VER)
- typedef __int64 int64_t;
diff --git a/textproc/sphinxsearch/pkg-plist b/textproc/sphinxsearch/pkg-plist
index 72eeabf7f437..6b70ba9ab41b 100644
--- a/textproc/sphinxsearch/pkg-plist
+++ b/textproc/sphinxsearch/pkg-plist
@@ -8,9 +8,4 @@ etc/sphinx.conf.sample
%%PORTDOCS%%%%DOCSDIR%%/sphinx.html
%%PORTDOCS%%%%DOCSDIR%%/sphinx.txt
%%PORTDOCS%%%%DOCSDIR%%/sphinx.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/example.sql
-%%PORTDOCS%%%%EXAMPLESDIR%%/sphinxapi.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/test.php
-%%PORTDOCS%%%%EXAMPLESDIR%%/test2.php
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%