aboutsummaryrefslogtreecommitdiff
path: root/textproc/sphinxsearch
diff options
context:
space:
mode:
authorMatthew Seaman <matthew@FreeBSD.org>2012-12-30 10:14:51 +0000
committerMatthew Seaman <matthew@FreeBSD.org>2012-12-30 10:14:51 +0000
commitf2003b5ee6837baf5b03a741a4f33101b813478a (patch)
tree8c39ce10540338758d8045aa692593df646b9289 /textproc/sphinxsearch
parentc1a9f352a6dec7c95407ee6b854e75723f07c28b (diff)
downloadports-f2003b5ee6837baf5b03a741a4f33101b813478a.tar.gz
ports-f2003b5ee6837baf5b03a741a4f33101b813478a.zip
Notes
Diffstat (limited to 'textproc/sphinxsearch')
-rw-r--r--textproc/sphinxsearch/Makefile36
-rw-r--r--textproc/sphinxsearch/pkg-plist1
2 files changed, 30 insertions, 7 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index c7486500f397..7a734eda74a0 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -1,12 +1,13 @@
# Created by: Matthew Seaman
# $FreeBSD$
-#
+
# Note: the Sphinx Storage Engine MySQL plugin is not supported by
# this port. You need a patched version of mysql server for that.
# See http://www.infracaninophile.co.uk/articles/sphinxse.html
PORTNAME= sphinxsearch
PORTVERSION= 2.0.6
+PORTREVISION= 1
CATEGORIES= textproc databases
MASTER_SITES= http://sphinxsearch.com/files/
DISTNAME= sphinx-${PORTVERSION}-release
@@ -23,7 +24,7 @@ LICENSE= GPLv2
LIB_DEPENDS= expat:${PORTSDIR}/textproc/expat2
OPTIONS_DEFINE= ICONV ID64 LIBSTEMMER MYSQL OPTIMIZED_CFLAGS PGSQL \
- SYSLOG UNIXODBC
+ SYSLOG UNIXODBC
#ICONV_DESC= Iconv support
ID64_DESC= use 64-bit document and word IDs
@@ -36,7 +37,7 @@ UNIXODBC_DESC= unixODBC support
OPTIONS_DEFAULT= ICONV MYSQL SYSLOG
-CONFLICTS= sphinxsearch-devel-[0-9]* dpsearch-[0-9]* rdb-2.6d \
+CONFLICTS= sphinxsearch-devel-[0-9]* dpsearch-[0-9]* rdb-[0-9]* \
swish++-[0-9]* xaira-[0-9]*
.include <bsd.port.options.mk>
@@ -150,6 +151,9 @@ PORTEXAMPLES= *
.if ${PORT_OPTIONS:MDOCS}
DOCS= doc/sphinx.css doc/sphinx.html doc/sphinx.txt doc/sphinx.xml
+MAN1= indexer.1 indextool.1 search.1 spelldump.1
+MAN8= searchd.8
+DOCSRC= ${WRKSRC}/doc
.endif
post-extract:
@@ -167,14 +171,22 @@ post-patch:
-e "s!@CONFDIR@/log/searchd.log!${SPHINX_LOG}/searchd.log!" \
-e "s!@CONFDIR@!${SPHINX_DIR}!" \
${WRKSRC}/sphinx.conf.in
+.if ${PORT_OPTIONS:MDOCS}
+ ${SED} -e 's/"1"/"8"/' ${DOCSRC}/searchd.1 > ${DOCSRC}/searchd.8
+.for man in ${MAN1}
+ ${SED} -i~ -e 's/\\fBsearchd\\fR(1)/\\fBsearchd\\fR(8)/' \
+ ${DOCSRC}/${man}
+.endfor
+.endif
-do-install: install-bin install-docs install-examples
+do-install: install-bin install-docs install-man install-examples
install-bin:
- ${INSTALL_PROGRAM} ${WRKSRC}/src/indexer ${PREFIX}/bin/indexer
- ${INSTALL_PROGRAM} ${WRKSRC}/src/search ${PREFIX}/bin/search
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/indexer ${PREFIX}/bin/indexer
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/indextool ${PREFIX}/bin/indextool
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/search ${PREFIX}/bin/search
${INSTALL_PROGRAM} ${WRKSRC}/src/spelldump ${PREFIX}/bin/spelldump
- ${INSTALL_PROGRAM} ${WRKSRC}/src/searchd ${PREFIX}/sbin/searchd
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/searchd ${PREFIX}/sbin/searchd
${INSTALL_DATA} ${WRKSRC}/sphinx.conf.dist ${CFGFILE}.sample
install-docs:
@@ -185,6 +197,16 @@ install-docs:
.endfor
.endif
+install-man:
+.if ${PORT_OPTIONS:MDOCS}
+.for man in ${MAN1}
+ ${INSTALL_MAN} ${DOCSRC}/${man} ${MANPREFIX}/man/man1/${man}
+.endfor
+.for man in ${MAN8}
+ ${INSTALL_MAN} ${DOCSRC}/${man} ${MANPREFIX}/man/man8/${man}
+.endfor
+.endif
+
install-examples:
.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
diff --git a/textproc/sphinxsearch/pkg-plist b/textproc/sphinxsearch/pkg-plist
index 168290911cd9..69e851942acd 100644
--- a/textproc/sphinxsearch/pkg-plist
+++ b/textproc/sphinxsearch/pkg-plist
@@ -1,4 +1,5 @@
bin/indexer
+bin/indextool
bin/search
bin/spelldump
sbin/searchd