aboutsummaryrefslogtreecommitdiff
path: root/textproc/sphinxsearch
diff options
context:
space:
mode:
authorStefan Walter <stefan@FreeBSD.org>2008-10-22 05:33:56 +0000
committerStefan Walter <stefan@FreeBSD.org>2008-10-22 05:33:56 +0000
commitdf4ccc76827094cf4e9bd81dbfa389a4b30f6e47 (patch)
tree7540b36d8117edf55ccb99b174c6220e2dfcd2c4 /textproc/sphinxsearch
parente7ef054e56865f68199b7c8f593eba4dbed3128a (diff)
- Add an ID64 knob to toggle support for 64 bit identifiers in sphinxsearch.
- Force library dependency on expat. The configure script will automatically add expat support if it detects it on the system, and there's no way of overriding that. Means that previously, when installed from a binary package built on the cluster, there was no expat support compiled in, but when compiled from source there frequently would be. Therefore, for consistencies' sake, always depend on expat. PR: 127730 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=221896
Diffstat (limited to 'textproc/sphinxsearch')
-rw-r--r--textproc/sphinxsearch/Makefile43
1 files changed, 39 insertions, 4 deletions
diff --git a/textproc/sphinxsearch/Makefile b/textproc/sphinxsearch/Makefile
index ff359d995071..13b727a33b16 100644
--- a/textproc/sphinxsearch/Makefile
+++ b/textproc/sphinxsearch/Makefile
@@ -6,9 +6,11 @@
#
# Note: the Sphinx Storage Engine MySQL plugin is not supported by
# this port. You need a patched version of mysql server for that.
+# See http://www.infracaninophile.co.uk/articles/sphinxse.html
PORTNAME= sphinxsearch
PORTVERSION= 0.9.8
+PORTREVISION= 1
CATEGORIES= textproc databases
MASTER_SITES= http://www.sphinxsearch.com/downloads/
DISTNAME= sphinx-${PORTVERSION}
@@ -18,10 +20,19 @@ COMMENT= Sphinx Full-Text Search Engine
CONFLICTS= sphinxsearch-devel-[0-9]*
-OPTIONS= MYSQL "MySQL support" on \
- PGSQL "PostgreSQL support" off \
- ICONV "Iconv support" on \
- OPTIMIZED_CFLAGS "Use compiler optimization (-O3)" off
+# If expat is present on the system and configure finds it, it will
+# unconditionally link the output binary against it. There's no way
+# of turning this off. So for consistency, make sure it's always on.
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+OPTIONS= MYSQL "MySQL support" on \
+ PGSQL "PostgreSQL support" off \
+ ICONV "Iconv support" on \
+ OPTIMIZED_CFLAGS "Use compiler optimization (-O3)" off \
+ ID64 "use 64-bit document and word IDs" off
+
+## FFR
+## LIBSTEMMER "compile with libstemmer support" off
SPHINX_USR?= _sphinx
SPHINX_UID?= 312
@@ -88,6 +99,30 @@ CONFIGURE_ARGS+= --without-iconv
CXXFLAGS+= -O3 -fomit-frame-pointer
.endif
+# Changes document and word IDs to a 64bit type, useful if you have
+# more than about 4.2E9 such items to deal with. Means corresponding
+# changes in DB schema. Disabled by default.
+.if defined(WITH_ID64)
+CONFIGURE_ARGS+= --enable-id64
+.endif
+
+## FFR. The snowball project doesn't release numbered versions of it's
+## pre-processors. Instead, at arbitrary intervals a snapshot of their
+## source repository is turned into a tarball (always the same filename)
+## and placed on their web site. It's like they want to make it as hard
+## as possible for anyone to package and use their software.
+##
+## # Adds support for two additional word stemmming pre-processors from
+## # the Snowball project (http://snowball.tartarus.org/) -- these
+## # essentially do exactly the same thing as the built in English and
+## # Russian stemmers but are slightly slower and may produce subtly
+## # different output. Disabled by default.
+## .if defined(WITH_LIBSTEMMER) && !defined(WITHOUT_LIBSTEMMER)
+## CONFIGURE_ARGS+= --with-libstemmer
+## .else
+## CONFIGURE_ARGS+= --without-libstemmer
+## .endif
+
# Fix up the sample configuration file to correspond to FreeBSD norms
post-patch: