aboutsummaryrefslogtreecommitdiff
path: root/textproc/sr-hunspell
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
commit72c08ec487edbe98662f3278bee17f8726ee4ce4 (patch)
treea3c6d7d2a4a492c3e55a418f3fa370e951b5ccc7 /textproc/sr-hunspell
parenta600d4522cadfa512ce465f98566cee7b9bec843 (diff)
downloadports-72c08ec487edbe98662f3278bee17f8726ee4ce4.tar.gz
ports-72c08ec487edbe98662f3278bee17f8726ee4ce4.zip
Notes
Diffstat (limited to 'textproc/sr-hunspell')
-rw-r--r--textproc/sr-hunspell/Makefile27
1 files changed, 14 insertions, 13 deletions
diff --git a/textproc/sr-hunspell/Makefile b/textproc/sr-hunspell/Makefile
index 46ee5bcc4b5f..0f57d86acf0a 100644
--- a/textproc/sr-hunspell/Makefile
+++ b/textproc/sr-hunspell/Makefile
@@ -5,11 +5,13 @@
# $FreeBSD$
#
-PORTNAME= sr-hunspell
+PORTNAME= hunspell
PORTVERSION= 0.18
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_MOZILLA_EXTENDED}
MASTER_SITE_SUBDIR= addons/10894
+PKGNAMEPREFIX= sr-
DISTNAME= serbian_dictionary-${PORTVERSION}-fx+tb+sm
EXTRACT_SUFX= .xpi
@@ -18,20 +20,19 @@ COMMENT= Serbian hunspell dictionaries
USE_ZIP= yes
NO_BUILD= yes
+WRKSRC= ${WRKDIR}/dictionaries
-PLIST_FILES= share/hunspell/sr_YU.aff \
- share/hunspell/sr_YU.dic \
- share/hunspell/sh_YU.aff \
- share/hunspell/sh_YU.dic
-
-PLIST_DIRS= share/hunspell
+PLIST_FILES= %%DATADIR%%/sh_YU.aff \
+ %%DATADIR%%/sh_YU.dic \
+ %%DATADIR%%/sr_YU.aff \
+ %%DATADIR%%/sr_YU.dic
+PLIST_DIRSTRY= %%DATADIR%%
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKDIR}/dictionaries/sr-RS-Cyrl.aff ${PREFIX}/share/hunspell/sr_YU.aff
- @${INSTALL_DATA} ${WRKDIR}/dictionaries/sr-RS-Cyrl.dic ${PREFIX}/share/hunspell/sr_YU.dic
- @${INSTALL_DATA} ${WRKDIR}/dictionaries/sr-RS-Latn.aff ${PREFIX}/share/hunspell/sh_YU.aff
- @${INSTALL_DATA} ${WRKDIR}/dictionaries/sr-RS-Latn.dic ${PREFIX}/share/hunspell/sh_YU.dic
-
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/sr-RS-Latn.aff ${DATADIR}/sh_YU.aff
+ ${INSTALL_DATA} ${WRKSRC}/sr-RS-Latn.dic ${DATADIR}/sh_YU.dic
+ ${INSTALL_DATA} ${WRKSRC}/sr-RS-Cyrl.aff ${DATADIR}/sr_YU.aff
+ ${INSTALL_DATA} ${WRKSRC}/sr-RS-Cyrl.dic ${DATADIR}/sr_YU.dic
.include <bsd.port.mk>