aboutsummaryrefslogtreecommitdiff
path: root/textproc/srilm
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2014-09-15 09:04:02 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2014-09-15 09:04:02 +0000
commit3550b8b9fd4a9d1e052590da54294e3c8445a436 (patch)
tree41a0b7b52c8d2c89d06167972cb22723ff82ba29 /textproc/srilm
parentde284f51e1f0fa59764a9d4172aa53e39ac15c88 (diff)
downloadports-3550b8b9fd4a9d1e052590da54294e3c8445a436.tar.gz
ports-3550b8b9fd4a9d1e052590da54294e3c8445a436.zip
Notes
Diffstat (limited to 'textproc/srilm')
-rw-r--r--textproc/srilm/Makefile1
-rw-r--r--textproc/srilm/files/patch-dstruct-src-Array.h11
2 files changed, 11 insertions, 1 deletions
diff --git a/textproc/srilm/Makefile b/textproc/srilm/Makefile
index 6de3f6f65b7d..558e770f03b1 100644
--- a/textproc/srilm/Makefile
+++ b/textproc/srilm/Makefile
@@ -16,7 +16,6 @@ LIB_DEPENDS= libtcl84.so:${PORTSDIR}/lang/tcl84
DOWNLOAD_URL?= http://www.speech.sri.com/projects/srilm/download.html
USES= gmake
-USE_GCC= yes
MAKE_ENV+= SRILM=${WRKSRC}
ALL_TARGET= World
ONLY_FOR_ARCHS= i386 amd64
diff --git a/textproc/srilm/files/patch-dstruct-src-Array.h b/textproc/srilm/files/patch-dstruct-src-Array.h
new file mode 100644
index 000000000000..08d10253f443
--- /dev/null
+++ b/textproc/srilm/files/patch-dstruct-src-Array.h
@@ -0,0 +1,11 @@
+--- dstruct/src/Array.h.orig 2014-09-02 15:48:38.000000000 +0400
++++ dstruct/src/Array.h 2014-09-02 15:48:57.000000000 +0400
+@@ -89,7 +89,7 @@ public:
+ * gcc and icc allow this as part of the language, but many other C++ compilers
+ * don't (Sun Studio, MS Visual C).
+ */
+-#if !defined(DEBUG) && defined(__GNUC__) && (!defined(__INTEL_COMPILER) || __INTEL_COMPILER >=900)
++#if !defined(DEBUG) && !defined(__clang__) && defined(__GNUC__) && (!defined(__INTEL_COMPILER) || __INTEL_COMPILER >=900)
+ # define makeArray(T, A, n) T A[n]
+ #else
+ # define makeArray(T, A, n) StaticArray<T> A(n)