aboutsummaryrefslogtreecommitdiff
path: root/textproc/srilm
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-07-03 07:31:08 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-07-03 07:31:08 +0000
commitc06662832608780e6571e283d5b21e1a0463bf1e (patch)
treeda915d9909c758b64dcf524bb082987c070eb681 /textproc/srilm
parentdbe3e25f73c7006e1e2746a6ef5a59965f584445 (diff)
downloadports-c06662832608780e6571e283d5b21e1a0463bf1e.tar.gz
ports-c06662832608780e6571e283d5b21e1a0463bf1e.zip
Notes
Diffstat (limited to 'textproc/srilm')
-rw-r--r--textproc/srilm/Makefile6
-rw-r--r--textproc/srilm/distinfo1
-rw-r--r--textproc/srilm/files/patch-lm-src-matherr.c16
3 files changed, 20 insertions, 3 deletions
diff --git a/textproc/srilm/Makefile b/textproc/srilm/Makefile
index adb3d49b1bf9..61c25dbe75ac 100644
--- a/textproc/srilm/Makefile
+++ b/textproc/srilm/Makefile
@@ -22,7 +22,7 @@ USE_GMAKE= yes
MAKE_ENV+= SRILM=${WRKSRC}
ALL_TARGET= World
ONLY_FOR_ARCHS= i386
-NO_PACKAGE= "not yet"
+NO_PACKAGE= not yet
PROGRAMS= ngram ngram-count ngram-merge ngram-class disambig anti-ngram \
nbest-lattice nbest-mix nbest-optimize nbest-pron-score \
@@ -65,8 +65,8 @@ MAN5= ngram-format.5 nbest-format.5 classes-format.5 \
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
ECHO_MSG=/usr/bin/printf
-IGNORE= :\n\
-Because of license document, we suggest you fetch the source distribution\n\
+IGNORE= because of license document, we suggest you fetch the source \
+distribution\n\
manually. Please access ${DOWNLOAD_URL}\n\
, follow the download instructions, download the source\n\
into ${DISTDIR}/, and then run make again.\n
diff --git a/textproc/srilm/distinfo b/textproc/srilm/distinfo
index e2d2174b6259..2c81f3f678fa 100644
--- a/textproc/srilm/distinfo
+++ b/textproc/srilm/distinfo
@@ -1,2 +1,3 @@
MD5 (srilm.tgz) = e0923ac8fcf42c98e9118a705e0a1dd5
+SHA256 (srilm.tgz) = 1965085b968350f035bab948ffcc8cc8fdb40ced73cf3694761fa4cf084aca16
SIZE (srilm.tgz) = 30315385
diff --git a/textproc/srilm/files/patch-lm-src-matherr.c b/textproc/srilm/files/patch-lm-src-matherr.c
new file mode 100644
index 000000000000..d4174d7c68b2
--- /dev/null
+++ b/textproc/srilm/files/patch-lm-src-matherr.c
@@ -0,0 +1,16 @@
+--- lm/src/matherr.c.orig Fri Jul 29 11:29:51 2005
++++ lm/src/matherr.c Mon Jul 3 15:16:58 2006
+@@ -18,13 +18,6 @@
+ matherr(struct exception *x)
+ #endif
+ {
+- if (x->type == SING && strcmp(x->name, "log10") == 0) {
+- /*
+- * suppress warnings about log10(0.0)
+- */
+- return 1;
+- } else {
+ return 0;
+- }
+ }
+