aboutsummaryrefslogtreecommitdiff
path: root/textproc/srilm
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-04-03 21:46:24 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-04-03 21:46:24 +0000
commit6e345601286b0c658d68354af303362a73d43688 (patch)
tree65524c6f5d4f9496e15acfbe4d9f67dcfa481d7a /textproc/srilm
parentd39c0d117c6569054de7f3224bc84e6f769d3292 (diff)
downloadports-6e345601286b0c658d68354af303362a73d43688.tar.gz
ports-6e345601286b0c658d68354af303362a73d43688.zip
Notes
Diffstat (limited to 'textproc/srilm')
-rw-r--r--textproc/srilm/Makefile9
-rw-r--r--textproc/srilm/distinfo4
-rw-r--r--textproc/srilm/files/patch-Makefile.machine.freebsd10
-rw-r--r--textproc/srilm/files/patch-Makefile.machine.i38672
-rw-r--r--textproc/srilm/files/patch-bin-machine-type11
-rw-r--r--textproc/srilm/files/patch-compare-outputs8
-rw-r--r--textproc/srilm/files/patch-go.run-test17
-rw-r--r--textproc/srilm/files/patch-lattice-src-Makefile11
-rw-r--r--textproc/srilm/files/patch-lm-src-Makefile11
-rw-r--r--textproc/srilm/pkg-plist66
10 files changed, 72 insertions, 147 deletions
diff --git a/textproc/srilm/Makefile b/textproc/srilm/Makefile
index f3e8e3fb4475..d52769e96351 100644
--- a/textproc/srilm/Makefile
+++ b/textproc/srilm/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= srilm
-PORTVERSION= 1.3.3
+PORTVERSION= 1.4
CATEGORIES= textproc
DISTNAME= srilm
-EXTRACT_SUFX?= .gz
+EXTRACT_SUFX?= .tgz
MAINTAINER= clsung@dragon2.net
COMMENT= Toolkit for building and applying statistical language models
@@ -56,7 +56,8 @@ MAN1= ngram.1 ngram-count.1 ngram-class.1 ngram-merge.1 disambig.1 \
nbest-lattice.1 nbest-optimize.1 nbest-mix.1 \
nbest-pron-score.1 segment.1 segment-nbest.1 hidden-ngram.1 \
anti-ngram.1 multi-ngram.1 lattice-tool.1 training-scripts.1 \
- lm-scripts.1 ppl-scripts.1 pfsg-scripts.1 nbest-scripts.1
+ lm-scripts.1 ppl-scripts.1 pfsg-scripts.1 nbest-scripts.1 \
+ select-vocab.1
MAN3= Prob.3 Vocab.3 LM.3 File.3
MAN5= ngram-format.5 nbest-format.5 classes-format.5 \
pfsg-format.5 wlat-format.5
@@ -87,7 +88,7 @@ post-patch:
do-install:
@${MKDIR} ${EXAMPLESDIR}
- cd ${WRKSRC}/bin/${MACHINE_ARCH} && \
+ cd ${WRKSRC}/bin/freebsd && \
${INSTALL_PROGRAM} ${PROGRAMS} ${PREFIX}/bin && \
${INSTALL_SCRIPT} ${GAWK_SCRIPTS} ${EXAMPLESDIR} && \
cd ${WRKSRC}/man/man1 && \
diff --git a/textproc/srilm/distinfo b/textproc/srilm/distinfo
index be8a24f2b183..abd08e91370d 100644
--- a/textproc/srilm/distinfo
+++ b/textproc/srilm/distinfo
@@ -1,2 +1,2 @@
-MD5 (srilm.gz) = fc9ec46ba80466fcb6586899eead4f86
-SIZE (srilm.gz) = 28246362
+MD5 (srilm.tgz) = 5c084953c2f73ecf565f8791dfb401e0
+SIZE (srilm.tgz) = 30125078
diff --git a/textproc/srilm/files/patch-Makefile.machine.freebsd b/textproc/srilm/files/patch-Makefile.machine.freebsd
new file mode 100644
index 000000000000..fcd64075843a
--- /dev/null
+++ b/textproc/srilm/files/patch-Makefile.machine.freebsd
@@ -0,0 +1,10 @@
+--- common/Makefile.machine.freebsd.orig Mon Oct 20 02:59:58 2003
++++ common/Makefile.machine.freebsd Sat Apr 3 16:44:00 2004
+@@ -65,6 +65,6 @@
+ LINT_FLAGS = -DDEBUG $(CFLAGS)
+
+ # Location of gawk binary
+- GAWK = /usr/bin/gawk
++ GAWK = /usr/bin/awk
+
+
diff --git a/textproc/srilm/files/patch-Makefile.machine.i386 b/textproc/srilm/files/patch-Makefile.machine.i386
deleted file mode 100644
index 5b30e33973c6..000000000000
--- a/textproc/srilm/files/patch-Makefile.machine.i386
+++ /dev/null
@@ -1,72 +0,0 @@
---- common/Makefile.machine.i386.orig Thu Jan 1 12:44:20 2004
-+++ common/Makefile.machine.i386 Thu Jan 1 12:38:27 2004
-@@ -0,0 +1,69 @@
-+#
-+# File: Makefile.i686
-+# Author: The SRI DECIPHER (TM) System
-+# Date: Fri Feb 19 22:45:31 PST 1999
-+#
-+# Description:
-+# Machine dependent compilation options and variable definitions
-+# for Linux/i686 platform
-+#
-+# Copyright (c) 1999-2001 SRI International. All Rights Reserved.
-+#
-+# $Header: /home/srilm/devel/common/RCS/Makefile.machine.i686,v 1.8 2003/02/21 22:30:00 stolcke Exp $
-+#
-+
-+ # Use the GNU C compiler.
-+ GCC_FLAGS =
-+ CC = gcc $(GCC_FLAGS)
-+ CXX = g++ -Wno-deprecated $(GCC_FLAGS) -DINSTANTIATE_TEMPLATES
-+
-+ # Optional compilation flags.
-+ OPTIMIZE_FLAGS = -g -O2
-+ DEBUG_FLAGS = -g -DDEBUG
-+ PROFILE_FLAGS = -g -pg -O2
-+
-+ # Optional linking flags.
-+ EXPORT_LDFLAGS = -s
-+
-+ # Shared compilation flags.
-+ CFLAGS = $(ADDITIONAL_CFLAGS) $(INCLUDES)
-+ CXXFLAGS = $(ADDITIONAL_CXXFLAGS) $(INCLUDES)
-+
-+ # Shared linking flags.
-+ LDFLAGS = $(ADDITIONAL_LDFLAGS) -L$(SRILM_LIBDIR)
-+
-+ # Other useful compilation flags.
-+ ADDITIONAL_CFLAGS =
-+ ADDITIONAL_CXXFLAGS =
-+
-+ # Other useful include directories.
-+ ADDITIONAL_INCLUDES =
-+
-+ # Other useful linking flags.
-+ ADDITIONAL_LDFLAGS =
-+
-+ # Other useful libraries.
-+ ADDITIONAL_LIBRARIES = -L/home/clsung/srilm/work/srilm/dstruct/obj/i686 -L/home/clsung/srilm/work/srilm/misc/obj/i686 -L/home/clsung/srilm/work/srilm/htk/obj/i686 -L/home/clsung/srilm/work/srilm/lattice/obj/i686 -L/home/clsung/srilm/work/srilm/utils/obj/i686 -L/home/clsung/srilm/work/srilm/lm/obj/i686 -lm
-+
-+ # run-time linker path flag
-+ RLD_FLAG = -R
-+
-+ # Tcl support (standard in Linux)
-+ TCL_INCLUDE = -I/usr/local/include/tcl8.3
-+ TCL_LIBRARY = -L/usr/local/lib -ltcl83
-+
-+ # No ranlib
-+ RANLIB = :
-+
-+ # Generate dependencies from source files.
-+ GEN_DEP = $(CC) $(CFLAGS) -MM
-+
-+ GEN_DEP.cc = $(CXX) $(CXXFLAGS) -MM
-+
-+ # Run lint.
-+ LINT = lint
-+ LINT_FLAGS = -DDEBUG $(CFLAGS)
-+
-+ # Location of awk binary
-+ GAWK = /usr/bin/awk
-+
diff --git a/textproc/srilm/files/patch-bin-machine-type b/textproc/srilm/files/patch-bin-machine-type
deleted file mode 100644
index a5d1f37f33b4..000000000000
--- a/textproc/srilm/files/patch-bin-machine-type
+++ /dev/null
@@ -1,11 +0,0 @@
---- bin/machine-type.orig Sat Feb 22 06:04:46 2003
-+++ bin/machine-type Thu Jan 1 12:43:08 2004
-@@ -92,6 +92,8 @@
- set MACHINE_TYPE = macosx
- else if (`uname -m` == i686) then
- set MACHINE_TYPE = i686
-+ else if (`uname -m` == i386) then
-+ set MACHINE_TYPE = i386
- else
- ## Generate an error by doing nothing. (Used to be the line below:)
- ## echo "ERROR: Unsupported machine type: "$RESULT
diff --git a/textproc/srilm/files/patch-compare-outputs b/textproc/srilm/files/patch-compare-outputs
new file mode 100644
index 000000000000..4b3592d89d9e
--- /dev/null
+++ b/textproc/srilm/files/patch-compare-outputs
@@ -0,0 +1,8 @@
+--- test/compare-outputs.orig Fri Feb 28 10:04:35 2003
++++ test/compare-outputs Sat Apr 3 16:45:20 2004
+@@ -1,4 +1,4 @@
+-#!/usr/local/bin/gawk -f
++#!/usr/bin/awk -f
+ #
+ # compare test outputs allowing for small numerical differences
+ #
diff --git a/textproc/srilm/files/patch-go.run-test b/textproc/srilm/files/patch-go.run-test
index 96800a46af32..b173ead3400c 100644
--- a/textproc/srilm/files/patch-go.run-test
+++ b/textproc/srilm/files/patch-go.run-test
@@ -1,12 +1,21 @@
---- test/go.run-test.orig Thu Jan 1 12:15:21 2004
-+++ test/go.run-test Thu Jan 1 12:16:10 2004
+--- test/go.run-test.orig Tue Mar 4 12:51:40 2003
++++ test/go.run-test Sat Apr 3 16:46:12 2004
@@ -6,6 +6,9 @@
- # $Header: /home/srilm/devel/test/RCS/go.run-test,v 1.10 2003/02/27 23:42:35 stolcke Exp $
+ # $Header: /home/srilm/devel/test/RCS/go.run-test,v 1.11 2003/03/04 04:51:27 stolcke Exp $
#
-+PATH=$PATH:$WRKSRC/bin:$WRKSRC/bin/i386
++PATH=$PATH:$WRKSRC/bin:$WRKSRC/bin/freebsd
+export PATH
+
dir=$1
if [ -z "$MACHINE_TYPE" ]; then
+@@ -16,7 +19,7 @@
+
+ #diff=cmp
+ # ignore different whitespace and EOL conventions
+-diff="gawk -f compare-outputs 2>/dev/null"
++diff="awk -f compare-outputs 2>/dev/null"
+
+ test -d output || mkdir output
+
diff --git a/textproc/srilm/files/patch-lattice-src-Makefile b/textproc/srilm/files/patch-lattice-src-Makefile
deleted file mode 100644
index 3d538ac7eab6..000000000000
--- a/textproc/srilm/files/patch-lattice-src-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- lattice/src/Makefile.orig Sun Aug 25 05:29:45 2002
-+++ lattice/src/Makefile Thu Jan 1 11:12:00 2004
-@@ -131,7 +131,7 @@
- $(ARCHIVE) $@ $^ $(DEMANGLE_FILTER)
- $(RANLIB) $@ $(DEMANGLE_FILTER)
-
--$(PROGRAMS): $(LIBRARY) $(OTHER_LIBRARIES)
-+$(PROGRAMS): $(LIBRARY)
-
- # Variables and Targets for released system
-
diff --git a/textproc/srilm/files/patch-lm-src-Makefile b/textproc/srilm/files/patch-lm-src-Makefile
deleted file mode 100644
index ea48aee14621..000000000000
--- a/textproc/srilm/files/patch-lm-src-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- lm/src/Makefile.orig Sat Feb 22 04:20:46 2003
-+++ lm/src/Makefile Thu Jan 1 11:11:40 2004
-@@ -234,7 +234,7 @@
- $(ARCHIVE) $@ $^ $(DEMANGLE_FILTER)
- $(RANLIB) $@ $(DEMANGLE_FILTER)
-
--$(PROGRAMS): $(LIBRARY) $(OTHER_LIBRARIES)
-+$(PROGRAMS): $(LIBRARY)
-
- # Variables and Targets for released system
-
diff --git a/textproc/srilm/pkg-plist b/textproc/srilm/pkg-plist
index dc8a39a122bb..fd721cd9547d 100644
--- a/textproc/srilm/pkg-plist
+++ b/textproc/srilm/pkg-plist
@@ -1,45 +1,36 @@
-bin/ngram
-bin/ngram-count
-bin/ngram-merge
-bin/ngram-class
-bin/disambig
bin/anti-ngram
+bin/disambig
+bin/fax2tiff
+bin/hidden-ngram
+bin/lattice-tool
+bin/multi-ngram
bin/nbest-lattice
bin/nbest-mix
bin/nbest-optimize
bin/nbest-pron-score
+bin/ncftpget
+bin/ngram
+bin/ngram-class
+bin/ngram-count
+bin/ngram-merge
bin/segment
bin/segment-nbest
-bin/hidden-ngram
-bin/multi-ngram
-bin/lattice-tool
-%%EXAMPLESDIR%%/change-lm-vocab
-%%EXAMPLESDIR%%/rescore-decipher
-%%EXAMPLESDIR%%/rescore-acoustic
-%%EXAMPLESDIR%%/rescore-reweight
-%%EXAMPLESDIR%%/rescore-minimize-wer
-%%EXAMPLESDIR%%/make-batch-counts
-%%EXAMPLESDIR%%/merge-batch-counts
-%%EXAMPLESDIR%%/make-big-lm
-%%EXAMPLESDIR%%/make-multiword-pfsg
-%%EXAMPLESDIR%%/pfsg-from-ngram
-%%EXAMPLESDIR%%/nbest-error
-%%EXAMPLESDIR%%/nbest-rover
-%%EXAMPLESDIR%%/align-with-tags
-%%EXAMPLESDIR%%/compute-sclite
-%%EXAMPLESDIR%%/compare-sclite
%%EXAMPLESDIR%%/add-classes-to-pfsg
%%EXAMPLESDIR%%/add-dummy-bows
%%EXAMPLESDIR%%/add-pauses-to-pfsg
%%EXAMPLESDIR%%/add-ppls
+%%EXAMPLESDIR%%/align-with-tags
%%EXAMPLESDIR%%/bytelog-to-log10
+%%EXAMPLESDIR%%/change-lm-vocab
%%EXAMPLESDIR%%/classes-to-fsm
%%EXAMPLESDIR%%/combine-acoustic-scores
%%EXAMPLESDIR%%/compare-ppls
+%%EXAMPLESDIR%%/compare-sclite
%%EXAMPLESDIR%%/compute-best-mix
%%EXAMPLESDIR%%/compute-best-rover-mix
%%EXAMPLESDIR%%/compute-best-sentence-mix
%%EXAMPLESDIR%%/compute-oov-rate
+%%EXAMPLESDIR%%/compute-sclite
%%EXAMPLESDIR%%/continuous-ngram-count
%%EXAMPLESDIR%%/extract-skip-probs
%%EXAMPLESDIR%%/find-reference-posteriors
@@ -48,37 +39,48 @@ bin/lattice-tool
%%EXAMPLESDIR%%/hits-from-log
%%EXAMPLESDIR%%/log10-to-bytelog
%%EXAMPLESDIR%%/make-abs-discount
+%%EXAMPLESDIR%%/make-batch-counts
+%%EXAMPLESDIR%%/make-big-lm
%%EXAMPLESDIR%%/make-diacritic-map
%%EXAMPLESDIR%%/make-gt-discounts
-%%EXAMPLESDIR%%/make-kn-discounts
-%%EXAMPLESDIR%%/make-kn-counts
%%EXAMPLESDIR%%/make-hiddens-lm
+%%EXAMPLESDIR%%/make-kn-counts
+%%EXAMPLESDIR%%/make-kn-discounts
%%EXAMPLESDIR%%/make-lm-subset
+%%EXAMPLESDIR%%/make-multiword-pfsg
%%EXAMPLESDIR%%/make-nbest-pfsg
%%EXAMPLESDIR%%/make-ngram-pfsg
%%EXAMPLESDIR%%/make-sub-lm
-%%EXAMPLESDIR%%/sort-lm
-%%EXAMPLESDIR%%/reverse-lm
+%%EXAMPLESDIR%%/merge-batch-counts
%%EXAMPLESDIR%%/merge-nbest
+%%EXAMPLESDIR%%/nbest-error
%%EXAMPLESDIR%%/nbest-posteriors
-%%EXAMPLESDIR%%/nbest2-to-nbest1
+%%EXAMPLESDIR%%/nbest-rover
%%EXAMPLESDIR%%/nbest-vocab
+%%EXAMPLESDIR%%/nbest2-to-nbest1
+%%EXAMPLESDIR%%/pfsg-from-ngram
%%EXAMPLESDIR%%/pfsg-to-dot
%%EXAMPLESDIR%%/pfsg-to-fsm
%%EXAMPLESDIR%%/pfsg-vocab
%%EXAMPLESDIR%%/ppl-from-log
+%%EXAMPLESDIR%%/prettify
%%EXAMPLESDIR%%/remove-lowprob-ngrams
%%EXAMPLESDIR%%/replace-words-with-classes
-%%EXAMPLESDIR%%/reverse-text
+%%EXAMPLESDIR%%/rescore-acoustic
+%%EXAMPLESDIR%%/rescore-decipher
+%%EXAMPLESDIR%%/rescore-minimize-wer
+%%EXAMPLESDIR%%/rescore-reweight
+%%EXAMPLESDIR%%/reverse-lm
%%EXAMPLESDIR%%/reverse-ngram-counts
-%%EXAMPLESDIR%%/sentid-to-sclite
+%%EXAMPLESDIR%%/reverse-text
%%EXAMPLESDIR%%/sentid-to-ctm
+%%EXAMPLESDIR%%/sentid-to-sclite
+%%EXAMPLESDIR%%/sort-lm
%%EXAMPLESDIR%%/subtract-ppls
%%EXAMPLESDIR%%/uniform-classes
%%EXAMPLESDIR%%/vp2text
+%%EXAMPLESDIR%%/wlat-stats
%%EXAMPLESDIR%%/wlat-to-dot
%%EXAMPLESDIR%%/wlat-to-pfsg
-%%EXAMPLESDIR%%/wlat-stats
%%EXAMPLESDIR%%/wordlat-to-lisp
-%%EXAMPLESDIR%%/prettify
@dirrm %%EXAMPLESDIR%%