aboutsummaryrefslogtreecommitdiff
path: root/textproc/ssddiff
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-24 20:22:49 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-24 20:22:49 +0000
commitdaa47c39ff2748d4c31e7334185da55bdd3e53b0 (patch)
treec2afea0dee2a64a8509ccf0149fec03b7430a8e1 /textproc/ssddiff
parent2e1f678ae663ac9a33507642343ff1a95b5a08fb (diff)
downloadports-daa47c39ff2748d4c31e7334185da55bdd3e53b0.tar.gz
ports-daa47c39ff2748d4c31e7334185da55bdd3e53b0.zip
Notes
Diffstat (limited to 'textproc/ssddiff')
-rw-r--r--textproc/ssddiff/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/textproc/ssddiff/Makefile b/textproc/ssddiff/Makefile
index 187480374190..0fd2e1e5593d 100644
--- a/textproc/ssddiff/Makefile
+++ b/textproc/ssddiff/Makefile
@@ -12,23 +12,23 @@ COMMENT= Diff application for semistructured data such as XML files
LICENSE= GPLv2 # (or later)
-USES= pkgconfig tar:bzip2
-USE_GNOME= libxml2
-USE_GCC= any
-USE_AUTOTOOLS= automake14
+GNU_CONFIGURE= yes
+USES= autoreconf pkgconfig tar:bzip2
+USE_GNOME= libxml2
PLIST_FILES= bin/xmldiff
-post-extract:
- @${FIND} ${WRKSRC} -type l -delete
-
post-patch:
-.for f in config.guess config.sub install-sh missing mkinstalldirs
- @${LN} -sf ${AUTOMAKE_DIR}/${f} ${WRKSRC}/${f}
-.endfor
+ @${FIND} ${WRKSRC} -type l -delete
@${REINPLACE_CMD} -e \
's|^CXXFLAGS|AM_CPPFLAGS|' ${WRKSRC}/src/Makefile.am
@${REINPLACE_CMD} -e \
's|"getopt\.h"|<unistd.h>|' ${WRKSRC}/src/main.cc
+ @${REINPLACE_CMD} \
+ -e 's/hash</__gnu_cxx::&/' -e 's/hash<char/& const/' \
+ ${WRKSRC}/src/doc.h ${WRKSRC}/src/out_common.cc \
+ ${WRKSRC}/src/out_merged.cc ${WRKSRC}/src/out_xupdate.cc \
+ ${WRKSRC}/src/out_xupdate.h ${WRKSRC}/src/ustring.cc \
+ ${WRKSRC}/src/ustring.h
.include <bsd.port.mk>