aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict3/Makefile
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2006-07-17 06:52:07 +0000
committerXin LI <delphij@FreeBSD.org>2006-07-17 06:52:07 +0000
commit98aa8bd0ef8073bfdd4abd4bcd93a841101ed422 (patch)
treef9d6130e542a6abcd11525433093b9e0b344478f /textproc/stardict3/Makefile
parentc26cce333cf2f5ccbba4f7c95c23d1240ddd81ea (diff)
downloadports-98aa8bd0ef8073bfdd4abd4bcd93a841101ed422.tar.gz
ports-98aa8bd0ef8073bfdd4abd4bcd93a841101ed422.zip
Notes
Diffstat (limited to 'textproc/stardict3/Makefile')
-rw-r--r--textproc/stardict3/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index d7e5de03095f..c17943dd4651 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stardict
PORTVERSION= 2.4.8
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,11 +23,22 @@ USE_GMAKE= yes
USE_GCC= 3.4
USE_X_PREFIX= yes
USE_BZIP2= yes
-USE_GNOME= gnomehack gnomeprefix libgnomeui
+USE_GNOME= gnomehack gnomeprefix
USE_GETTEXT= yes
+OPTIONS= GNOMEUI "GNOME support" On
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GNOMEUI)
+USE_GNOME+= libgnomeui
GCONF_SCHEMAS= stardict.schemas
INSTALLS_OMF= yes
+PLIST_SUB= GNOME=""
+.else
+CONFIGURE_ARGS+=--disable-gnome-support --disable-schemas-install
+PLIST_SUB= GNOME="@comment not installed: "
+.endif
MAN1= stardict.1
@@ -39,4 +51,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>