aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict3
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2013-02-25 15:46:23 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2013-02-25 15:46:23 +0000
commit63cf306afa92691b25959b5eb4b6b92a7fd0fe43 (patch)
treece52acd809774b29dc2d643458db4d461ec3a5cb /textproc/stardict3
parentf33283a3c5f1d8f5196173dfda43a5393f1589b4 (diff)
downloadports-63cf306afa92691b25959b5eb4b6b92a7fd0fe43.tar.gz
ports-63cf306afa92691b25959b5eb4b6b92a7fd0fe43.zip
Notes
Diffstat (limited to 'textproc/stardict3')
-rw-r--r--textproc/stardict3/Makefile8
-rw-r--r--textproc/stardict3/distinfo4
-rw-r--r--textproc/stardict3/files/patch-dict__src__conf.cpp13
-rw-r--r--textproc/stardict3/files/patch-lib__configure4
-rw-r--r--textproc/stardict3/pkg-plist4
5 files changed, 18 insertions, 15 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 06eaf3e3f666..c952f745ff5b 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -2,14 +2,13 @@
# $FreeBSD$
PORTNAME= stardict
-PORTVERSION= 3.0.3
-PORTREVISION= 1
+PORTVERSION= 3.0.4
CATEGORIES= textproc
MASTER_SITES= GOOGLE_CODE
DIST_SUBDIR= stardict
MAINTAINER= makc@FreeBSD.org
-COMMENT= A cross-platform and international dictionary written in Gtk2
+COMMENT= Dictionary lookup program written in Gtk2
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
enchant.1:${PORTSDIR}/textproc/enchant
@@ -25,6 +24,7 @@ USE_GMAKE= yes
USE_BZIP2= yes
USE_GNOME= gnomehack
USE_GETTEXT= yes
+MAKE_JOBS_SAFE= yes
CONFIGURE_WRKSRC= ${WRKSRC}/dict
BUILD_WRKSRC= ${CONFIGURE_WRKSRC}
INSTALL_WRKSRC= ${CONFIGURE_WRKSRC}
@@ -48,7 +48,7 @@ USE_AUTOTOOLS= autoconf
USE_GNOME+= gtk20
CONFIGURE_ARGS+=--disable-gnome-support --disable-schemas-install
PLIST_SUB= GNOME="@comment "
-MAKE_ARGS+= AUTOMAKE="${TRUE}" ACLOCAL="${TRUE}"
+MAKE_ARGS+= AUTOMAKE="${TRUE}" ACLOCAL="${TRUE}"
.endif
MAN1= stardict.1
diff --git a/textproc/stardict3/distinfo b/textproc/stardict3/distinfo
index c3fcb7830a09..6810b78d149b 100644
--- a/textproc/stardict3/distinfo
+++ b/textproc/stardict3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (stardict/stardict-3.0.3.tar.bz2) = 9ba10a5b3dcdd02b81c7a138dac15903a6bc2355856f60338f3775e371472b73
-SIZE (stardict/stardict-3.0.3.tar.bz2) = 9147947
+SHA256 (stardict/stardict-3.0.4.tar.bz2) = c38b9d953fe0b2380a8aed4c98cb121ad83aff91a32af3c665198d8268b1dce8
+SIZE (stardict/stardict-3.0.4.tar.bz2) = 8961622
diff --git a/textproc/stardict3/files/patch-dict__src__conf.cpp b/textproc/stardict3/files/patch-dict__src__conf.cpp
index 31e521cc8e1d..de626bcad320 100644
--- a/textproc/stardict3/files/patch-dict__src__conf.cpp
+++ b/textproc/stardict3/files/patch-dict__src__conf.cpp
@@ -1,6 +1,13 @@
---- ./dict/src/conf.cpp.orig 2011-07-03 06:58:40.000000000 +0000
-+++ ./dict/src/conf.cpp 2011-10-20 21:40:21.491156419 +0000
-@@ -181,7 +181,7 @@
+--- ./dict/src/conf.cpp.orig 2012-12-10 14:44:32.000000000 +0000
++++ ./dict/src/conf.cpp 2013-02-24 14:11:08.724362041 +0000
+@@ -184,13 +184,13 @@
+ add_entry("/apps/stardict/preferences/dictionary/sound_play_command", std::string("play")); // absolute command
+ add_entry("/apps/stardict/preferences/dictionary/always_use_sound_play_command", false);
+ #else
+- add_entry("/apps/stardict/preferences/dictionary/sound_play_command", std::string("aplay")); // absolute command
++ add_entry("/apps/stardict/preferences/dictionary/sound_play_command", std::string("play")); // absolute command
+ #endif
+ add_entry("/apps/stardict/preferences/dictionary/video_play_command", std::string("play")); // absolute command
#if defined(CONFIG_GPE)
add_entry("/apps/stardict/preferences/dictionary/url_open_command", std::string("gpe-mini-browser"));
#else
diff --git a/textproc/stardict3/files/patch-lib__configure b/textproc/stardict3/files/patch-lib__configure
index 51f15f6e099e..4f0049d637a4 100644
--- a/textproc/stardict3/files/patch-lib__configure
+++ b/textproc/stardict3/files/patch-lib__configure
@@ -4,8 +4,8 @@
# Checks for typedefs, structures, and compiler characteristics.
# Checks for library functions.
--DEP_MODULES="gtk+-2.0 >= 2.6 glib-2.0 >= 2.8 zlib libxml-2.0 >= 2.5"
-+DEP_MODULES="gtk+-2.0 >= 2.6 glib-2.0 >= 2.8 libxml-2.0 >= 2.5"
+-DEP_MODULES="gtk+-2.0 glib-2.0 >= 2.8 zlib libxml-2.0 >= 2.5"
++DEP_MODULES="gtk+-2.0 glib-2.0 >= 2.8 libxml-2.0 >= 2.5"
diff --git a/textproc/stardict3/pkg-plist b/textproc/stardict3/pkg-plist
index 644b49ff27dd..653b9ed2c2c4 100644
--- a/textproc/stardict3/pkg-plist
+++ b/textproc/stardict3/pkg-plist
@@ -180,9 +180,7 @@ share/stardict/pixmaps/splash.png
share/stardict/pixmaps/video.png
share/stardict/sounds/buttonactive.wav
share/stardict/sounds/menushow.wav
-@dirrmtry share/stardict/treedict
@dirrm share/stardict/sounds
-@dirrm share/stardict/skins
@dirrm share/stardict/pixmaps
@dirrm share/stardict/dic/stardict-dict/res
@dirrm share/stardict/dic/stardict-dict
@@ -216,5 +214,3 @@ share/stardict/sounds/menushow.wav
@dirrmtry share/applications
@dirrm lib/stardict/plugins
@dirrm lib/stardict
-@exec mkdir -p %D/share/stardict/skins
-@exec mkdir -p %D/share/stardict/treedict