aboutsummaryrefslogtreecommitdiff
path: root/textproc/stardict3
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2011-06-17 21:10:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2011-06-17 21:10:38 +0000
commit274e261b1b335fd6276d92f254abf9272dba15f8 (patch)
tree8386f49727402c681e7507784092c02117be4d55 /textproc/stardict3
parenta6958267e4c53b20ae9d94a9d2967277eb676a3b (diff)
downloadports-274e261b1b335fd6276d92f254abf9272dba15f8.tar.gz
ports-274e261b1b335fd6276d92f254abf9272dba15f8.zip
Notes
Diffstat (limited to 'textproc/stardict3')
-rw-r--r--textproc/stardict3/Makefile3
-rw-r--r--textproc/stardict3/files/patch-src__readword.cpp20
2 files changed, 23 insertions, 0 deletions
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index cc3abf727837..42915faf3f2d 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -7,6 +7,7 @@
PORTNAME= stardict
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= SF
DIST_SUBDIR= stardict
@@ -16,6 +17,7 @@ COMMENT= A cross-platform and international dictionary written in Gtk2
LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20 \
enchant.1:${PORTSDIR}/textproc/enchant
+RUN_DEPENDS= xdg-open:${PORTSDIR}/devel/xdg-utils
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
@@ -55,6 +57,7 @@ post-patch:
${REINPLACE_CMD} -e '/^GNOME_DOC_INIT/d' ${WRKSRC}/configure.ac
.endif
${REINPLACE_CMD} -e 's,/usr/share,${PREFIX}/share,g' \
+ -e 's,firefox,xdg-open,' \
${WRKSRC}/src/conf.cpp
post-install:
diff --git a/textproc/stardict3/files/patch-src__readword.cpp b/textproc/stardict3/files/patch-src__readword.cpp
new file mode 100644
index 000000000000..ac24d09f8dfe
--- /dev/null
+++ b/textproc/stardict3/files/patch-src__readword.cpp
@@ -0,0 +1,20 @@
+--- ./src/readword.cpp.orig 2010-12-17 19:58:59.000000000 +0300
++++ ./src/readword.cpp 2011-06-18 00:38:15.560473773 +0400
+@@ -78,7 +78,7 @@
+ std::string filename;
+ std::list<std::string>::const_iterator it;
+ for (it=ttspath.begin(); it!=ttspath.end(); ++it) {
+- filename = build_path(*it, lowerword[0] + G_DIR_SEPARATOR_S + lowerword + ".wav");
++ filename = build_path(*it, std::string(1,lowerword[0]) + G_DIR_SEPARATOR_S + lowerword + ".wav");
+ return_val = g_file_test(filename.c_str(), G_FILE_TEST_EXISTS);
+ if (return_val)
+ break;
+@@ -109,7 +109,7 @@
+ std::string filename;
+ std::list<std::string>::const_iterator it;
+ for (it=ttspath.begin(); it!=ttspath.end(); ++it) {
+- filename = build_path(*it, lowerword[0] + G_DIR_SEPARATOR_S + lowerword + ".wav");
++ filename = build_path(*it, std::string(1,lowerword[0]) + G_DIR_SEPARATOR_S + lowerword + ".wav");
+ if (g_file_test(filename.c_str(), G_FILE_TEST_EXISTS)) {
+ play_sound_file(filename);
+ break;