aboutsummaryrefslogtreecommitdiff
path: root/textproc/sw-hunspell/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
commit72c08ec487edbe98662f3278bee17f8726ee4ce4 (patch)
treea3c6d7d2a4a492c3e55a418f3fa370e951b5ccc7 /textproc/sw-hunspell/Makefile
parenta600d4522cadfa512ce465f98566cee7b9bec843 (diff)
downloadports-72c08ec487edbe98662f3278bee17f8726ee4ce4.tar.gz
ports-72c08ec487edbe98662f3278bee17f8726ee4ce4.zip
Notes
Diffstat (limited to 'textproc/sw-hunspell/Makefile')
-rw-r--r--textproc/sw-hunspell/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/textproc/sw-hunspell/Makefile b/textproc/sw-hunspell/Makefile
index 3d5e07d4303a..801efea161dc 100644
--- a/textproc/sw-hunspell/Makefile
+++ b/textproc/sw-hunspell/Makefile
@@ -5,30 +5,32 @@
# $FreeBSD$
#
-PORTNAME= sw-hunspell
+PORTNAME= hunspell
PORTVERSION= 1.46
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= sw-
DISTNAME= sv-${PORTVERSION}
MAINTAINER= office@FreeBSD.org
COMMENT= Swedish hunspell dictionaries
-PROJECTHOST= dsso
USE_ZIP= yes
NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PROJECTHOST= dsso
-PLIST_FILES= share/hunspell/sv_SE.aff \
- share/hunspell/sv_SE.dic \
- share/hunspell/sv_FI.aff \
- share/hunspell/sv_FI.dic
-PLIST_DIRS= share/hunspell
+PLIST_FILES= %%DATADIR%%/sv_FI.aff \
+ %%DATADIR%%/sv_FI.dic \
+ %%DATADIR%%/sv_SE.aff \
+ %%DATADIR%%/sv_SE.dic
+PLIST_DIRSTRY= %%DATADIR%%
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKDIR}/sv_SE* ${PREFIX}/share/hunspell
- @cd ${PREFIX}/share/hunspell; \
- ${LN} -s sv_SE.aff sv_FI.aff; \
- ${LN} -s sv_SE.dic sv_FI.dic
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/sv_SE.aff ${WRKSRC}/sv_SE.dic ${DATADIR}/
+ ${LN} -s sv_SE.aff ${DATADIR}/sv_FI.aff
+ ${LN} -s sv_SE.dic ${DATADIR}/sv_FI.dic
.include <bsd.port.mk>