aboutsummaryrefslogtreecommitdiff
path: root/textproc/tdhkit
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:34:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-03-09 22:34:45 +0000
commit4c37f2e14ad7a49c76585f50f7e514237008ba1d (patch)
treecfa13102799409a72497cd43f3cab3b685edbb2a /textproc/tdhkit
parent8b47eebfa5ced9e39a37b04ba0d6d9218facc0cc (diff)
Notes
Diffstat (limited to 'textproc/tdhkit')
-rw-r--r--textproc/tdhkit/Makefile77
-rw-r--r--textproc/tdhkit/distinfo3
-rw-r--r--textproc/tdhkit/files/patch-Makefile11
-rw-r--r--textproc/tdhkit/pkg-descr8
-rw-r--r--textproc/tdhkit/pkg-plist35
5 files changed, 134 insertions, 0 deletions
diff --git a/textproc/tdhkit/Makefile b/textproc/tdhkit/Makefile
new file mode 100644
index 000000000000..db9d2bdc9039
--- /dev/null
+++ b/textproc/tdhkit/Makefile
@@ -0,0 +1,77 @@
+# ex:ts=8
+# Ports collection makefile for: tdhkit
+# Date created: 2 Mar 2010
+# Whom: corky1951@comcast.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= tdhkit
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://quisp.sourceforge.net/${PORTNAME}/
+DISTNAME= ${PORTNAME}${PORTVERSION:C/\.//1}
+
+MAINTAINER= corky1951@comcast.net
+COMMENT= A set of programs for working with tabular ascii data
+
+OPTIONS= LIBCHRON "Install libchron" Off
+
+.include <bsd.port.options.mk>
+
+.if defined(WITH_LIBCHRON)
+PLIST_SUB+= LIBCHRON=""
+.else
+PLIST_SUB+= LIBCHRON="@comment "
+.endif
+
+.if !defined(NO_INSTALL_MANPAGES)
+MAN1= dateconvert.1 \
+ fldfmt.1 \
+ fldmap.1 \
+ fldsel.1 \
+ pjoin.1 \
+ recsel.1 \
+ tabo.1 \
+ tdhfunction.1 \
+ xlcells.1 \
+ xlcleaner.1
+
+.if defined(WITH_LIBCHRON)
+MAN3= libchron.3
+.endif
+MANCOMPRESSED= no
+.endif
+
+do-build:
+ cd ${WRKSRC}/libsrc && ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
+ cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS}
+.if defined(WITH_LIBCHRON)
+ cd ${WRKSRC}/libsrc && ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} libchron
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/* ${PREFIX}/bin
+
+.if defined(WITH_LIBCHRON)
+ ${INSTALL_PROGRAM} ${WRKSRC}/libchron.a ${PREFIX}/lib
+.endif
+
+.if !defined(NO_INSTALL_MANPAGES)
+.for manpage in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/mantdh/${manpage} ${MAN1PREFIX}/man/man1
+.endfor
+.if defined(WITH_LIBCHRON)
+ ${INSTALL_MAN} ${WRKSRC}/man/mantdh/${MAN3} ${MAN3PREFIX}/man/man3
+.endif
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/man/html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/tdhkit/distinfo b/textproc/tdhkit/distinfo
new file mode 100644
index 000000000000..a6cf9e35544c
--- /dev/null
+++ b/textproc/tdhkit/distinfo
@@ -0,0 +1,3 @@
+MD5 (tdhkit10.tar.gz) = e515bb87ad2e221ac479e66f2c0786ad
+SHA256 (tdhkit10.tar.gz) = fa684660757c63c33be7f27e3c659481a3151c32a6d7c619092c7c5156eb3021
+SIZE (tdhkit10.tar.gz) = 149842
diff --git a/textproc/tdhkit/files/patch-Makefile b/textproc/tdhkit/files/patch-Makefile
new file mode 100644
index 000000000000..08fae082c7e9
--- /dev/null
+++ b/textproc/tdhkit/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- src/Makefile.orig 2010-03-02 15:09:45.000000000 -0800
++++ src/Makefile 2010-03-02 15:10:08.000000000 -0800
+@@ -6,7 +6,7 @@
+ CC = gcc
+
+
+-all: recsel fldsel fldfmt pjoin tabo dateconvert tdhfunction xlcleaner xlcells
++all: recsel fldmap fldsel fldfmt pjoin tabo dateconvert tdhfunction xlcleaner xlcells
+
+
+ # FLDMAP -
diff --git a/textproc/tdhkit/pkg-descr b/textproc/tdhkit/pkg-descr
new file mode 100644
index 000000000000..5a07f4d2d96e
--- /dev/null
+++ b/textproc/tdhkit/pkg-descr
@@ -0,0 +1,8 @@
+The TDH utilities are a set of programs and filters useful in working
+with ordinary tabular ascii data from the command line or in shell
+scripts. They were developed to supplement standard unix utilities
+such as sort and uniq. Two of the utilities are designed to work
+specifically with tab-delimited exports from Excel/spreadsheets.
+A full-featured date and time package (libchron) is also included.
+
+WWW: http://quisp.sourceforge.net/tdhkit
diff --git a/textproc/tdhkit/pkg-plist b/textproc/tdhkit/pkg-plist
new file mode 100644
index 000000000000..75057e1ab505
--- /dev/null
+++ b/textproc/tdhkit/pkg-plist
@@ -0,0 +1,35 @@
+bin/dateconvert
+bin/fldfmt
+bin/fldmap
+bin/fldsel
+bin/pjoin
+bin/recsel
+bin/tabo
+bin/tdhfunction
+bin/xlcells
+bin/xlcleaner
+%%LIBCHRON%%lib/libchron.a
+%%PORTDOCS%%%%DOCSDIR%%/Copyright.html
+%%PORTDOCS%%%%DOCSDIR%%/commalist.html
+%%PORTDOCS%%%%DOCSDIR%%/condex.html
+%%PORTDOCS%%%%DOCSDIR%%/config.html
+%%PORTDOCS%%%%DOCSDIR%%/dateconvert.1.html
+%%PORTDOCS%%%%DOCSDIR%%/dates.html
+%%PORTDOCS%%%%DOCSDIR%%/fldfmt.1.html
+%%PORTDOCS%%%%DOCSDIR%%/fldmap.1.html
+%%PORTDOCS%%%%DOCSDIR%%/fldsel.1.html
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/headerfields.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/inlinecodes.html
+%%PORTDOCS%%%%DOCSDIR%%/libchron.3.html
+%%PORTDOCS%%%%DOCSDIR%%/pjoin.1.html
+%%PORTDOCS%%%%DOCSDIR%%/recsel.1.html
+%%PORTDOCS%%%%DOCSDIR%%/tabo.1.html
+%%PORTDOCS%%%%DOCSDIR%%/tdhfunction.1.html
+%%PORTDOCS%%%%DOCSDIR%%/tdhkit.gif
+%%PORTDOCS%%%%DOCSDIR%%/tdhkit.html
+%%PORTDOCS%%%%DOCSDIR%%/times.html
+%%PORTDOCS%%%%DOCSDIR%%/xlcells.1.html
+%%PORTDOCS%%%%DOCSDIR%%/xlcleaner.1.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%