aboutsummaryrefslogtreecommitdiff
path: root/textproc/tdtd.el/Makefile
diff options
context:
space:
mode:
authorClive Lin <clive@FreeBSD.org>2001-01-03 21:05:06 +0000
committerClive Lin <clive@FreeBSD.org>2001-01-03 21:05:06 +0000
commit43c2522422d8799fc18a441f7fd0db16873a8a2e (patch)
treedd747bbd11bdb8eef942305bed243a49a3b12844 /textproc/tdtd.el/Makefile
parentbb83b4147cb829061e42dd7bb712556555212ef6 (diff)
downloadports-43c2522422d8799fc18a441f7fd0db16873a8a2e.tar.gz
ports-43c2522422d8799fc18a441f7fd0db16873a8a2e.zip
Notes
Diffstat (limited to 'textproc/tdtd.el/Makefile')
-rw-r--r--textproc/tdtd.el/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/tdtd.el/Makefile b/textproc/tdtd.el/Makefile
new file mode 100644
index 000000000000..f125b23cba2a
--- /dev/null
+++ b/textproc/tdtd.el/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: tdtd.el
+# Date created: 15 September 2000
+# Whom: Leo Kim <leo@florida.sarang.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tdtd.el
+PORTVERSION= 0.7.1
+CATEGORIES= textproc
+MASTER_SITES= http://www.menteith.com/tdtd/data/
+DISTNAME= tdtd071
+EXTRACT_SUFX= .zip
+
+MAINTAINER= leo@florida.sarang.net
+
+RUN_DEPENDS= emacs:${PORTSDIR}/editors/emacs20
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+USE_ZIP= yes
+
+ELISPDIR= ${PREFIX}/share/emacs/site-lisp
+DOCDIR= ${PREFIX}/share/doc
+
+do-install:
+ ${MKDIR} ${ELISPDIR}
+ ${MKDIR} ${DOCDIR}/${PORTNAME}
+ @(cd ${WRKSRC} && \
+ ${INSTALL_DATA} tdtd.el tdtd-font.el ${ELISPDIR} && \
+ ${INSTALL_DATA} TODO changelog.txt dot_emacs readme.txt tutorial.txt ${DOCDIR}/${PORTNAME} \
+ )
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>