aboutsummaryrefslogtreecommitdiff
path: root/textproc/tei-xlite
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-01-03 12:16:48 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-01-03 12:16:48 +0000
commit1ac6a1baf98d33604a875ad52ff77c179e28d719 (patch)
tree32f8f89461afa1498e09ab6c808d4402d62c7cb3 /textproc/tei-xlite
parente54ca2eb37b49dffdf5ad031e7b91fc37e094040 (diff)
downloadports-1ac6a1baf98d33604a875ad52ff77c179e28d719.tar.gz
ports-1ac6a1baf98d33604a875ad52ff77c179e28d719.zip
Notes
Diffstat (limited to 'textproc/tei-xlite')
-rw-r--r--textproc/tei-xlite/Makefile36
-rw-r--r--textproc/tei-xlite/distinfo1
-rw-r--r--textproc/tei-xlite/files/catalog1
-rw-r--r--textproc/tei-xlite/pkg-comment1
-rw-r--r--textproc/tei-xlite/pkg-descr12
-rw-r--r--textproc/tei-xlite/pkg-plist7
6 files changed, 58 insertions, 0 deletions
diff --git a/textproc/tei-xlite/Makefile b/textproc/tei-xlite/Makefile
new file mode 100644
index 000000000000..01344f5d745e
--- /dev/null
+++ b/textproc/tei-xlite/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: tei-xlite
+# Date created: 19 May 2002
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tei
+PORTVERSION= 1.0
+CATEGORIES= textproc
+MASTER_SITES= http://www.tei-c.org/Lite/DTD/
+PKGNAMESUFFIX= -xlite
+DISTNAME= teixlite
+EXTRACT_SUFX= .dtd
+EXTRACT_ONLY= # Empty
+
+MAINTAINER= henrik.motakef@web.de
+
+RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+
+NO_BUILD= yes
+PLIST_SUB= MKCATALOG=${MKCATALOG} CATALOG=${CATALOG}
+INSTDIR= ${PREFIX}/share/xml/tei/xlite
+CATALOG= ${PREFIX}/share/xml/catalog
+MKCATALOG= ${PREFIX}/sbin/mkcatalog
+
+do-install:
+ @[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
+ @${INSTALL_DATA} ${DISTDIR}/teixlite.dtd ${INSTDIR}
+ @${SED} -e 's!%%INSTDIR%%!${INSTDIR}!' ${FILESDIR}/catalog \
+ > ${INSTDIR}/catalog
+
+post-install:
+ @${MKCATALOG} -q -c ${CATALOG} install ${PORTNAME}/xlite
+
+.include <bsd.port.mk>
diff --git a/textproc/tei-xlite/distinfo b/textproc/tei-xlite/distinfo
new file mode 100644
index 000000000000..07d65446df4a
--- /dev/null
+++ b/textproc/tei-xlite/distinfo
@@ -0,0 +1 @@
+MD5 (teixlite.dtd) = c27eca451396fea132c21f1eddc67748
diff --git a/textproc/tei-xlite/files/catalog b/textproc/tei-xlite/files/catalog
new file mode 100644
index 000000000000..f761017481c1
--- /dev/null
+++ b/textproc/tei-xlite/files/catalog
@@ -0,0 +1 @@
+PUBLIC "-//TEI//DTD TEI Lite XML ver. 1//EN" "%%INSTDIR%%/teixlite.dtd"
diff --git a/textproc/tei-xlite/pkg-comment b/textproc/tei-xlite/pkg-comment
new file mode 100644
index 000000000000..158ad0e2eeda
--- /dev/null
+++ b/textproc/tei-xlite/pkg-comment
@@ -0,0 +1 @@
+XML version of the TEI-Lite DTD
diff --git a/textproc/tei-xlite/pkg-descr b/textproc/tei-xlite/pkg-descr
new file mode 100644
index 000000000000..ae13fc6cd2e9
--- /dev/null
+++ b/textproc/tei-xlite/pkg-descr
@@ -0,0 +1,12 @@
+The DTD of the Text Encoding Initiative allows encoding of a wide range
+of document types in the domain of humanities. If focuses on, but is not
+restricted to, the needs of the scholarly research and education community.
+
+This port contains the XML version of the TEI Lite DTD, a small
+customization of the TEI DTD that should meet 90% of the needs of 90%
+of users.
+
+WWW: http://www.tei-c.org/
+
+-- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/textproc/tei-xlite/pkg-plist b/textproc/tei-xlite/pkg-plist
new file mode 100644
index 000000000000..611db2c2db8f
--- /dev/null
+++ b/textproc/tei-xlite/pkg-plist
@@ -0,0 +1,7 @@
+@unexec %%MKCATALOG%% -q -c %%CATALOG%% deinstall tei/xlite
+share/xml/tei/xlite/teixlite.dtd
+share/xml/tei/xlite/catalog
+@exec %%MKCATALOG%% -q -c %%CATALOG%% install tei/xlite
+@dirrm share/xml/tei/xlite
+@unexec rmdir %D/share/xml/tei 2>/dev/null || true
+@unexec rmdir %D/share/xml 2>/dev/null || true