aboutsummaryrefslogtreecommitdiff
path: root/textproc/ti-hunspell
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2011-07-29 13:13:17 +0000
commit72c08ec487edbe98662f3278bee17f8726ee4ce4 (patch)
treea3c6d7d2a4a492c3e55a418f3fa370e951b5ccc7 /textproc/ti-hunspell
parenta600d4522cadfa512ce465f98566cee7b9bec843 (diff)
downloadports-72c08ec487edbe98662f3278bee17f8726ee4ce4.tar.gz
ports-72c08ec487edbe98662f3278bee17f8726ee4ce4.zip
- Move language prefix to PKGNAMEPREFIX
- Use DATADIR - Use PLIST_DIRSTRY for DATADIR - Explicitly list installing filenames - Bump PORTREVISION for PORTNAME and PLIST change - Sort PLIST - Cosmetic change
Notes
Notes: svn path=/head/; revision=278527
Diffstat (limited to 'textproc/ti-hunspell')
-rw-r--r--textproc/ti-hunspell/Makefile24
1 files changed, 13 insertions, 11 deletions
diff --git a/textproc/ti-hunspell/Makefile b/textproc/ti-hunspell/Makefile
index 80205cded6f4..055b7f35adda 100644
--- a/textproc/ti-hunspell/Makefile
+++ b/textproc/ti-hunspell/Makefile
@@ -5,10 +5,12 @@
# $FreeBSD$
#
-PORTNAME= ti-hunspell
+PORTNAME= hunspell
PORTVERSION= 20090911
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.cs.ru.nl/~biniam/geez/dict/
+PKGNAMEPREFIX= ti-
DISTNAME= ti_ER
MAINTAINER= office@FreeBSD.org
@@ -16,18 +18,18 @@ COMMENT= Tigrigna hunspell dictionaries
USE_ZIP= yes
NO_BUILD= yes
+NO_WRKSUBDIR= yes
-PLIST_FILES= share/hunspell/ti_ER.dic \
- share/hunspell/ti_ER.aff \
- share/hunspell/ti_ET.dic \
- share/hunspell/ti_ET.aff
-PLIST_DIRS= share/hunspell
+PLIST_FILES= %%DATADIR%%/ti_ER.dic \
+ %%DATADIR%%/ti_ER.aff \
+ %%DATADIR%%/ti_ET.dic \
+ %%DATADIR%%/ti_ET.aff
+PLIST_DIRSTRY= %%DATADIR%%
do-install:
- @${MKDIR} ${PREFIX}/share/hunspell
- @${INSTALL_DATA} ${WRKDIR}/ti_ER* ${PREFIX}/share/hunspell
- @cd ${PREFIX}/share/hunspell; \
- ${LN} -s ti_ER.aff ti_ET.aff; \
- ${LN} -s ti_ER.dic ti_ET.dic
+ ${MKDIR} ${DATADIR}/
+ ${INSTALL_DATA} ${WRKSRC}/ti_ER.aff ${WRKSRC}/ti_ER.dic ${DATADIR}/
+ ${LN} -s ti_ER.aff ${DATADIR}/ti_ET.aff
+ ${LN} -s ti_ER.dic ${DATADIR}/ti_ET.dic
.include <bsd.port.mk>