aboutsummaryrefslogtreecommitdiff
path: root/textproc/tidyp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-16 09:23:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-16 09:23:35 +0000
commite70a9fa2175168768d283b6dfa771a30101908f1 (patch)
treee9f3795526cd9a21ae1b4d722d6fdc3d155997fc /textproc/tidyp/Makefile
parent75fe720ef3a5ba0a515fbf6942d9dac74426053b (diff)
downloadports-e70a9fa2175168768d283b6dfa771a30101908f1.tar.gz
ports-e70a9fa2175168768d283b6dfa771a30101908f1.zip
Notes
Diffstat (limited to 'textproc/tidyp/Makefile')
-rw-r--r--textproc/tidyp/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/textproc/tidyp/Makefile b/textproc/tidyp/Makefile
new file mode 100644
index 000000000000..68f1158fc84d
--- /dev/null
+++ b/textproc/tidyp/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: tidyp
+# Date created: 2010-05-14
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@sunpoet.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tidyp
+PORTVERSION= 1.02
+CATEGORIES= textproc www
+MASTER_SITES= http://cloud.github.com/downloads/petdance/tidyp/ \
+ http://sunpoet.net/distfiles/
+
+MAINTAINER= sunpoet@sunpoet.net
+COMMENT= A library and program to validate and fix HTML
+
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+OPTIONS= ACCESS "Support Accessibility checks" off \
+ ASIAN "Support Asian encoding" off \
+ DEBUG "Enable debugging" off \
+ UTF16 "Support UTF-16 encoding" off
+
+PLIST_SUB+= TIDYP_VER="${PORTVERSION}"
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ACCESS)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_ASIAN)
+CONFIGURE_ARGS+= --enable-asian
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+.if defined(WITH_UTF16)
+CONFIGURE_ARGS+= --enable-utf16
+.endif
+
+.include <bsd.port.post.mk>