aboutsummaryrefslogtreecommitdiff
path: root/textproc/tinyxml/Makefile
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2004-07-29 14:38:12 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2004-07-29 14:38:12 +0000
commit8f518b0bb9d37eb7b1db22403f3cadee28141de1 (patch)
tree45069a2183fea696f836c13f9ce900395e0713f2 /textproc/tinyxml/Makefile
parentd8254e0cc49328c99dccea22793d46aeee2f4632 (diff)
downloadports-8f518b0bb9d37eb7b1db22403f3cadee28141de1.tar.gz
ports-8f518b0bb9d37eb7b1db22403f3cadee28141de1.zip
Notes
Diffstat (limited to 'textproc/tinyxml/Makefile')
-rw-r--r--textproc/tinyxml/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/textproc/tinyxml/Makefile b/textproc/tinyxml/Makefile
new file mode 100644
index 000000000000..d7bb80f52c2d
--- /dev/null
+++ b/textproc/tinyxml/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: tinyxml
+# Date created: 28 July 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinyxml
+PORTVERSION= 2.3.1
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/g}
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Small C++ XML parser
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+MAKE_ENV= PREFIX=${PREFIX}
+
+INSTALLS_SHLIB= YES
+SHLIB_MAJOR= 1
+PLIST_SUB= SHLIB_MAJOR="${SHLIB_MAJOR}"
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
+ @${SED} -e "s=%%SHLIB_MAJOR%%=${SHLIB_MAJOR}=g" \
+ ${FILESDIR}/Makefile > ${WRKSRC}/Makefile
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${ECHO_MSG} "===> Installing documentation for ${PKGNAME}"
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>