aboutsummaryrefslogtreecommitdiff
path: root/textproc/tth/Makefile
diff options
context:
space:
mode:
authorThomas Gellekum <tg@FreeBSD.org>1998-02-20 08:04:08 +0000
committerThomas Gellekum <tg@FreeBSD.org>1998-02-20 08:04:08 +0000
commitb490dc5fa27754fabadc29d943fb846a8042daa8 (patch)
tree791fc8ebb5061916c7bde228535caf54a10a0a9b /textproc/tth/Makefile
parent7f27b5ae418eda925a90c062ee63e2f118155663 (diff)
Import tth port. TtH is a TeX to HTML converter.
Notes
Notes: svn path=/head/; revision=9852
Diffstat (limited to 'textproc/tth/Makefile')
-rw-r--r--textproc/tth/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/textproc/tth/Makefile b/textproc/tth/Makefile
new file mode 100644
index 000000000000..dbcf63e0dc55
--- /dev/null
+++ b/textproc/tth/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: tth
+# Version required: 1.21
+# Date created: 19 Feb 1998
+# Whom: Thomas Gellekum <tg@FreeBSD.ORG>
+#
+# $Id$
+#
+
+DISTNAME= tth_C
+PKGNAME= tth-1.21
+CATEGORIES= textproc
+MASTER_SITES= http://hutchinson.belmont.ma.us/tth/tth-noncom/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.ORG
+
+RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript5 \
+ ppmtogif:${PORTSDIR}/graphics/netpbm \
+ latex:${PORTSDIR}/print/teTeX
+
+RESTRICTED= "No commercial use"
+NO_CDROM= ${RESTRICTED}
+NO_WRKSUBDIR= yes
+MAN1= tth.1
+
+do-build:
+ cd ${WRKSRC}; ${CC} ${CFLAGS} tth.c -o tth -ll
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tth ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/l2h ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/latex2gif ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/ps2gif ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tth.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/tth
+ ${INSTALL_SCRIPT} ${WRKSRC}/tth_manual.html ${PREFIX}/share/doc/tth
+ ${INSTALL_SCRIPT} ${WRKSRC}/license.txt ${PREFIX}/share/doc/tth
+.endif
+ @${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>