aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim-gtk
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-04-01 15:41:28 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2012-04-01 15:41:28 +0000
commite7db971f3cea019ed2474093114fd773ba704b50 (patch)
tree8b1b80513ead0b621c56663c39e008060b31634f /textproc/uim-gtk
parent4512e6eeb113c7d30d40e0295e2c74c2cf637760 (diff)
downloadports-e7db971f3cea019ed2474093114fd773ba704b50.tar.gz
ports-e7db971f3cea019ed2474093114fd773ba704b50.zip
Notes
Diffstat (limited to 'textproc/uim-gtk')
-rw-r--r--textproc/uim-gtk/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/textproc/uim-gtk/Makefile b/textproc/uim-gtk/Makefile
index b02c3aeb8cf1..80ac5cc3da32 100644
--- a/textproc/uim-gtk/Makefile
+++ b/textproc/uim-gtk/Makefile
@@ -18,8 +18,11 @@ CONFIGURE_ARGS= --with-gtk2 --enable-pref
UIM_SLAVE= yes
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-gtk_Makefile.in \
- ${PATCHDIR}/extra-patch-helper_Makefile.in
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-gtk2_immodule_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk2_pad_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk2_pref_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk2_switcher_Makefile.in \
+ ${PATCHDIR}/extra-patch-gtk2_toolbar_Makefile.in
.if defined(WITHOUT_X11)
IGNORE= requires X11
@@ -27,11 +30,17 @@ IGNORE= requires X11
do-build:
(cd ${WRKSRC}/uim && ${GMAKE} libuim-x-util.la libuim-counted-init.la)
- (cd ${WRKSRC}/gtk && ${GMAKE})
- (cd ${WRKSRC}/helper && ${GMAKE})
+ (cd ${WRKSRC}/gtk2/immodule && ${GMAKE})
+ (cd ${WRKSRC}/gtk2/pad && ${GMAKE})
+ (cd ${WRKSRC}/gtk2/pref && ${GMAKE})
+ (cd ${WRKSRC}/gtk2/switcher && ${GMAKE})
+ (cd ${WRKSRC}/gtk2/toolbar && ${GMAKE})
do-install:
- (cd ${WRKSRC}/gtk && ${GMAKE} install)
- (cd ${WRKSRC}/helper && ${GMAKE} install-binPROGRAMS)
+ (cd ${WRKSRC}/gtk2/immodule && ${GMAKE} install)
+ (cd ${WRKSRC}/gtk2/pad && ${GMAKE} install)
+ (cd ${WRKSRC}/gtk2/pref && ${GMAKE} install)
+ (cd ${WRKSRC}/gtk2/switcher && ${GMAKE} install)
+ (cd ${WRKSRC}/gtk2/toolbar && ${GMAKE} install)
.include "${MASTERDIR}/Makefile"