aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim-qt
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2007-10-14 15:12:51 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2007-10-14 15:12:51 +0000
commitc9fa452e03b9fc6da6d3f67ca13e09c7f76295cb (patch)
treed58c39c9b555ba9c763d9c70c41c05e09a23d9c1 /textproc/uim-qt
parent9507ee1867e1c29f86dd229f856ac99ad527c342 (diff)
downloadports-c9fa452e03b9fc6da6d3f67ca13e09c7f76295cb.tar.gz
ports-c9fa452e03b9fc6da6d3f67ca13e09c7f76295cb.zip
Notes
Diffstat (limited to 'textproc/uim-qt')
-rw-r--r--textproc/uim-qt/Makefile25
-rw-r--r--textproc/uim-qt/pkg-descr2
2 files changed, 8 insertions, 19 deletions
diff --git a/textproc/uim-qt/Makefile b/textproc/uim-qt/Makefile
index 2b715a28c69f..5840a7c0841b 100644
--- a/textproc/uim-qt/Makefile
+++ b/textproc/uim-qt/Makefile
@@ -9,19 +9,15 @@ PKGNAMESUFFIX= -qt
COMMENT= QT modules of uim input method
-LIB_DEPENDS= qt-mt.3:${PORTSDIR}/x11-toolkits/qt33 \
- uim.4:${PORTSDIR}/textproc/uim
-
-BROKEN= fails to deinstall cleanly
-DEPRECATED= "${BROKEN}"
-EXPIRATION_DATE= 2007-11-29
-
+USE_QT_VER= 3
USE_AUTOTOOLS= libtool:15
+LIB_DEPENDS= uim.5:${PORTSDIR}/textproc/uim
+
MASTERDIR= ${.CURDIR}/../../textproc/uim
PKGDIR= ${.CURDIR}
CONFIGURE_ARGS= --with-qt --enable-pref --enable-default-toolkit=qt \
- --enable-kde-applet=no
+ --disable-kde-applet
CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include -I${LOCALBASE}/include" \
@@ -29,22 +25,15 @@ CONFIGURE_ENV= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
LDFLAGS="${LDFLAGS} ${PTHREAD_LIBS} -L${X11BASE}/lib -L${LOCALBASE}/lib"
UIM_SLAVE= yes
-# This is normally handled by defining USE_QT_VER ...
-
-.if defined(PACKAGE_BUILDING)
-TMPDIR?= /tmp
-MAKE_ENV+= TMPDIR="${TMPDIR}"
-CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
-.endif
-
-EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt_Makefile.in
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-qt_Makefile.in \
+ ${PATCHDIR}/extra-patch-qt_chardict_po_Makefile.in.in
.if defined(WITHOUT_X11)
IGNORE= requires X11
.endif
do-build:
- (cd ${WRKSRC}/qt && ${GMAKE} LIBTOOL=${WRKSRC}/libtool LIBS="-luim -luim-custom")
+ (cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${GMAKE} LIBS="-luim -luim-custom")
do-install:
(cd ${WRKSRC}/qt && ${SETENV} ${MAKE_ENV} ${GMAKE} install)
diff --git a/textproc/uim-qt/pkg-descr b/textproc/uim-qt/pkg-descr
index e9317fc8a4cd..4ae941be8779 100644
--- a/textproc/uim-qt/pkg-descr
+++ b/textproc/uim-qt/pkg-descr
@@ -1,3 +1,3 @@
QT modules of uim input method.
-WWW: http://uim.freedesktop.org/wiki/
+WWW: http://code.google.com/p/uim/