aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-01-31 17:43:42 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-01-31 17:43:42 +0000
commita40f2d0d2b31582abfe7b5f3c8eb00e490b94be4 (patch)
tree56ed7c527c12181b6e72082565b486bb56220f73 /textproc/uim/Makefile
parentfcde993b017467e42d63834bedcae887e1c55022 (diff)
Notes
Diffstat (limited to 'textproc/uim/Makefile')
-rw-r--r--textproc/uim/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 1a12edee204d..0e670e171951 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -15,7 +15,6 @@ COMMENT= Input method library
USE_X_PREFIX= yes
USE_REINPLACE= yes
-USE_PERL5_BUILD=yes
INSTALLS_SHLIB= yes
WANT_GNOME= yes
USE_GNOME= gnometarget glib20
@@ -45,6 +44,17 @@ PLIST_SUB= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 500000
+EXTRA_PATCHES= ${PATCHDIR}/extra-patch-uim_editline.c
+.endif
+
+.if ${PERL_LEVEL} >= 500600
+USE_PERL5_BUILD=yes
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/bin/perl:${PORTSDIR}/lang/perl5
+CONFIGURE_ENV+= INTLTOOL_PERL="${LOCALBASE}/bin/perl"
+.endif
+
.if defined(WITH_GTK) && !defined(WITHOUT_GTK)
USE_GNOME+= gtk20
CONFIGURE_ARGS+=--with-gtk2