aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-04-16 16:27:27 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2006-04-16 16:27:27 +0000
commit43308a7375bd5f3b7038441d719a2d1e67260631 (patch)
tree304d93881fd8f653218387878b515f2007300349 /textproc/uim/Makefile
parentfbe6b12eb9433200bf2fb5ae68836b6f85a2fb41 (diff)
downloadports-43308a7375bd5f3b7038441d719a2d1e67260631.tar.gz
ports-43308a7375bd5f3b7038441d719a2d1e67260631.zip
Notes
Diffstat (limited to 'textproc/uim/Makefile')
-rw-r--r--textproc/uim/Makefile109
1 files changed, 16 insertions, 93 deletions
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 11d40a6f1629..256310c3380c 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -7,41 +7,35 @@
PORTNAME= uim
PORTVERSION= 1.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://uim.freedesktop.org/releases/
MAINTAINER= nobutaka@FreeBSD.org
-COMMENT= Input method library
+COMMENT?= Input method library
USE_X_PREFIX= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
WANT_GNOME= yes
-USE_GNOME= gnometarget glib20
+USE_GNOME+= gnometarget glib20
USE_GMAKE= yes
USE_ICONV= yes
GNU_CONFIGURE= yes
-LIB_DEPENDS= Xft.2:${PORTSDIR}/x11-fonts/libXft
+LIB_DEPENDS+= Xft.2:${PORTSDIR}/x11-fonts/libXft
+.if !defined(UIM_SLAVE)
CONFIGURE_ARGS= --enable-emacs
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
+.endif
+CONFIGURE_ENV+= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
-OPTIONS= GTK "Enable GTK support" off \
- QT "Enable QT support" off \
- GNOME "Enable GNOME support" off \
- ANTHY "Enable Anthy support" off \
- CANNA "Enable Canna support" off \
- M17NLIB "Enable m17lib support" off \
- PRIME "Enable PRIME support" off \
- SCIM "Enable SCIM support" off \
- SKK "Enable SKK support" off
-
+.if !defined(UIM_SLAVE)
MAN1= uim-xim.1
DOCSDIR_JA= ${PREFIX}/share/doc/ja/uim
PLIST_SUB= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
+.endif
.include <bsd.port.pre.mk>
@@ -56,90 +50,19 @@ BUILD_DEPENDS+= ${LOCALBASE}/bin/perl:${PORTSDIR}/lang/perl5
CONFIGURE_ENV+= INTLTOOL_PERL="${LOCALBASE}/bin/perl"
.endif
-.if defined(WITH_GTK)
-USE_GNOME+= gtk20
-CONFIGURE_ARGS+=--with-gtk2
-PLIST_SUB+= GTK=""
-.else
-CONFIGURE_ARGS+=--without-gtk2
-PLIST_SUB+= GTK="@comment "
-.endif
-
-.if defined(WITH_QT)
-LIB_DEPENDS+= qt-mt.3:${PORTSDIR}/x11-toolkits/qt33
-CONFIGURE_ARGS+=--with-qt
-CONFIGURE_ENV+= QTDIR=${X11BASE}/lib QTINCDIR=${X11BASE}/include \
- CXXFLAGS="${CXXFLAGS} ${PTHREAD_CFLAGS} -I${X11BASE}/include" LIBS="${LIBS} ${PTHREAD_LIBS} -L${X11BASE}/lib"
-PLIST_SUB+= QT=""
-.else
-CONFIGURE_ARGS+=--without-qt
-PLIST_SUB+= QT="@comment "
-.endif
-
-.if defined(WITH_GNOME)
-USE_GNOME+= gnomepanel
-CONFIGURE_ARGS+=--with-gnome2 --enable-applet
-PLIST_SUB+= GNOME=""
-.else
-CONFIGURE_ARGS+=--without-gnome2 --disable-applet
-PLIST_SUB+= GNOME="@comment "
-.endif
-
-.if defined(WITH_ANTHY)
-LIB_DEPENDS+= anthy.1:${PORTSDIR}/japanese/anthy
-CONFIGURE_ARGS+=--with-anthy
-PLIST_SUB+= ANTHY=""
-.else
-CONFIGURE_ARGS+=--without-anthy
-PLIST_SUB+= ANTHY="@comment "
-.endif
-
-.if defined(WITH_CANNA)
-LIB_DEPENDS+= canna.1:${PORTSDIR}/japanese/Canna
-CONFIGURE_ARGS+=--with-canna
-PLIST_SUB+= CANNA=""
-.else
-CONFIGURE_ARGS+=--without-canna
-PLIST_SUB+= CANNA="@comment "
+.for _x in gtk2 qt gnome2 anthy canna m17nlib prime scim
+.if ${CONFIGURE_ARGS:M--with-${_x}} == ""
+CONFIGURE_ARGS+=--without-${_x}
.endif
-
-.if defined(WITH_M17NLIB)
-LIB_DEPENDS+= m17n.1:${PORTSDIR}/devel/m17n-lib
-CONFIGURE_ARGS+=--with-m17nlib
-PLIST_SUB+= M17NLIB=""
-.else
-CONFIGURE_ARGS+=--without-m17nlib
-PLIST_SUB+= M17NLIB="@comment "
-.endif
-
-.if defined(WITH_PRIME)
-BUILD_DEPENDS+= prime:${PORTSDIR}/japanese/prime
-RUN_DEPENDS+= ${BUILD_DEPENDS}
-CONFIGURE_ARGS+=--with-prime
-PLIST_SUB+= PRIME=""
-.else
-CONFIGURE_ARGS+=--without-prime
-PLIST_SUB+= PRIME="@comment "
-.endif
-
-.if defined(WITH_SCIM)
-USE_GCC= 3.4
-LIB_DEPENDS+= scim-1.0.9:${PORTSDIR}/textproc/scim
-CONFIGURE_ARGS+=--with-scim
-PLIST_SUB+= SCIM=""
-.else
-CONFIGURE_ARGS+=--without-scim
-PLIST_SUB+= SCIM="@comment "
-.endif
-
-.if defined(WITH_SKK)
-RUN_DEPENDS+= ${LOCALBASE}/share/skk/SKK-JISYO.L:${PORTSDIR}/japanese/skk-jisyo
+.endfor
+.if ${CONFIGURE_ARGS:M--enable-applet} == ""
+CONFIGURE_ARGS+=--disable-applet
.endif
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/scm/skk-custom.scm
-.if !defined(NOPORTDOCS)
+.if !defined(UIM_SLAVE) && !defined(NOPORTDOCS)
post-install:
${MKDIR} ${DOCSDIR}
${MKDIR} ${DOCSDIR_JA}