aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim/Makefile
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-12-02 18:46:55 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-12-02 18:46:55 +0000
commit1a3c9915718ed7c107c4b17caed738f6b7cbcfe4 (patch)
tree1d9746be77ce1d7cafe87f33c86d3e6fcde1aa54 /textproc/uim/Makefile
parent771fbdbb216d8b74f1871cace91a5c136ee92923 (diff)
downloadports-1a3c9915718ed7c107c4b17caed738f6b7cbcfe4.tar.gz
ports-1a3c9915718ed7c107c4b17caed738f6b7cbcfe4.zip
Notes
Diffstat (limited to 'textproc/uim/Makefile')
-rw-r--r--textproc/uim/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index 868afb16b5b8..b3f69700fb51 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -7,9 +7,10 @@
PORTNAME= uim
PORTVERSION= 0.4.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
-MASTER_SITES= http://uim.freedesktop.org/releases/
+MASTER_SITES= http://uim.freedesktop.org/releases/ \
+ http://www.tuhep.phys.tohoku.ac.jp/~jhpark/uim/:byeoru
MAINTAINER= nobutaka@FreeBSD.org
COMMENT= Input method library
@@ -30,6 +31,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
LDFLAGS="-L${X11BASE}/lib -L${LOCALBASE}/lib"
DOCSDIR_JA= ${PREFIX}/share/doc/ja/uim
PLIST_SUB+= DOCSDIR_JA="${DOCSDIR_JA:S,^${PREFIX}/,,}"
+BYEORU_FILES= byeoru.scm byeoru-custom.scm byeoru-key-custom.scm \
+ byeoru-symbols.scm byeoru-dic.scm
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${BYEORU_FILES:S/$/:byeoru/}
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAN1= uim-xim.1
@@ -70,6 +75,11 @@ PLIST_SUB+= CANNA=""
PLIST_SUB+= CANNA="@comment "
.endif
+post-extract:
+ for i in ${BYEORU_FILES}; do \
+ ${CAT} ${DISTDIR}/$$i >${WRKSRC}/scm/$$i; \
+ done
+
post-patch:
${REINPLACE_CMD} -e 's,%%LOCALBASE%%,${LOCALBASE},' ${WRKSRC}/scm/skk-custom.scm