aboutsummaryrefslogtreecommitdiff
path: root/textproc/uim
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-06-05 16:05:11 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2005-06-05 16:05:11 +0000
commit558b04f73dbcdbd32ba9727898d676c8e992b183 (patch)
treea83527535f28ea466fd5d736ac58077545f5b1ad /textproc/uim
parent66492abc86472ad04542ffd955bc0e9b31124212 (diff)
downloadports-558b04f73dbcdbd32ba9727898d676c8e992b183.tar.gz
ports-558b04f73dbcdbd32ba9727898d676c8e992b183.zip
Notes
Diffstat (limited to 'textproc/uim')
-rw-r--r--textproc/uim/Makefile4
-rw-r--r--textproc/uim/files/patch-uim:context.h22
2 files changed, 24 insertions, 2 deletions
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index e32c1e67ae08..09113b9d803d 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -7,7 +7,7 @@
PORTNAME= uim
PORTVERSION= 0.4.6
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= japanese x11
MASTER_SITES= http://uim.freedesktop.org/releases/
@@ -48,7 +48,7 @@ PLIST_SUB+= GNOME="@comment "
.endif
.if exists(${X11BASE}/bin/scim) || defined(WITH_SCIM)
-LIB_DEPENDS= scim-1.0.6:${PORTSDIR}/textproc/scim
+LIB_DEPENDS= scim-1.0.7:${PORTSDIR}/textproc/scim
PLIST_SUB+= SCIM=""
.else
PLIST_SUB+= SCIM="@comment "
diff --git a/textproc/uim/files/patch-uim:context.h b/textproc/uim/files/patch-uim:context.h
new file mode 100644
index 000000000000..fc4da7781f4c
--- /dev/null
+++ b/textproc/uim/files/patch-uim:context.h
@@ -0,0 +1,22 @@
+--- uim/context.h.orig Sat Feb 5 11:50:05 2005
++++ uim/context.h Sun Jun 5 16:43:06 2005
+@@ -156,13 +156,16 @@
+
+ #ifdef ENABLE_NLS
+ #define UIM_PREPARE_SAVING_TEXTDOMAIN_CODESET() \
+- const char *orig_encoding, *client_encoding;
++ char *enc, *orig_encoding = NULL; \
++ const char *client_encoding;
+ #define UIM_SWITCH_TEXTDOMAIN_CODESET(uc) \
+- orig_encoding = bind_textdomain_codeset(GETTEXT_PACKAGE, NULL); \
++ if ((enc = bind_textdomain_codeset(GETTEXT_PACKAGE, NULL))) \
++ orig_encoding = strdup(enc); \
+ client_encoding = (uc) ? ((struct uim_context_ *)uc)->encoding : uim_last_client_encoding; \
+ bind_textdomain_codeset(GETTEXT_PACKAGE, client_encoding);
+ #define UIM_RESTORE_TEXTDOMAIN_CODESET() \
+- bind_textdomain_codeset(GETTEXT_PACKAGE, orig_encoding);
++ bind_textdomain_codeset(GETTEXT_PACKAGE, orig_encoding); \
++ free(orig_encoding);
+ #else /* ENABLE_NLS */
+ #define UIM_PREPARE_SAVING_TEXTDOMAIN_CODESET()
+ #define UIM_SWITCH_TEXTDOMAIN_CODESET(uc)