aboutsummaryrefslogtreecommitdiff
path: root/textproc/unrtf
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-09 09:15:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-01-09 09:15:46 +0000
commit2f42d4dc7cd2ae696e0b3877123fba3bd471cb70 (patch)
tree09309382f7471c82664cb9bfa4b45dac38873378 /textproc/unrtf
parentc05b9c66f30bac6cdc50dd6fd60097068ed1e219 (diff)
downloadports-2f42d4dc7cd2ae696e0b3877123fba3bd471cb70.tar.gz
ports-2f42d4dc7cd2ae696e0b3877123fba3bd471cb70.zip
Notes
Diffstat (limited to 'textproc/unrtf')
-rw-r--r--textproc/unrtf/Makefile22
-rw-r--r--textproc/unrtf/distinfo2
-rw-r--r--textproc/unrtf/files/patch-Makefile24
-rw-r--r--textproc/unrtf/files/patch-malloc.c14
-rw-r--r--textproc/unrtf/files/patch-ps.c236
-rw-r--r--textproc/unrtf/pkg-descr2
-rw-r--r--textproc/unrtf/pkg-plist2
7 files changed, 15 insertions, 287 deletions
diff --git a/textproc/unrtf/Makefile b/textproc/unrtf/Makefile
index 3895894f2e8b..557a4095b60f 100644
--- a/textproc/unrtf/Makefile
+++ b/textproc/unrtf/Makefile
@@ -5,25 +5,27 @@
# $FreeBSD$
PORTNAME= unrtf
-PORTVERSION= 0.18.1
+PORTVERSION= 0.19.1
CATEGORIES= textproc
-MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITES= http://unrtf.50megs.com/ \
+ ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A converter from RTF to several formats, including HTML and LaTeX
-WRKSRC= ${WRKDIR}/unrtf
-
+USE_REINPLACE= yes
ALL_TARGET= unrtf
MAN1= unrtf.1
-post-install:
- ${INSTALL_MAN} ${WRKSRC}/unrtf.1 ${PREFIX}/man/man1/${MAN1}
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/unrtf.html ${DOCSDIR}
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e "s|^CC|#CC| ; s|^CFLAGS|#CFLAGS| ; \
+ s| ||" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e "s|<malloc\.h>|<stdlib.h>|" ${WRKSRC}/malloc.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/unrtf ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/unrtf.1 ${MAN1PREFIX}/man/man1
.include <bsd.port.mk>
diff --git a/textproc/unrtf/distinfo b/textproc/unrtf/distinfo
index b05b699a332c..29c406db668f 100644
--- a/textproc/unrtf/distinfo
+++ b/textproc/unrtf/distinfo
@@ -1 +1 @@
-MD5 (unrtf-0.18.1.tar.gz) = c7eb7eb30880c4fb8d089b8a486d255d
+MD5 (unrtf-0.19.1.tar.gz) = 1882e598ebc89ca1d9eda8f592cefbdf
diff --git a/textproc/unrtf/files/patch-Makefile b/textproc/unrtf/files/patch-Makefile
deleted file mode 100644
index 500f2927661c..000000000000
--- a/textproc/unrtf/files/patch-Makefile
+++ /dev/null
@@ -1,24 +0,0 @@
-
-$FreeBSD$
-
---- Makefile.orig Wed Oct 3 06:45:59 2001
-+++ Makefile Mon Oct 28 20:58:02 2002
-@@ -25,8 +25,8 @@
- #
-
-
--CFLAGS=-g -Wall
--CC=gcc
-+#CFLAGS=-g -Wall
-+#CC=gcc
-
- OBJS=convert.o word.o error.o main.o hash.o \
- parse.o malloc.o attr.o util.o \
-@@ -57,6 +57,6 @@
- rm -f ${OBJS}
-
- install: ${TARGET}
-- cp ${TARGET} /usr/local/bin
-+ ${INSTALL} ${TARGET} ${PREFIX}/bin
-
-
diff --git a/textproc/unrtf/files/patch-malloc.c b/textproc/unrtf/files/patch-malloc.c
deleted file mode 100644
index b56903d05d13..000000000000
--- a/textproc/unrtf/files/patch-malloc.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- malloc.c.orig Tue Mar 26 21:50:37 2002
-+++ malloc.c Tue Mar 26 21:52:14 2002
-@@ -39,11 +39,7 @@
- #include <stdio.h>
- #include <string.h>
-
--#if AMIGA
- #include <stdlib.h>
--#else
--#include <malloc.h>
--#endif
-
- #include "error.h"
-
diff --git a/textproc/unrtf/files/patch-ps.c b/textproc/unrtf/files/patch-ps.c
deleted file mode 100644
index 3ed8dd788592..000000000000
--- a/textproc/unrtf/files/patch-ps.c
+++ /dev/null
@@ -1,236 +0,0 @@
---- ps.c.orig Tue Jul 22 18:56:13 2003
-+++ ps.c Tue Jul 22 19:02:44 2003
-@@ -187,7 +187,7 @@
- /didShowPage false def \n\
- %%------------------------------------------------------\n\
- %% Set up the ISO fonts \n\
--
-+\n\
- %% Times \n\
- %% ----- \n\
- /Times-Roman findfont dup length dict begin { \n\
-@@ -196,28 +196,28 @@
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /TRomanISO exch definefont pop \n\
--
-+\n\
- /Times-Bold findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /TBoldISO exch definefont pop \n\
--
-+\n\
- /Times-BoldItalic findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /TBoldItalicISO exch definefont pop \n\
--
-+\n\
- /Times-Italic findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /TItalicISO exch definefont pop \n\
--
-+\n\
- %% Courier \n\
- %% ----- \n\
- /Courier-Roman findfont dup length dict begin { \n\
-@@ -226,28 +226,28 @@
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /CRomanISO exch definefont pop \n\
--
-+\n\
- /Courier-Bold findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /CBoldISO exch definefont pop \n\
--
-+\n\
- /Courier-BoldItalic findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /CBoldItalicISO exch definefont pop \n\
--
-+\n\
- /Courier-Italic findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /CItalicISO exch definefont pop \n\
--
-+\n\
- %% Symbol \n\
- %% ----- \n\
- /Symbol-Roman findfont dup length dict begin { \n\
-@@ -256,28 +256,28 @@
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /SRomanISO exch definefont pop \n\
--
-+\n\
- /Symbol-Bold findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /SBoldISO exch definefont pop \n\
--
-+\n\
- /Symbol-BoldItalic findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /SBoldItalicISO exch definefont pop \n\
--
-+\n\
- /Symbol-Italic findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /SItalicISO exch definefont pop \n\
--
-+\n\
- %% Helvetica \n\
- %% --------- \n\
- /Helvetica-Roman findfont dup length dict begin { \n\
-@@ -286,28 +286,28 @@
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /HRomanISO exch definefont pop \n\
--
-+\n\
- /Helvetica-Bold findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /HBoldISO exch definefont pop \n\
--
-+\n\
- /Helvetica-BoldOblique findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /HBoldItalicISO exch definefont pop \n\
--
-+\n\
- /Helvetica-Oblique findfont dup length dict begin { \n\
- 1 index /FID ne { def } { pop pop } ifelse \n\
- } forall \n\
- /Encoding ISOLatin1Encoding def \n\
- currentdict end \n\
- /HItalicISO exch definefont pop \n\
--
-+\n\
- %% \n\
- %% Ideally, before we can draw a line of text, we need to collect all the\n\
- %% words that will be on it, just as I do in my Beest HTML viewer, as well\n\
-@@ -318,39 +318,39 @@
- %% ----------- Functions ------------\n\
- /updateFont { \n\
- /f0 null def \n\
-- (Times) fontFamily eq (Times New Roman) fontFamily eq or {
-+ (Times) fontFamily eq (Times New Roman) fontFamily eq or {\n\
- bold { \n\
- italic { /TBoldItalicISO } { /TBoldISO } ifelse \n\
- } { \n\
- italic { /TItalicISO } { /TRomanISO } ifelse \n\
- } \n\
- ifelse \n\
-- } if
-- (Helvetica) fontFamily eq (Arial) fontFamily eq or {
-+ } if\n\
-+ (Helvetica) fontFamily eq (Arial) fontFamily eq or {\n\
- bold { \n\
- italic { /HBoldItalicISO } { /HBoldISO } ifelse \n\
- } { \n\
- italic { /HItalicISO } { /HRomanISO } ifelse \n\
- } \n\
- ifelse \n\
-- } if
-- (Courier) fontFamily eq (Courier New) fontFamily eq or {
-+ } if\n\
-+ (Courier) fontFamily eq (Courier New) fontFamily eq or {\n\
- bold { \n\
- italic { /CBoldItalicISO } { /CBoldISO } ifelse \n\
- } { \n\
- italic { /CItalicISO } { /CRomanISO } ifelse \n\
- } \n\
- ifelse \n\
-- } if
-- (Symbol) fontFamily eq {
-+ } if\n\
-+ (Symbol) fontFamily eq {\n\
- bold { \n\
- italic { /SBoldItalicISO } { /SBoldISO } ifelse \n\
- } { \n\
- italic { /SItalicISO } { /SRomanISO } ifelse \n\
- } \n\
- ifelse \n\
-- } if
--
-+ } if\n\
-+\n\
- findfont /f0 exch def \n\
- /bboxBottom f0 /FontBBox get 1 get 1000 div fontSize mul -1 mul def \n\
- /bboxTop f0 /FontBBox get 3 get 1000 div fontSize mul def \n\
-@@ -392,13 +392,13 @@
- } \n\
- def \n\
- /acharpath { \n\
-- /acstr exch def pop /acsp exch def
-- newpath
-- str {
-- /ch exch def
-- 1 string 0 ch put false charpath
-- acsp 0 rmoveto
-- } forall
-+ /acstr exch def pop /acsp exch def\n\
-+ newpath \n\
-+ str {\n\
-+ /ch exch def\n\
-+ 1 string 0 ch put false charpath\n\
-+ acsp 0 rmoveto\n\
-+ } forall\n\
- } def \n\
- /A { \n\
- /str exch def \n\
-@@ -412,7 +412,7 @@
- 1 -0.1 0 { \n\
- /offset exch def \n\
- offset setgray \n\
-- x offset 3 mul add y offset 3 mul sub moveto
-+ x offset 3 mul add y offset 3 mul sub moveto\n\
- intercharSpace 0 str acharpath \n\
- %% str false charpath \n\
- fontSize 30 div setlinewidth stroke \n\
-@@ -428,11 +428,11 @@
- 1 -0.1 0 { \n\
- /offset exch def \n\
- offset setgray \n\
-- x offset 3 mul add y offset 3 mul sub moveto
-+ x offset 3 mul add y offset 3 mul sub moveto\n\
- intercharSpace 0 str ashow \n\
- %% str show \n\
- } for \n\
-- 0 setgray
-+ 0 setgray\n\
- } { \n\
- intercharSpace 0 str ashow \n\
- %% str show \n\
diff --git a/textproc/unrtf/pkg-descr b/textproc/unrtf/pkg-descr
index 8347c059c3f3..076d389b336b 100644
--- a/textproc/unrtf/pkg-descr
+++ b/textproc/unrtf/pkg-descr
@@ -3,5 +3,7 @@ PostScript, plain text, and text with VT100 codes. When converting to HTML, it
supports tables, fonts, embedded images, hyperlinks, paragraph alignment, and
more. All other conversions are "alpha" i.e. being newly developed.
+WWW: http://www.gnu.org/software/unrtf/unrtf.html
+
-- Oliver Braun
obraun@informatik.unibw-muenchen.de
diff --git a/textproc/unrtf/pkg-plist b/textproc/unrtf/pkg-plist
index 79f02a0eb964..db24f10a671c 100644
--- a/textproc/unrtf/pkg-plist
+++ b/textproc/unrtf/pkg-plist
@@ -1,3 +1 @@
bin/unrtf
-%%PORTDOCS%%share/doc/unrtf/unrtf.html
-%%PORTDOCS%%@dirrm share/doc/unrtf