aboutsummaryrefslogtreecommitdiff
path: root/textproc/up
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2019-09-02 19:38:22 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2019-09-02 19:38:22 +0000
commit646077479f1487ec53fb52c0ff1a38f1718ae6d7 (patch)
tree8dbcdfaa075b7c27165c9356690d6ae42024f98e /textproc/up
parent6ad22ed69c9e4252c2dcf03ebf85201a3bec32a9 (diff)
downloadports-646077479f1487ec53fb52c0ff1a38f1718ae6d7.tar.gz
ports-646077479f1487ec53fb52c0ff1a38f1718ae6d7.zip
Notes
Diffstat (limited to 'textproc/up')
-rw-r--r--textproc/up/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/textproc/up/Makefile b/textproc/up/Makefile
index 44e6b742b30c..862ede76454a 100644
--- a/textproc/up/Makefile
+++ b/textproc/up/Makefile
@@ -11,27 +11,23 @@ COMMENT= Ultimate plumber, a tool for writing pipes with instant live preview
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= go
+USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= akavel
-GH_TUPLE= gdamore:encoding:b23993cbb635:encoding/src/github.com/gdamore/encoding \
- gdamore:tcell:493f3b46b3c2:tcell/src/github.com/gdamore/tcell \
- lucasb-eyer:go-colorful:231272389856:gocolorful/src/github.com/lucasb-eyer/go-colorful \
- mattn:go-isatty:v0.0.3:goisatty/src/github.com/mattn/go-isatty \
- mattn:go-runewidth:v0.0.2:gorunewidth/src/github.com/mattn/go-runewidth \
- spf13:pflag:v1.0.3:pflag/src/github.com/spf13/pflag \
- golang:text:f21a4dfb5e38:text/src/golang.org/x/text
+GH_TUPLE= gdamore:encoding:b23993cbb635:encoding/vendor/github.com/gdamore/encoding \
+ gdamore:tcell:493f3b46b3c2:tcell/vendor/github.com/gdamore/tcell \
+ lucasb-eyer:go-colorful:231272389856:gocolorful/vendor/github.com/lucasb-eyer/go-colorful \
+ mattn:go-isatty:v0.0.3:goisatty/vendor/github.com/mattn/go-isatty \
+ mattn:go-runewidth:v0.0.2:gorunewidth/vendor/github.com/mattn/go-runewidth \
+ spf13:pflag:v1.0.3:pflag/vendor/github.com/spf13/pflag \
+ golang:text:f21a4dfb5e38:text/vendor/golang.org/x/text
PLIST_FILES= bin/up
PORTDOCS= README.md
OPTIONS_DEFINE= DOCS
-post-extract:
- @${LN} -sf ${WRKSRC}/src ${WRKDIR}
- @${LN} -sf ${WRKSRC} ${GO_WRKSRC}
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}