aboutsummaryrefslogtreecommitdiff
path: root/textproc/wbxml2
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-05-11 11:19:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-05-11 11:19:05 +0000
commitb79e6158ee43e1d70005dae41070ec15b8d91f39 (patch)
tree2d3379403b1fbb83baba161c0d78d6fd3aaaedb5 /textproc/wbxml2
parent62189704021a54c34cd0876a109348109cc1fc6d (diff)
downloadports-b79e6158ee43e1d70005dae41070ec15b8d91f39.tar.gz
ports-b79e6158ee43e1d70005dae41070ec15b8d91f39.zip
Notes
Diffstat (limited to 'textproc/wbxml2')
-rw-r--r--textproc/wbxml2/Makefile6
-rw-r--r--textproc/wbxml2/distinfo6
-rw-r--r--textproc/wbxml2/files/noportdocs-CMakeLists.txt.diff11
-rw-r--r--textproc/wbxml2/files/patch-CMakeLists.txt12
-rw-r--r--textproc/wbxml2/pkg-plist26
5 files changed, 37 insertions, 24 deletions
diff --git a/textproc/wbxml2/Makefile b/textproc/wbxml2/Makefile
index 2403b9519410..cef8db78c604 100644
--- a/textproc/wbxml2/Makefile
+++ b/textproc/wbxml2/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= wbxml2
-PORTVERSION= 0.10.0
-PORTREVISION= 1
+PORTVERSION= 0.10.6
CATEGORIES= textproc devel
MASTER_SITES= SF
MASTER_SITE_SUBDIR= libwbxml
@@ -24,6 +23,9 @@ USE_CMAKE= YES
WRKSRC= ${WRKDIR}/libwbxml-${PORTVERSION}/build
CMAKE_SOURCE_PATH=..
PATCH_WRKSRC= ${WRKDIR}/libwbxml-${PORTVERSION}
+.if defined(NOPORTDOCS)
+EXTRA_PATCHES= ${FILESDIR}/noportdocs-CMakeLists.txt.diff
+.endif
pre-patch:
@cd ${PATCH_WRKSRC}
diff --git a/textproc/wbxml2/distinfo b/textproc/wbxml2/distinfo
index 51b2cc2cfece..e286af43eb20 100644
--- a/textproc/wbxml2/distinfo
+++ b/textproc/wbxml2/distinfo
@@ -1,3 +1,3 @@
-MD5 (libwbxml-0.10.0.tar.bz2) = faaa28938e22ba839ca5eafbdaa1543b
-SHA256 (libwbxml-0.10.0.tar.bz2) = 35cee44dcec64dce0672aa412df174f6e794445a708d7179be683cb37a2a103e
-SIZE (libwbxml-0.10.0.tar.bz2) = 314569
+MD5 (libwbxml-0.10.6.tar.bz2) = 2befb9116a82915f7ed4af0820d80a44
+SHA256 (libwbxml-0.10.6.tar.bz2) = 5cb7b5d63c88e6baf4a57e5e6157591de815d9582ee110f85a744c705571aab1
+SIZE (libwbxml-0.10.6.tar.bz2) = 349749
diff --git a/textproc/wbxml2/files/noportdocs-CMakeLists.txt.diff b/textproc/wbxml2/files/noportdocs-CMakeLists.txt.diff
new file mode 100644
index 000000000000..71dd152c32d1
--- /dev/null
+++ b/textproc/wbxml2/files/noportdocs-CMakeLists.txt.diff
@@ -0,0 +1,11 @@
+--- CMakeLists.txt.orig 2009-04-26 09:57:57.218017335 +0000
++++ CMakeLists.txt 2009-04-26 09:58:09.121018414 +0000
+@@ -158,7 +158,7 @@
+ # ADD_CUSTOM_TARGET( DoxygenDoc )
+ # ADD_DEPENDENCIES( DoxygenDoc DoxygenDocLibrary DoxygenDocTools )
+ #ENDIF ( BUILD_DOCUMENTATION )
+-OPTION( ENABLE_INSTALL_DOC "install documentation" ON )
++OPTION( ENABLE_INSTALL_DOC "install documentation" OFF )
+ IF( ENABLE_INSTALL_DOC )
+ ADD_DOCUMENTATION( TEXT FILE ${CMAKE_SOURCE_DIR}/AUTHORS )
+ ADD_DOCUMENTATION( TEXT FILE ${CMAKE_SOURCE_DIR}/BUGS )
diff --git a/textproc/wbxml2/files/patch-CMakeLists.txt b/textproc/wbxml2/files/patch-CMakeLists.txt
index 3fd578b25beb..ddfc3a10b857 100644
--- a/textproc/wbxml2/files/patch-CMakeLists.txt
+++ b/textproc/wbxml2/files/patch-CMakeLists.txt
@@ -1,11 +1,11 @@
---- CMakeLists.txt 2008-12-05 16:06:35.000000000 +0200
-+++ CMakeLists.txt 2008-12-06 15:09:44.000000000 +0200
-@@ -152,7 +152,7 @@
- ADD_DOCUMENTATION( TEXT FILE ${CMAKE_SOURCE_DIR}/TODO )
+--- CMakeLists.txt.orig 2009-04-24 14:49:51.000000000 +0000
++++ CMakeLists.txt 2009-04-26 09:57:23.953012704 +0000
+@@ -174,7 +174,7 @@
+ ENDIF( ENABLE_INSTALL_DOC )
# todo: add requires in pc file
--INSTALL( FILES "${CMAKE_CURRENT_BINARY_DIR}/libwbxml2.pc" DESTINATION "${LIB_INSTALL_DIR}/pkgconfig/" )
+-INSTALL( FILES "${CMAKE_CURRENT_BINARY_DIR}/libwbxml2.pc" DESTINATION "${LIBDATA_INSTALL_DIR}/pkgconfig/" )
+INSTALL( FILES "${CMAKE_CURRENT_BINARY_DIR}/libwbxml2.pc" DESTINATION "${CMAKE_INSTALL_PREFIX}/libdata/pkgconfig/" )
-
# status output
INCLUDE( ShowStatus )
+ MESSAGE( STATUS "==================================================" )
diff --git a/textproc/wbxml2/pkg-plist b/textproc/wbxml2/pkg-plist
index 6c962bffcd4a..673f5a04eaab 100644
--- a/textproc/wbxml2/pkg-plist
+++ b/textproc/wbxml2/pkg-plist
@@ -20,17 +20,17 @@ include/wbxml_tree_clb_xml.h
include/wbxml_config.h
lib/libwbxml2.so
lib/libwbxml2.so.0
-lib/libwbxml2.so.0.0.10
+lib/libwbxml2.so.0.0.15
libdata/pkgconfig/libwbxml2.pc
-share/doc/libwbxml/AUTHORS
-share/doc/libwbxml/BUGS
-share/doc/libwbxml/COPYING
-share/doc/libwbxml/ChangeLog
-share/doc/libwbxml/GNU-LGPL
-share/doc/libwbxml/INSTALL
-share/doc/libwbxml/NEWS
-share/doc/libwbxml/README
-share/doc/libwbxml/References
-share/doc/libwbxml/THANKS
-share/doc/libwbxml/TODO
-@dirrm share/doc/libwbxml
+%%PORTDOCS%%share/doc/libwbxml/AUTHORS
+%%PORTDOCS%%share/doc/libwbxml/BUGS
+%%PORTDOCS%%share/doc/libwbxml/COPYING
+%%PORTDOCS%%share/doc/libwbxml/ChangeLog
+%%PORTDOCS%%share/doc/libwbxml/GNU-LGPL
+%%PORTDOCS%%share/doc/libwbxml/INSTALL
+%%PORTDOCS%%share/doc/libwbxml/NEWS
+%%PORTDOCS%%share/doc/libwbxml/README
+%%PORTDOCS%%share/doc/libwbxml/References
+%%PORTDOCS%%share/doc/libwbxml/THANKS
+%%PORTDOCS%%share/doc/libwbxml/TODO
+%%PORTDOCS%%@dirrm share/doc/libwbxml