aboutsummaryrefslogtreecommitdiff
path: root/textproc/website
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-23 16:29:26 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-23 16:29:26 +0000
commit58a5950e4a2f7fc6505e13b0440bf7c27abac9f4 (patch)
treefb25d666655cac5121f7bad6659e7b3bea049b64 /textproc/website
parentd2fdb96332a3542416fcaf87ce625e45020f1fd1 (diff)
Notes
Diffstat (limited to 'textproc/website')
-rw-r--r--textproc/website/Makefile83
-rw-r--r--textproc/website/distinfo4
-rw-r--r--textproc/website/files/pkg-deinstall.in4
-rw-r--r--textproc/website/files/pkg-install.in6
-rw-r--r--textproc/website/pkg-plist347
5 files changed, 224 insertions, 220 deletions
diff --git a/textproc/website/Makefile b/textproc/website/Makefile
index dabc595dcefe..1195e5d984a9 100644
--- a/textproc/website/Makefile
+++ b/textproc/website/Makefile
@@ -2,75 +2,48 @@
# $FreeBSD$
PORTNAME= website
-PORTVERSION= 2.5.0
-PORTREVISION= 1
+PORTVERSION= 2.6.0
CATEGORIES= textproc www
-MASTER_SITES= SF/docbook/OldFiles
+MASTER_SITES= SF/docbook/${PORTNAME}/${PORTVERSION}
+DISTNAME= docbook-${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Doctype and stylesheets for making websites
-RUN_DEPENDS= ${LOCALBASE}/share/xsl/docbook/catalog:${PORTSDIR}/textproc/docbook-xsl
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= docbook-xsl>0:${PORTSDIR}/textproc/docbook-xsl
+
+NO_ARCH= yes
+NO_BUILD= yes
+
+USES= tar:bzip2
+
+SUB_FILES= pkg-deinstall pkg-install
+SUB_LIST= XMLCATMGR="${XMLCATMGR}" \
+ CATALOG_PORTS_XML="${CATALOG_PORTS}" \
+ INSTDIR="${INSTDIR}"
+
+OPTIONS_DEFINE= EXAMPLES
XMLDIR= ${LOCALBASE}/share/xml
INSTDIR= share/xsl/website
PINSTDIR= ${PREFIX}/${INSTDIR}
-COPYDIRS= extensions schema tests xsl
+COPYDIRS= extensions schema xsl
-PKGINSTALL= ${WRKSRC}/pkg-install
-PKGDEINSTALL= ${WRKSRC}/pkg-deinstall
-
-NO_BUILD= yes
XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
CATALOG_PORTS= ${XMLDIR}/catalog.ports
-CATALOG_XSL= ${WRKSRC}/catalog
-
-DXVERSIONS= current 2.2 2.3 2.4.0 2.4.1 2.5.0
-
-NO_STAGE= yes
-post-extract:
- ${FIND} ${WRKSRC} -name '.#*' -delete
do-install:
-.ifndef NOPORTDOCS
- ${MKDIR} ${EXAMPLESDIR}
- (cd ${WRKSRC}/example && ${TAR} -cf - . |\
- ${TAR} -xf - -C${EXAMPLESDIR})
-.endif
- ${XMLCATMGR} -c "${CATALOG_XSL}" create
-.for dxversion in ${DXVERSIONS}
- ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteSystem \
- http://docbook.sourceforge.net/release/website/${dxversion}/xsl \
- "file://${PREFIX}/${INSTDIR}/xsl"
- ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteURI \
- http://docbook.sourceforge.net/release/website/${dxversion}/xsl \
- "file://${PREFIX}/${INSTDIR}/xsl"
- ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteSystem \
- http://docbook.sourceforge.net/release/website/${dxversion}/schema/dtd \
- "file://${PREFIX}/${INSTDIR}/schema/dtd"
- ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteURI \
- http://docbook.sourceforge.net/release/website/${dxversion}/schema/dtd \
- "file://${PREFIX}/${INSTDIR}/schema/dtd"
- ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteSystem \
- http://docbook.sourceforge.net/release/website/${dxversion} \
- "file://${PREFIX}/${INSTDIR}/schema/dtd"
- ${XMLCATMGR} -c "${CATALOG_XSL}" add rewriteURI \
- http://docbook.sourceforge.net/release/website/${dxversion} \
- "file://${PREFIX}/${INSTDIR}/schema/dtd"
+ @${MKDIR} ${STAGEDIR}${PINSTDIR}
+.for i in VERSION catalog
+ (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${PINSTDIR})
.endfor
- ${MKDIR} ${PINSTDIR}
- (cd ${WRKSRC} && ${TAR} -cf - VERSION catalog ${COPYDIRS} |\
- ${TAR} -xf - -C${PINSTDIR})
-
-post-install:
- @${SED} -e 's,@INSTDIR@,${INSTDIR},g ; \
- s,@XMLCATMGR@,${XMLCATMGR},g ; \
- s,@CATALOG_PORTS_XML@,${CATALOG_PORTS},g' \
- < ${FILESDIR}/pkg-install.in > ${PKGINSTALL}
- @${SED} -e 's,@XMLCATMGR@,${XMLCATMGR},g ; \
- s,@CATALOG_PORTS_XML@,${CATALOG_PORTS},g' \
- < ${FILESDIR}/pkg-deinstall.in > ${PKGDEINSTALL}
- @${SETENV} PKG_PREFIX=${PREFIX} \
- ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+.for i in ${COPYDIRS}
+ @(cd ${WRKSRC} && ${COPYTREE_SHARE} ${i} ${STAGEDIR}${PINSTDIR})
+.endfor
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @(cd ${WRKSRC}/example && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR})
.include <bsd.port.mk>
diff --git a/textproc/website/distinfo b/textproc/website/distinfo
index a1d0c1ed8d95..a721c592a844 100644
--- a/textproc/website/distinfo
+++ b/textproc/website/distinfo
@@ -1,2 +1,2 @@
-SHA256 (website-2.5.0.tar.gz) = e36a30dce6be08ca274846f7e4a2f5ff1c395af0a31996c9a316665485308b0d
-SIZE (website-2.5.0.tar.gz) = 135313
+SHA256 (docbook-website-2.6.0.tar.bz2) = 0e8da409d557c72dccc709b59579665fe2089bc8840e30b1162d4ad81e825804
+SIZE (docbook-website-2.6.0.tar.bz2) = 172118
diff --git a/textproc/website/files/pkg-deinstall.in b/textproc/website/files/pkg-deinstall.in
index 40632aa8268c..05190bd3098a 100644
--- a/textproc/website/files/pkg-deinstall.in
+++ b/textproc/website/files/pkg-deinstall.in
@@ -2,8 +2,8 @@
# This script will remove the website entries added to xml catalog.
# -- Rui Lopes <rui@ruilopes.com>
-XMLCATMGR=@XMLCATMGR@
-CATALOG_PORTS_XML=@CATALOG_PORTS_XML@
+XMLCATMGR=%%XMLCATMGR%%
+CATALOG_PORTS_XML=%%CATALOG_PORTS_XML%%
if [ "$2" != "POST-DEINSTALL" ]; then
exit 0
diff --git a/textproc/website/files/pkg-install.in b/textproc/website/files/pkg-install.in
index dc98b61b5764..612af1337d0a 100644
--- a/textproc/website/files/pkg-install.in
+++ b/textproc/website/files/pkg-install.in
@@ -9,9 +9,9 @@
#
# -- Rui Lopes <rui@ruilopes.com>
-XMLCATMGR=@XMLCATMGR@
-CATALOG_PORTS_XML=@CATALOG_PORTS_XML@
-XSL_DIR=${PKG_PREFIX}/@INSTDIR@
+XMLCATMGR=%%XMLCATMGR%%
+CATALOG_PORTS_XML=%%CATALOG_PORTS_XML%%
+XSL_DIR=${PKG_PREFIX}/%%INSTDIR%%
CATALOG_XSL=${XSL_DIR}/catalog
if [ "$2" != "POST-INSTALL" ]; then
diff --git a/textproc/website/pkg-plist b/textproc/website/pkg-plist
index 5a7e8d9d983f..2defeb167a21 100644
--- a/textproc/website/pkg-plist
+++ b/textproc/website/pkg-plist
@@ -1,124 +1,147 @@
-%%PORTDOCS%%%%EXAMPLESDIR%%/.tabular
-%%PORTDOCS%%%%EXAMPLESDIR%%/.textonly
-%%PORTDOCS%%%%EXAMPLESDIR%%/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/about.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/about.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/autolayout.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/bookmark/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/bookmark/bookmark.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/bookmark/catalog
-%%PORTDOCS%%%%EXAMPLESDIR%%/bookmark/xml.dcl
-%%PORTDOCS%%%%EXAMPLESDIR%%/build-ext.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/build-make.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/build-textonly.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/build.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/buildext.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/building.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/building.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/buildmake.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/catalog.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/custom.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/custom.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/dynxbel.js
-%%PORTDOCS%%%%EXAMPLESDIR%%/example.css
-%%PORTDOCS%%%%EXAMPLESDIR%%/formtest.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/full.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/full.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/.xvpics/spacer.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/arrow.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/banner.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/blank.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/homebanner.png
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/icons/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/icons/iconat.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/icons/iconhome.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/icons/iconsmallrightarrow.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/added.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/changed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/pointer.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/closed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/added.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/changed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/pointer.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/closed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/added.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/changed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/pointer.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/closed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/added.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/changed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/pointer.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/closed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/added.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/changed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/pointer.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/closed.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/leaf.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/open.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/graphics/spacer.gif
-%%PORTDOCS%%%%EXAMPLESDIR%%/index.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/layout.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/layout.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/linking.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/olink.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/param.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/php.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/php.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/rddl.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/rddl.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/revflag.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/revflag.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/rss.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/rss.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/subdir/ChangeLog
-%%PORTDOCS%%%%EXAMPLESDIR%%/subdir/test1a.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/subdir/test1b.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/subdir/txttest1a.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/subdir/txttest1b.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/test1.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/test1.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/test1a.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/test1b.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/test2.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/test3.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/test3.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/textonly.html
-%%PORTDOCS%%%%EXAMPLESDIR%%/website.xml
-%%PORTDOCS%%%%EXAMPLESDIR%%/wslayout.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/Makefile-example.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/about.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/about.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/autolayout.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bookmark/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bookmark/bookmark.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bookmark/catalog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bookmark/xml.dcl
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/build-ext.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/build-make.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/build-nontab.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/build.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/buildext.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/building.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/building.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/buildmake.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/catalog.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/custom.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/custom.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/depends.nontabular
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/depends.tabular
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dynxbel.js
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/formtest.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/full.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/full.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/arrow.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/banner.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/blank.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/homebanner.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/icons/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/icons/iconat.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/icons/iconhome.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/icons/iconsmallrightarrow.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/added.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/changed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/current/pointer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/closed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/arrow/other/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/added.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/changed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/current/pointer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/closed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder/other/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/added.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/changed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/current/pointer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/closed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/folder16/other/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/added.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/changed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/current/pointer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/closed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/plusminus/other/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/added.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/changed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/current/pointer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/closed.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/leaf.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/navicons/triangle/other/open.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/note.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/note.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/note.svg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/note.tif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/graphics/spacer.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/layout.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/linking.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-about.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-buildext.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-building.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-buildmake.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-custom.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-formtest.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-full.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-index.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-layout.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-linking.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-nontab.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-php.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-rddl.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-revflag.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-rss.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-test1.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/n-test3.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/nontab.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/olink.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/param.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/php.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/php.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rddl.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rddl.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/revflag.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/revflag.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rss.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rss.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/subdir/.cvskeepemptydir
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/subdir/ChangeLog
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/subdir/n-test1a.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/subdir/n-test1b.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/subdir/test1a.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/subdir/test1b.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1a.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test1b.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test2.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test3.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test3.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website.database.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/website.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/wslayout.xml
share/xsl/website/VERSION
share/xsl/website/catalog
share/xsl/website/extensions/ChangeLog
@@ -126,12 +149,10 @@ share/xsl/website/extensions/saxon64.jar
share/xsl/website/extensions/saxon64/ChangeLog
share/xsl/website/extensions/saxon64/com/nwalsh/saxon/ChangeLog
share/xsl/website/extensions/saxon64/com/nwalsh/saxon/Website.java
-share/xsl/website/extensions/saxon64/prj.el
share/xsl/website/extensions/xalan2.jar
share/xsl/website/extensions/xalan2/ChangeLog
share/xsl/website/extensions/xalan2/com/nwalsh/xalan/ChangeLog
share/xsl/website/extensions/xalan2/com/nwalsh/xalan/Website.java
-share/xsl/website/extensions/xalan2/prj.el
share/xsl/website/schema/ChangeLog
share/xsl/website/schema/dtd/ChangeLog
share/xsl/website/schema/dtd/autolayout.dtd
@@ -145,22 +166,35 @@ share/xsl/website/schema/dtd/website-full.dtd
share/xsl/website/schema/dtd/website.dtd
share/xsl/website/schema/dtd/website.mod
share/xsl/website/schema/relaxng/ChangeLog
+share/xsl/website/schema/relaxng/autolayout.rnc
share/xsl/website/schema/relaxng/autolayout.rng
-share/xsl/website/schema/relaxng/config.xml
-share/xsl/website/schema/relaxng/extensions.rng
-share/xsl/website/schema/relaxng/forms.rng
+share/xsl/website/schema/relaxng/calstblx.rnc
+share/xsl/website/schema/relaxng/calstblx.rng
+share/xsl/website/schema/relaxng/dbhierx.mod.rnc
+share/xsl/website/schema/relaxng/dbhierx.mod.rng
+share/xsl/website/schema/relaxng/dbpoolx.mod.rnc
+share/xsl/website/schema/relaxng/dbpoolx.mod.rng
+share/xsl/website/schema/relaxng/docbookx.rnc
+share/xsl/website/schema/relaxng/docbookx.rng
+share/xsl/website/schema/relaxng/extensions.mod.rnc
+share/xsl/website/schema/relaxng/extensions.mod.rng
+share/xsl/website/schema/relaxng/forms.mod.rnc
+share/xsl/website/schema/relaxng/forms.mod.rng
+share/xsl/website/schema/relaxng/htmltblx.mod.rnc
+share/xsl/website/schema/relaxng/htmltblx.mod.rng
+share/xsl/website/schema/relaxng/layout.rnc
share/xsl/website/schema/relaxng/layout.rng
-share/xsl/website/schema/relaxng/rddl.rng
-share/xsl/website/schema/relaxng/union.xml
+share/xsl/website/schema/relaxng/namespaces.mod.rnc
+share/xsl/website/schema/relaxng/namespaces.mod.rng
+share/xsl/website/schema/relaxng/rddl.mod.rnc
+share/xsl/website/schema/relaxng/rddl.mod.rng
+share/xsl/website/schema/relaxng/website-full.rnc
share/xsl/website/schema/relaxng/website-full.rng
+share/xsl/website/schema/relaxng/website.mod.rnc
+share/xsl/website/schema/relaxng/website.mod.rng
+share/xsl/website/schema/relaxng/website.rnc
share/xsl/website/schema/relaxng/website.rng
-share/xsl/website/schema/relaxng/websitedb.rng
-share/xsl/website/tests/ChangeLog
-share/xsl/website/tests/test.xml
-share/xsl/website/tests/testcust.xml
-share/xsl/website/tests/testfull.xml
share/xsl/website/xsl/ChangeLog
-share/xsl/website/xsl/VERSION
share/xsl/website/xsl/autolayout.xsl
share/xsl/website/xsl/chunk-common.xsl
share/xsl/website/xsl/chunk-tabular.xsl
@@ -178,7 +212,6 @@ share/xsl/website/xsl/website-targets.xsl
share/xsl/website/xsl/website.xsl
share/xsl/website/xsl/xbel.xsl
@dirrm share/xsl/website/xsl
-@dirrm share/xsl/website/tests
@dirrm share/xsl/website/schema/relaxng
@dirrm share/xsl/website/schema/dtd
@dirrm share/xsl/website/schema
@@ -192,26 +225,24 @@ share/xsl/website/xsl/xbel.xsl
@dirrm share/xsl/website/extensions/saxon64
@dirrm share/xsl/website/extensions
@dirrm share/xsl/website
-@dirrmtry share/xsl
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/subdir
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/triangle/other
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/triangle/current
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/triangle
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/plusminus/other
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/plusminus/current
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/plusminus
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder16/other
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder16/current
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder16
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder/other
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder/current
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/arrow/other
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/arrow/current
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/arrow
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/navicons
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/icons
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics/.xvpics
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/graphics
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/bookmark
-%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/subdir
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/triangle/other
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/triangle/current
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/triangle
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/plusminus/other
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/plusminus/current
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/plusminus
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder16/other
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder16/current
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder16
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder/other
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder/current
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/folder
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/arrow/other
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/arrow/current
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons/arrow
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/navicons
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics/icons
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/graphics
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/bookmark
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%