aboutsummaryrefslogtreecommitdiff
path: root/textproc/wordnet/Makefile
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2001-10-31 05:04:29 +0000
committerMikhail Teterin <mi@FreeBSD.org>2001-10-31 05:04:29 +0000
commit7e04dc48fd8b42fb3951ce1736e8c229d122d48e (patch)
tree8b7ff7b8d2ab75b39b6294ca28a9579915923413 /textproc/wordnet/Makefile
parent6c5b827b78fea2c1a0f42738b1921608e71e9e91 (diff)
Notes
Diffstat (limited to 'textproc/wordnet/Makefile')
-rw-r--r--textproc/wordnet/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/textproc/wordnet/Makefile b/textproc/wordnet/Makefile
index 521dbdb0c36d..13d769cc548e 100644
--- a/textproc/wordnet/Makefile
+++ b/textproc/wordnet/Makefile
@@ -6,33 +6,29 @@
#
PORTNAME= wordnet
-PORTVERSION= 1.6
+PORTVERSION= 1.7
CATEGORIES= textproc
-MASTER_SITES= ftp://ftp.cogsci.princeton.edu/pub/wordnet/ \
+MASTER_SITES= ftp://ftp.cogsci.princeton.edu/pub/wordnet/${PORTVERSION}/ \
ftp://ftp.ims.uni-stuttgart.de/pub/WordNet/${PORTVERSION}/
-DISTFILES= wn16.unix.tar.gz
+DISTFILES= wn${PORTVERSION:S/.//}.unix.tar.gz
MAINTAINER= mi@aldan.algebra.com
LIB_DEPENDS= tk83.1:${PORTSDIR}/x11-toolkits/tk83
-MAN1= wn.1 wnb.1 wnintro.1
-MAN3= binsrch.3 morph.3 wnintro.3 wnsearch.3 wnutil.3
-MAN5= cntlist.5 glossidx.5 lexnames.5 senseidx.5 taglist.5 \
- wndb.5 wninput.5 wnintro.5
-MAN7= morphy.7 uniqbeg.7 wngloss.7 wngroups.7 wnintro.7 \
- wnlicens.7 wnpkgs.7 wnstats.7
-MANCOMPRESSED= maybe
-
TCL_DVER= 8.3
SCRIPTS_ENV+= TCL_DVER=${TCL_DVER}
MAKE_ENV+= TCL_DVER=${TCL_DVER}
-PLIST_SUB+= TCL_DVER=${TCL_DVER}
+PLIST_SUB+= TCL_DVER=${TCL_DVER} VER=${PORTVERSION}
# Parallel build is faster even on a single cpu machine:
MAKE_ARGS= -j 2
+NO_WRKSUBDIR= yes
-post-extract:
- # bin and lib contain useless pre-built binaries:
- ${RM} -rf ${WRKSRC}/bin ${WRKSRC}/lib
+.include <bsd.port.pre.mk>
+
+.for s in 1 3 5 7
+MAN$s!= ${MAKE} -f ${FILESDIR}/man.Makefile -V MAN$s
+.endfor
+MANCOMPRESSED= maybe
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>