aboutsummaryrefslogtreecommitdiff
path: root/textproc/wordnet/Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-01 02:40:51 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-01 02:40:51 +0000
commit2a0e4eb4127137582286dcbc1c37903411a7415c (patch)
tree6ab3523a0051415213493d04aa9e9587414918cd /textproc/wordnet/Makefile
parent0c4c0e292e8493d43c0f6032e4bbdd84ccfbd751 (diff)
downloadports-2a0e4eb4127137582286dcbc1c37903411a7415c.tar.gz
ports-2a0e4eb4127137582286dcbc1c37903411a7415c.zip
Notes
Diffstat (limited to 'textproc/wordnet/Makefile')
-rw-r--r--textproc/wordnet/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/textproc/wordnet/Makefile b/textproc/wordnet/Makefile
new file mode 100644
index 000000000000..45a661f9e169
--- /dev/null
+++ b/textproc/wordnet/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: wordnet
+# Date created: 26 Feb 2000
+# Whom: Mikhail Teterin <mi@aldan.algebra.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wordnet
+PORTVERSION= 1.6
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.cogsci.princeton.edu/pub/wordnet/ \
+ ftp://ftp.ims.uni-stuttgart.de/pub/WordNet/${PORTVERSION}/
+DISTNAME= wn16.unix
+
+MAINTAINER= mi@aldan.algebra.com
+
+LIB_DEPENDS= tk82.1:${PORTSDIR}/x11-toolkits/tk82
+
+MAN1= wn.1 wnb.1 wnintro.1
+MAN3= binsrch.3 morph.3 wnintro.3 wnsearch.3 wnutil.3
+MAN5= cntlist.5 glossidx.5 lexnames.5 senseidx.5 taglist.5 \
+ wndb.5 wninput.5 wnintro.5
+MAN7= morphy.7 uniqbeg.7 wngloss.7 wngroups.7 wnintro.7 \
+ wnlicens.7 wnpkgs.7 wnstats.7
+MANCOMPRESSED= maybe
+
+WRKSRC= ${WRKDIR}/${PKGNAME}
+
+TCL_DVER= 8.2
+SCRIPTS_ENV+= TCL_DVER=${TCL_DVER}
+MAKE_ENV+= TCL_DVER=${TCL_DVER}
+PLIST_SUB+= TCL_DVER=${TCL_DVER}
+# Parallel build is faster even on a single cpu machine:
+MAKE_ARGS= -j 2
+
+post-extract:
+ # bin and lib contain useless pre-built binaries:
+ ${RM} -rf ${WRKSRC}/bin ${WRKSRC}/lib
+
+.include <bsd.port.mk>