aboutsummaryrefslogtreecommitdiff
path: root/textproc/wordnet/files/src.wnb.Makefile
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2000-05-01 02:40:51 +0000
committerSteve Price <steve@FreeBSD.org>2000-05-01 02:40:51 +0000
commit2a0e4eb4127137582286dcbc1c37903411a7415c (patch)
tree6ab3523a0051415213493d04aa9e9587414918cd /textproc/wordnet/files/src.wnb.Makefile
parent0c4c0e292e8493d43c0f6032e4bbdd84ccfbd751 (diff)
downloadports-2a0e4eb4127137582286dcbc1c37903411a7415c.tar.gz
ports-2a0e4eb4127137582286dcbc1c37903411a7415c.zip
Notes
Diffstat (limited to 'textproc/wordnet/files/src.wnb.Makefile')
-rw-r--r--textproc/wordnet/files/src.wnb.Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/textproc/wordnet/files/src.wnb.Makefile b/textproc/wordnet/files/src.wnb.Makefile
new file mode 100644
index 000000000000..3089aa4ea538
--- /dev/null
+++ b/textproc/wordnet/files/src.wnb.Makefile
@@ -0,0 +1,41 @@
+PREFIX?= /usr/local
+TCL_DVER?= 8.2
+TCL_VER= ${TCL_DVER:S/.//g}
+TCL_INCDIR?= ${PREFIX}/include/tcl${TCL_DVER}
+
+CFLAGS+= -DUNIX -DDEFAULTPATH="\"${PREFIX}/share/wordnet-1.6\"" \
+ -DDEFAULTBIN="\"${PREFIX}/bin\""
+
+CFLAGS+= -I${.CURDIR}/../../include -I$(TCL_INCDIR)
+
+LDADD= -L../lib -lwn1 -L${PREFIX}/lib -ltcl${TCL_VER} -ltk${TCL_VER}
+
+LIB= tclwn1
+SHLIB_MAJOR= 6
+SHLIB_MINOR= 0
+SRCS= stubs.c
+
+INTERNALLIB= True # To avoid building the useless static library
+
+all: ${SHLIB_NAME} pkgIndex.tcl
+
+pkgIndex.tcl:
+ echo "package ifneeded Wordnet 1.6 [list load \
+ [file join ${PREFIX}/lib ${SHLIB_NAME}] Wordnet]" \
+ > pkgIndex.tcl
+
+LIBDIR= ${PREFIX}/lib
+RESDIR= ${PREFIX}/share/wordnet-1.6/wnres
+
+${LIBDIR} ${RESDIR} ${LIBDIR}/tcl${TCL_DVER}/Wordnet:
+ mkdir -p ${.TARGET}
+
+beforeinstall: ${LIBDIR} ${RESDIR} ${LIBDIR}/tcl${TCL_DVER}/Wordnet
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 \
+ pkgIndex.tcl ${LIBDIR}/tcl${TCL_DVER}/Wordnet
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 444 \
+ ${.CURDIR}/../lib/wnres/*.* ${RESDIR}
+ ${INSTALL} -C -o ${BINOWN} -g ${BINGRP} -m 755 \
+ wnb ${PREFIX}/bin
+
+.include <bsd.lib.mk>