aboutsummaryrefslogtreecommitdiff
path: root/textproc/wv2
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-08-29 12:45:31 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-08-29 12:45:31 +0000
commit9aabd9f1aeb6c21a1504509cfe6219569e7a984c (patch)
tree4a389cebd54b4cc27f0997e0433d1e74d7e977e7 /textproc/wv2
parentf071e23211cabfa01100a0db6b9da6b02b1c58c5 (diff)
downloadports-9aabd9f1aeb6c21a1504509cfe6219569e7a984c.tar.gz
ports-9aabd9f1aeb6c21a1504509cfe6219569e7a984c.zip
Notes
Diffstat (limited to 'textproc/wv2')
-rw-r--r--textproc/wv2/files/patch-CMakeLists.txt58
-rw-r--r--textproc/wv2/files/patch-cmake_FindIconv.cmake14
2 files changed, 8 insertions, 64 deletions
diff --git a/textproc/wv2/files/patch-CMakeLists.txt b/textproc/wv2/files/patch-CMakeLists.txt
index 71bc3f581765..5a5a2ba5b713 100644
--- a/textproc/wv2/files/patch-CMakeLists.txt
+++ b/textproc/wv2/files/patch-CMakeLists.txt
@@ -1,55 +1,13 @@
---- ./CMakeLists.txt.orig 2009-08-27 08:46:40.000000000 +1100
-+++ ./CMakeLists.txt 2009-09-16 10:21:34.000000000 +1100
-@@ -42,7 +42,7 @@
-
- INCLUDE( CheckIncludeFile )
-
--CHECK_INCLUDE_FILE( sys/iconv.h HAVE_SYS_ICONV_H )
-+#CHECK_INCLUDE_FILE( sys/iconv.h HAVE_SYS_ICONV_H )
-
- # Add "COMPILE_DEFINITIONS definitions" to TRY_RUN only if we have compile definitions
-
-@@ -59,19 +59,22 @@
+--- CMakeLists.txt
++++ CMakeLists.txt
+@@ -59,7 +59,9 @@
SET( ICONV_COMPILE_DEFINITIONS ${ICONV_COMPILE_DEFINITIONS} "-DHAVE_SYS_ICONV_H" )
ENDIF( HAVE_SYS_ICONV_H )
-TRY_RUN( MODERN_ICONV_RUN MODERN_ICONV_COMPILE ${wvWare_BINARY_DIR}/CMakeTmp ${wvWare_SOURCE_DIR}/cmake/TestModernIconv.c COMPILE_DEFINITIONS ${ICONV_COMPILE_DEFINITIONS} )
-+#TRY_RUN( MODERN_ICONV_RUN MODERN_ICONV_COMPILE ${wvWare_BINARY_DIR}/CMakeTmp ${wvWare_SOURCE_DIR}/cmake/TestModernIconv.c COMPILE_DEFINITIONS ${ICONV_COMPILE_DEFINITIONS} )
-
--IF( MODERN_ICONV_RUN GREATER 0 OR NOT MODERN_ICONV_COMPILE )
-- MESSAGE( STATUS "wv2 depends on a modern iconv installation, supporting UNICODELITTLE and" )
-- MESSAGE( STATUS "UNICODEBIG. The detected iconv version doesn't support these conversions." )
-- MESSAGE( STATUS "" )
-- MESSAGE( STATUS "Please get a new libiconv from http://www.gnu.org/software/libiconv/" )
-- MESSAGE( STATUS "You might want to install the library to some alternative directory, in" )
-- MESSAGE( STATUS "order not to overwrite your current installation. Please use the options" )
-- MESSAGE( STATUS "-DICONV_INCLUDE_DIR=DIR and -DICONV_LIBRARIES=DIR to specify the location." )
-- MESSAGE( STATUS "" )
-- MESSAGE( FATAL_ERROR "* * * No iconv support - unable to continue. * * *" )
--ENDIF( MODERN_ICONV_RUN GREATER 0 OR NOT MODERN_ICONV_COMPILE )
-+SET( MODERN_ICONV_RUN 1)
-+SET( MODERN_ICONV_COMPILE 1 )
-+
-+#IF( MODERN_ICONV_RUN GREATER 0 OR NOT MODERN_ICONV_COMPILE )
-+# MESSAGE( STATUS "wv2 depends on a modern iconv installation, supporting UNICODELITTLE and" )
-+# MESSAGE( STATUS "UNICODEBIG. The detected iconv version doesn't support these conversions." )
-+# MESSAGE( STATUS "" )
-+# MESSAGE( STATUS "Please get a new libiconv from http://www.gnu.org/software/libiconv/" )
-+# MESSAGE( STATUS "You might want to install the library to some alternative directory, in" )
-+# MESSAGE( STATUS "order not to overwrite your current installation. Please use the options" )
-+# MESSAGE( STATUS "-DICONV_INCLUDE_DIR=DIR and -DICONV_LIBRARIES=DIR to specify the location." )
-+# MESSAGE( STATUS "" )
-+# MESSAGE( FATAL_ERROR "* * * No iconv support - unable to continue. * * *" )
-+#ENDIF( MODERN_ICONV_RUN GREATER 0 OR NOT MODERN_ICONV_COMPILE )
-
- #
- # Various checks
-@@ -157,6 +160,8 @@
- SET( _WV2_CFLAGS ${_WV2_CFLAGS} ${GLIB2_INCLUDE_DIR} )
- ENDIF( GLIB2_FOUND )
++TRY_RUN( MODERN_ICONV_RUN MODERN_ICONV_COMPILE ${wvWare_BINARY_DIR}/CMakeTmp ${wvWare_SOURCE_DIR}/cmake/TestModernIconv.c
++ COMPILE_DEFINITIONS ${ICONV_COMPILE_DEFINITIONS}
++ CMAKE_FLAGS -DINCLUDE_DIRECTORIES=${ICONV_INCLUDE_DIR} -DLINK_LIBRARIES=${ICONV_LIBRARIES} )
-+SET( _WV2_CFLAGS "${_WV2_CFLAGS} -I${CMAKE_INSTALL_PREFIX}/include/wv2" )
-+
- #
- # Clean and prepare
- #
+ IF( MODERN_ICONV_RUN GREATER 0 OR NOT MODERN_ICONV_COMPILE )
+ MESSAGE( STATUS "wv2 depends on a modern iconv installation, supporting UNICODELITTLE and" )
diff --git a/textproc/wv2/files/patch-cmake_FindIconv.cmake b/textproc/wv2/files/patch-cmake_FindIconv.cmake
deleted file mode 100644
index 1d03bef5ee8b..000000000000
--- a/textproc/wv2/files/patch-cmake_FindIconv.cmake
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./cmake/FindIconv.cmake.orig 2009-08-27 08:46:40.000000000 +1100
-+++ ./cmake/FindIconv.cmake 2009-09-16 09:41:24.000000000 +1100
-@@ -13,9 +13,9 @@
- SET(ICONV_FIND_QUIETLY TRUE)
- ENDIF (ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
-
--FIND_PATH(ICONV_INCLUDE_DIR iconv.h)
-+FIND_PATH(ICONV_INCLUDE_DIR iconv.h PATHS /usr/local/include /usr/include )
-
--FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2 c)
-+FIND_LIBRARY(ICONV_LIBRARIES NAMES iconv libiconv libiconv-2 c PATHS /usr/local/lib /usr/lib )
-
- IF(ICONV_INCLUDE_DIR AND ICONV_LIBRARIES)
- SET(ICONV_FOUND TRUE)