aboutsummaryrefslogtreecommitdiff
path: root/textproc/xaira/Makefile
diff options
context:
space:
mode:
authorThomas Abthorpe <tabthorpe@FreeBSD.org>2007-09-19 12:21:34 +0000
committerThomas Abthorpe <tabthorpe@FreeBSD.org>2007-09-19 12:21:34 +0000
commit1fe85dfab66eb173c7f4bd9d7f320e59b147e06f (patch)
tree7743eb04477a15769964a1b1674438782b5f9a87 /textproc/xaira/Makefile
parent189797a349ad57fe6e6d4920427594de084145fb (diff)
downloadports-1fe85dfab66eb173c7f4bd9d7f320e59b147e06f.tar.gz
ports-1fe85dfab66eb173c7f4bd9d7f320e59b147e06f.zip
Notes
Diffstat (limited to 'textproc/xaira/Makefile')
-rw-r--r--textproc/xaira/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/textproc/xaira/Makefile b/textproc/xaira/Makefile
new file mode 100644
index 000000000000..190ef6a065e3
--- /dev/null
+++ b/textproc/xaira/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: xaira
+# Date created: 10 September 2007
+# Whom: Mathias Monnerville <mathias@monnerville.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xaira
+PORTVERSION= 1.23
+CATEGORIES= textproc
+MASTER_SITES= SF
+
+MAINTAINER= mathias@monnerville.com
+COMMENT= XML Aware Indexing and Retrieval Architecture
+
+LIB_DEPENDS= xerces-c:${PORTSDIR}/textproc/xerces-c2 \
+ icuio:${PORTSDIR}/devel/icu
+BUILD_DEPENDS= ${LIBTOOL}:${PORTSDIR}/devel/libtool15
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= aclocal:19 autoconf:259 libtool:15
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+USE_RC_SUBR= xaira-server
+SUB_FILES+= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+OPTIONS= PHP5 "Build PHP5 extension" no
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_PHP5)
+BUILD_DEPENDS+= php5>=5:${PORTSDIR}/lang/php5
+CONFIGURE_ARGS+= --with-php5=`${LOCALBASE}/bin/php-config --include-dir`
+PLIST_FILES+= lib/libphpXaira.a \
+ lib/libphpXaira.la \
+ lib/libphpXaira.so \
+ lib/libphpXaira.so.0
+.endif
+
+post-patch:
+ @${FIND} ${WRKSRC} -name Makefile.am -exec \
+ ${REINPLACE_CMD} -e 's,^AM_CPPFLAGS.*$$,& $${icu_cppflags},' {} \;
+
+pre-configure:
+ @${CP} ${LIBTOOL_SHAREDIR}/libltdl/acinclude.m4 ${WRKSRC}/
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>