aboutsummaryrefslogtreecommitdiff
path: root/textproc/xerces-c2-devel
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>2002-11-15 17:00:34 +0000
committerSADA Kenji <sada@FreeBSD.org>2002-11-15 17:00:34 +0000
commitc346fa3fa533e3f0c542e9b4b6ed025d9dd0d6f1 (patch)
treef92e1b25f1097c1621e0157530b73286dc65963d /textproc/xerces-c2-devel
parent1b6f3b8cd3b440687e1a1a817487a76a82d636dd (diff)
downloadports-c346fa3fa533e3f0c542e9b4b6ed025d9dd0d6f1.tar.gz
ports-c346fa3fa533e3f0c542e9b4b6ed025d9dd0d6f1.zip
Notes
Diffstat (limited to 'textproc/xerces-c2-devel')
-rw-r--r--textproc/xerces-c2-devel/Makefile49
-rw-r--r--textproc/xerces-c2-devel/pkg-plist6
2 files changed, 44 insertions, 11 deletions
diff --git a/textproc/xerces-c2-devel/Makefile b/textproc/xerces-c2-devel/Makefile
index c24e67687edd..fda5c2cc1c8f 100644
--- a/textproc/xerces-c2-devel/Makefile
+++ b/textproc/xerces-c2-devel/Makefile
@@ -7,13 +7,36 @@
PORTNAME= xerces-c2
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://xml.apache.org/dist/xerces-c/stable/
DISTNAME= xerces-c-src${PORTVERSION:S/./_/g}
MAINTAINER?= bzeeb+freebsdports@zabbadoz.net
-LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+.if !defined(TRANSCODER)
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+TRANSCODER= "IconvFBSD"
+PLIST_SUB+= TRANSICONV=""
+PLIST_SUB+= TRANSICU="@comment "
+.else
+.if (${TRANSCODER} == "icu")
+LIB_DEPENDS+= icuuc.22:${PORTSDIR}/devel/icu
+ICUROOT?= ${LOCALBASE}
+CONFIGURE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
+MAKE_ENV+= ICUROOT=${ICUROOT} LDFLAGS="-L${LOCALBASE}/lib"
+PLIST_SUB+= TRANSICONV="@comment "
+PLIST_SUB+= TRANSICU=""
+.elif (${TRANSCODER} == "native")
+PLIST_SUB+= TRANSICONV=""
+PLIST_SUB+= TRANSICU="@comment "
+.else
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+TRANSCODER= "IconvFBSD"
+PLIST_SUB+= TRANSICONV=""
+PLIST_SUB+= TRANSICU="@comment "
+.endif
+.endif
# expect this to get broken some day
NO_FILTER_SHLIBS= yes
@@ -30,18 +53,17 @@ USE_GMAKE= yes
MAKE_ENV+= XERCESCROOT=${WRKSRC}
GNU_CONFIGURE= yes
-CONFIGURE_ENV+= XERCESCROOT=${WRKSRC} TRANSCODER="IconvFBSD"
+CONFIGURE_ENV+= XERCESCROOT=${WRKSRC} TRANSCODER=${TRANSCODER}
CONFIGURE_SCRIPT= runConfigure
-CONFIGURE_ARGS?= -p freebsd -x g++ -n socket -P ${PREFIX}
+CONFIGURE_ARGS?= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
-CONFIGURE_ARGS+= -t IconvFBSD
+CONFIGURE_ARGS+= -t ${TRANSCODER}
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
.endif
-XERCESC_LIB_VERSIO= ${PORTVERSION:S/.//}
-XERCESC_LIB_VERSION= ${XERCESC_LIB_VERSIO:R}
+XERCESC_LIB_VERSION= ${PORTVERSION:S/.//:R}
XERCESC_LIB= libxerces-c.so.${PORTVERSION:S/.//}
PLIST_SUB+= XERCESC_LIB=${XERCESC_LIB} \
XERCESC_LIB_VERSION=${XERCESC_LIB_VERSION}
@@ -62,7 +84,7 @@ PLIST_SUB+= NO_SAMPLES="@comment "
pre-fetch:
.if !defined(BATCH) && !defined(PACKAGE_BUILDING)
@(/usr/bin/dialog --textbox ${MASTERDIR}/pkg-message 15 75 || \
- /usr/bin/true)
+ ${TRUE})
@${ECHO} ''
@${ECHO} 'You may use the following build options by defining'
@${ECHO} 'them on the command line with -D'
@@ -71,6 +93,8 @@ pre-fetch:
@${ECHO} 'NO_SAMPLES do not copy sample binaries and sources'
@${ECHO} 'NOPORTDOCS do not copy documentation'
@${ECHO} ''
+ @${ECHO} 'TRANSCODER=[icu|IconvFBSD|native] default: IconvFBSD'
+ @${ECHO} ''
@/bin/sleep 2
.endif
@@ -87,17 +111,24 @@ pre-configure:
post-configure:
.if !defined(NO_SAMPLES)
+.if defined(TRANSCODER) && (${TRANSCODER} == "icu")
+ @(cd ${WRKSRC}/samples && \
+ export XERCESCROOT=${WRKSRC} && \
+ export ICUROOT=${ICUROOT} && \
+ export LDFLAGS="-L${LOCALBASE}/lib" && \
+ ${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
+.else
@(cd ${WRKSRC}/samples && \
export XERCESCROOT=${WRKSRC} && \
${SH} runConfigure ${SAMPLES_CONFIG_ARGS})
.endif
+.endif
post-install:
@${STRIP_CMD} ${PREFIX}/lib/${XERCESC_LIB}
@${LN} -sf ${XERCESC_LIB} ${PREFIX}/lib/libxerces-c.so
@${LN} -sf ${XERCESC_LIB} \
- ${PREFIX}/lib/libxerces-c.so.${XERCESC_LIB_VERSION:R}
-
+ ${PREFIX}/lib/libxerces-c.so.${XERCESC_LIB_VERSION}
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xerces-c
@${CP} -r ${WRKSRC}/doc/ ${PREFIX}/share/doc/xerces-c/
diff --git a/textproc/xerces-c2-devel/pkg-plist b/textproc/xerces-c2-devel/pkg-plist
index 3f9662f35672..f1ca557d8570 100644
--- a/textproc/xerces-c2-devel/pkg-plist
+++ b/textproc/xerces-c2-devel/pkg-plist
@@ -131,7 +131,8 @@ include/xercesc/util/Base64.hpp
include/xercesc/util/AutoSense.hpp
include/xercesc/util/XMLDeleterFor.c
include/xercesc/util/Platforms/FreeBSD/FreeBSDDefs.hpp
-include/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.hpp
+%%TRANSICONV%%include/xercesc/util/Transcoders/IconvFBSD/IconvFBSDTransService.hpp
+%%TRANSICU%%include/xercesc/util/Transcoders/ICU/ICUTransService.hpp
include/xercesc/util/MsgLoaders/InMemory/InMemMsgLoader.hpp
include/xercesc/util/MsgLoaders/InMemory/CppErrMsgs_EN_US.hpp
include/xercesc/util/Compilers/BorlandCDefs.hpp
@@ -392,7 +393,8 @@ lib/%%XERCESC_LIB%%
@dirrm include/xercesc/util/Compilers
@dirrm include/xercesc/util/MsgLoaders/InMemory
@dirrm include/xercesc/util/MsgLoaders
-@dirrm include/xercesc/util/Transcoders/IconvFBSD
+%%TRANSICONV%%@dirrm include/xercesc/util/Transcoders/IconvFBSD
+%%TRANSICU%%@dirrm include/xercesc/util/Transcoders/ICU
@dirrm include/xercesc/util/Transcoders
@dirrm include/xercesc/util/Platforms/FreeBSD
@dirrm include/xercesc/util/Platforms