aboutsummaryrefslogtreecommitdiff
path: root/textproc/xerces-c27/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-01-12 02:03:09 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-01-12 02:03:09 +0000
commitd3eccd2d9965db047f56662f33923e7d0398a9e1 (patch)
tree4f0538d4bba891e1134090bc71a3b3f749d64176 /textproc/xerces-c27/Makefile
parenta481f4c27ce608cf497c1ee84cd4af0a92cb062e (diff)
downloadports-d3eccd2d9965db047f56662f33923e7d0398a9e1.tar.gz
ports-d3eccd2d9965db047f56662f33923e7d0398a9e1.zip
Notes
Diffstat (limited to 'textproc/xerces-c27/Makefile')
-rw-r--r--textproc/xerces-c27/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/textproc/xerces-c27/Makefile b/textproc/xerces-c27/Makefile
index fda5c2cc1c8f..976e31423fb4 100644
--- a/textproc/xerces-c27/Makefile
+++ b/textproc/xerces-c27/Makefile
@@ -55,10 +55,12 @@ MAKE_ENV+= XERCESCROOT=${WRKSRC}
GNU_CONFIGURE= yes
CONFIGURE_ENV+= XERCESCROOT=${WRKSRC} TRANSCODER=${TRANSCODER}
CONFIGURE_SCRIPT= runConfigure
-CONFIGURE_ARGS?= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
+CONFIGURE_ARGS+= -p freebsd -c ${CC} -x ${CXX} -n socket -P ${PREFIX}
CONFIGURE_ARGS+= -t ${TRANSCODER}
+.include <bsd.port.pre.mk>
+
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
.endif
@@ -73,7 +75,7 @@ PLIST_SUB+= NO_SAMPLES=""
ALL_TARGET?= all samples
XERCES_BINS?= CreateDOMDocument DOMCount DOMPrint EnumVal MemParse PParse \
Redirect SAX2Count SAX2Print SAXCount SAXPrint SEnumVal StdInParse
-SAMPLES_CONFIG_ARGS?= -p freebsd -x g++
+SAMPLES_CONFIG_ARGS+= -p freebsd -c ${CC} -x ${CXX}
.if defined(NO_THREADS)
SAMPLES_CONFIG_ARGS+= -r none
.endif
@@ -143,4 +145,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>