aboutsummaryrefslogtreecommitdiff
path: root/textproc/xerces-c27
diff options
context:
space:
mode:
authorDoug Barton <dougb@FreeBSD.org>2002-10-25 02:12:19 +0000
committerDoug Barton <dougb@FreeBSD.org>2002-10-25 02:12:19 +0000
commit83ee889b5aa3fae3961954e80fbcfa25c05af342 (patch)
treee0786eabb13fab84787b52e604353f824034abe1 /textproc/xerces-c27
parenta00e493b52a31c5410107e58ac383a4a4e777f64 (diff)
downloadports-83ee889b5aa3fae3961954e80fbcfa25c05af342.tar.gz
ports-83ee889b5aa3fae3961954e80fbcfa25c05af342.zip
Notes
Diffstat (limited to 'textproc/xerces-c27')
-rw-r--r--textproc/xerces-c27/Makefile17
-rw-r--r--textproc/xerces-c27/pkg-plist2
2 files changed, 17 insertions, 2 deletions
diff --git a/textproc/xerces-c27/Makefile b/textproc/xerces-c27/Makefile
index c670fe359c90..c24e67687edd 100644
--- a/textproc/xerces-c27/Makefile
+++ b/textproc/xerces-c27/Makefile
@@ -40,8 +40,11 @@ CONFIGURE_ARGS+= -t IconvFBSD
CONFIGURE_ARGS+= -r none
.endif
+XERCESC_LIB_VERSIO= ${PORTVERSION:S/.//}
+XERCESC_LIB_VERSION= ${XERCESC_LIB_VERSIO:R}
XERCESC_LIB= libxerces-c.so.${PORTVERSION:S/.//}
-PLIST_SUB+= XERCESC_LIB=${XERCESC_LIB}
+PLIST_SUB+= XERCESC_LIB=${XERCESC_LIB} \
+ XERCESC_LIB_VERSION=${XERCESC_LIB_VERSION}
.if !defined(NO_SAMPLES)
PLIST_SUB+= NO_SAMPLES=""
@@ -71,6 +74,13 @@ pre-fetch:
@/bin/sleep 2
.endif
+post-patch:
+ @${CP} ${WRKSRC}/src/xercesc/Makefile.incl \
+ ${WRKSRC}/src/xercesc/Makefile.incl.Dist
+ @${SED} -e 's#CP = -cp -p#CP = -cp#' \
+ ${WRKSRC}/src/xercesc/Makefile.incl.Dist > \
+ ${WRKSRC}/src/xercesc/Makefile.incl
+
pre-configure:
@${CHMOD} 700 ${CONFIGURE_WRKSRC}/runConfigure
@${CHMOD} 700 ${CONFIGURE_WRKSRC}/configure
@@ -84,7 +94,10 @@ post-configure:
post-install:
@${STRIP_CMD} ${PREFIX}/lib/${XERCESC_LIB}
- ${LN} -sf ${XERCESC_LIB} ${PREFIX}/lib/libxerces-c.so
+ @${LN} -sf ${XERCESC_LIB} ${PREFIX}/lib/libxerces-c.so
+ @${LN} -sf ${XERCESC_LIB} \
+ ${PREFIX}/lib/libxerces-c.so.${XERCESC_LIB_VERSION:R}
+
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/xerces-c
@${CP} -r ${WRKSRC}/doc/ ${PREFIX}/share/doc/xerces-c/
diff --git a/textproc/xerces-c27/pkg-plist b/textproc/xerces-c27/pkg-plist
index 9c2b0d8b5acb..3f9662f35672 100644
--- a/textproc/xerces-c27/pkg-plist
+++ b/textproc/xerces-c27/pkg-plist
@@ -372,7 +372,9 @@ include/xercesc/validators/schema/GeneralAttributeCheck.hpp
include/xercesc/validators/schema/XSDErrorReporter.hpp
lib/%%XERCESC_LIB%%
@exec ln -sf %%XERCESC_LIB%% %D/lib/libxerces-c.so
+@exec ln -sf %%XERCESC_LIB%% %D/lib/libxerces-c.so.%%XERCESC_LIB_VERSION%%
@unexec if test ! -r %D/lib/libxerces-c.so; then rm -f %D/lib/libxerces-c.so; fi
+@unexec if test ! -r %D/lib/libxerces-c.so; then rm -f %D/lib/libxerces-c.so.%%XERCESC_LIB_VERSION%%; fi
@dirrm include/xercesc/validators/schema/identity
@dirrm include/xercesc/validators/schema
@dirrm include/xercesc/validators/DTD