aboutsummaryrefslogtreecommitdiff
path: root/textproc/xerces-c
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2004-11-05 17:25:06 +0000
committerGreg Lewis <glewis@FreeBSD.org>2004-11-05 17:25:06 +0000
commitac18060927d6943a3cc71ebdaedaef212f086428 (patch)
treeed522356406d9bc965149a5d8c8b5a6c67789fbe /textproc/xerces-c
parentf6c9b7137f7f5f5522c1ccef6cda93217fa003f0 (diff)
downloadports-ac18060927d6943a3cc71ebdaedaef212f086428.tar.gz
ports-ac18060927d6943a3cc71ebdaedaef212f086428.zip
Notes
Diffstat (limited to 'textproc/xerces-c')
-rw-r--r--textproc/xerces-c/Makefile8
-rw-r--r--textproc/xerces-c/files/patch-src::xercesc::runConfigure13
2 files changed, 16 insertions, 5 deletions
diff --git a/textproc/xerces-c/Makefile b/textproc/xerces-c/Makefile
index da51dcd189b8..d1920698f646 100644
--- a/textproc/xerces-c/Makefile
+++ b/textproc/xerces-c/Makefile
@@ -30,7 +30,9 @@ MAKE_ENV+= XERCESCROOT=${WRKSRC}
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= runConfigure
-CONFIGURE_ENV+= XERCESCROOT=${WRKSRC} TRANSCODER="IconvFBSD"
+CONFIGURE_ENV+= XERCESCROOT=${WRKSRC} TRANSCODER="IconvFBSD" \
+ PTHREAD_LIBS="${PTHREAD_LIBS}" \
+ PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
CONFIGURE_ARGS= -p freebsd -n socket -P ${PREFIX}
.if defined(NO_THREADS)
CONFIGURE_ARGS+= -r none
@@ -40,10 +42,6 @@ PLIST_SUB+= XERCESC_VER=${PORTVERSION:S/./_/g} \
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502102
-FORBIDDEN= "Does not respect PTHREAD_{CFLAGS,LIBS}"
-.endif
-
pre-configure:
${CHMOD} 700 ${CONFIGURE_WRKSRC}/runConfigure
${CHMOD} 700 ${CONFIGURE_WRKSRC}/configure
diff --git a/textproc/xerces-c/files/patch-src::xercesc::runConfigure b/textproc/xerces-c/files/patch-src::xercesc::runConfigure
new file mode 100644
index 000000000000..df759bd87f91
--- /dev/null
+++ b/textproc/xerces-c/files/patch-src::xercesc::runConfigure
@@ -0,0 +1,13 @@
+--- src/xercesc/runConfigure.orig Wed Oct 20 12:25:47 2004
++++ src/xercesc/runConfigure Wed Oct 20 12:26:33 2004
+@@ -294,8 +294,8 @@
+ ;;
+ esac
+ elif test $platform = "freebsd"; then
+- threadingLibs="-pthread -lc_r"
+- threadingDefines="-D_THREAD_SAFE -DXML_USE_PTHREADS"
++ threadingLibs="${PTHREAD_LIBS}"
++ threadingDefines="${PTHREAD_CFLAGS} -DXML_USE_PTHREADS"
+ elif test $platform = "aix"; then
+ aix_version=`./config.guess`;
+ echo Found host system to be $aix_version