aboutsummaryrefslogtreecommitdiff
path: root/textproc/xerces-j
diff options
context:
space:
mode:
authorVolker Stolz <vs@FreeBSD.org>2004-07-14 11:44:09 +0000
committerVolker Stolz <vs@FreeBSD.org>2004-07-14 11:44:09 +0000
commit2432a7b5f6ec3372955acc9523e6e9cbd1134025 (patch)
tree65ca09a9d5b7a4fa1a57a5ae58060b8cc70a32c6 /textproc/xerces-j
parent912e35e4b52bade4c4bc11d0725857e183dc25d3 (diff)
downloadports-2432a7b5f6ec3372955acc9523e6e9cbd1134025.tar.gz
ports-2432a7b5f6ec3372955acc9523e6e9cbd1134025.zip
Notes
Diffstat (limited to 'textproc/xerces-j')
-rw-r--r--textproc/xerces-j/Makefile46
-rw-r--r--textproc/xerces-j/pkg-descr24
2 files changed, 50 insertions, 20 deletions
diff --git a/textproc/xerces-j/Makefile b/textproc/xerces-j/Makefile
index 2db66b217522..556ade8be34e 100644
--- a/textproc/xerces-j/Makefile
+++ b/textproc/xerces-j/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xerces-j
PORTVERSION= 2.6.2
+PORTREVISION= 1
CATEGORIES= textproc java
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= xerces-j/source
@@ -23,7 +24,7 @@ JAVA_VERSION= 1.3+
WRKSRC= ${WRKDIR}/xerces-${PORTVERSION:S/./_/g}
OPTIONS= DEPRECATED_JARS "build/install the deprecated JARs" on \
- SAMPLES_JAR "build/install the samples" off
+ SAMPLES "build/install the samples" on
.include <bsd.port.pre.mk>
@@ -35,11 +36,11 @@ PORTDOCS= api dom3-api other xerces2 xni xs
.endif
JARFILES+= xercesImpl.jar xml-apis.jar
-.if defined(WITH_DEPRECATED_JARS)
+.if !defined(WITHOUT_DEPRECATED_JARS)
ANT_TARGETS+= deprecatedjars
JARFILES+= xerces.jar xmlParserAPIs.jar resolver.jar
.endif
-.if defined(WITH_SAMPLES_JAR)
+.if !defined(WITHOUT_SAMPLES)
JARFILES+= xercesSamples.jar
.endif
@@ -51,24 +52,39 @@ post-extract:
@cd ${WRKSRC} && ${MV} ../tools .
do-build:
- @cd ${WRKSRC} && ${SETENV} CLASSPATH=`echo ${TOOLS_JARFILES:S,^,tools/,} | ${TR} " " ":"` ${ANT} ${ANT_TARGETS}
+ @cd ${WRKSRC} && \
+ ${SETENV} CLASSPATH=`echo ${TOOLS_JARFILES:S,^,tools/,} | \
+ ${TR} " " ":"` ${ANT} ${ANT_TARGETS}
do-install:
- @${ECHO_CMD} -n ">> Installing JAR files in ${JAVAJARDIR}..."
+ @${ECHO_MSG} -n ">> Installing JAR files in ${JAVAJARDIR}..."
@${MKDIR} ${JAVAJARDIR}
.for JARFILE in ${JARFILES}
- @cd ${WRKSRC}/build && ${CP} ${JARFILE} ${JAVAJARDIR}/
- @${ECHO_CMD} -n " ${JARFILE}"
+ @cd ${WRKSRC}/build && ${INSTALL_DATA} ${JARFILE} ${JAVAJARDIR}/${JARFILE}
+ @${ECHO_MSG} -n " ${JARFILE}"
.endfor
- @${ECHO_CMD} " [ DONE ]"
+ @${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)
- @${ECHO_CMD} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
-.for DOCFILE in ${PORTDOCS}
- @cd ${WRKSRC}/build/docs/javadocs && ${CP} -r ${DOCFILE} ${DOCSDIR}/
- @${ECHO_CMD} -n " ${DOCFILE}"
-.endfor
- @${ECHO_CMD} " [ DONE ]"
+ @${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
+ @cd ${WRKSRC}/build/docs/javadocs && \
+ ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} "${DOCSDIR}/{}" \; && \
+ ${FIND} ${PORTDOCS} -not -type d -exec ${INSTALL_DATA} "{}" "${DOCSDIR}/{}" \;
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+.if !defined(WITHOUT_SAMPLES)
+ @${ECHO_MSG} -n ">> Installing samples in ${EXAMPLESDIR}..."
+ @cd ${WRKSRC}/samples && \
+ ${FIND} . -type d -exec ${MKDIR} "${EXAMPLESDIR}/{}" \; && \
+ ${FIND} . -not -type d -exec ${INSTALL_DATA} "{}" "${EXAMPLESDIR}/{}" \;
+ @${ECHO_MSG} " [ DONE ]"
+.endif
+
+.if !defined(WITHOUT_SAMPLES)
+post-install:
+ @${FIND} -s ${WRKSRC}/samples -not -type d | \
+ ${SED} -ne 's,^${WRKSRC}/samples,${EXAMPLESDIR:S,${PREFIX}/,,},p' >> ${TMPPLIST}
+ @${FIND} -s -d ${WRKSRC}/samples -type d | \
+ ${SED} -ne 's,^${WRKSRC}/samples,@dirrm ${EXAMPLESDIR:S,${PREFIX}/,,},p' >> ${TMPPLIST}
.endif
.include <bsd.port.post.mk>
diff --git a/textproc/xerces-j/pkg-descr b/textproc/xerces-j/pkg-descr
index 75db363f91d5..12b9b566ae0b 100644
--- a/textproc/xerces-j/pkg-descr
+++ b/textproc/xerces-j/pkg-descr
@@ -1,6 +1,20 @@
-The Xerces Java Parser supports XML 1.0 recommendation and
-contains advanced parser functionality, such as XML Schema, DOM
-Level 2 version 1.0, and SAX Version 2, in addition to supporting
-the industry-standard DOM Level 1 and SAX version 1 APIs.
+The Xerces Java Parser supports XML 1.0 recommendation and contains advanced
+parser functionality, such as XML Schema, DOM Level 2 version 1.0, and SAX
+Version 2, in addition to supporting the industry-standard DOM Level 1 and SAX
+version 1 APIs.
-WWW: http://xml.apache.org/xerces2-j/index.html
+Xerces2 is the next generation of high performance, fully compliant XML parsers
+in the Apache Xerces family. This version of Xerces introduces the Xerces
+Native Interface (XNI), a complete framework for building parser components and
+configurations that is extremely modular and easy to program.
+
+The Apache Xerces2 parser is the reference implementation of XNI but other
+parser components, configurations, and parsers can be written using the Xerces
+Native Interface.
+
+Xerces2 also provides an experimental implementation of the Document Object
+Model Level 3 Core and Load/Save Proposed Recommendations and provides a
+partial implementation of the XML Inclusions (XInclude) W3C Working Draft in
+Last Call. It also provides support for OASIS XML Catalogs.
+
+WWW: http://xml.apache.org/xerces2-j/