aboutsummaryrefslogtreecommitdiff
path: root/textproc/xhtml-11
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-01-08 04:36:55 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-01-08 04:36:55 +0000
commitd8c9506a2898dbb58d796f04ed85cfaafd18a4a3 (patch)
tree03c11302e4e44000153444f50c6d97ff8f96c292 /textproc/xhtml-11
parentc86ea57e01d4db8388f074725758ba0026070354 (diff)
downloadports-d8c9506a2898dbb58d796f04ed85cfaafd18a4a3.tar.gz
ports-d8c9506a2898dbb58d796f04ed85cfaafd18a4a3.zip
Notes
Diffstat (limited to 'textproc/xhtml-11')
-rw-r--r--textproc/xhtml-11/Makefile38
-rw-r--r--textproc/xhtml-11/distinfo1
-rw-r--r--textproc/xhtml-11/pkg-descr3
-rw-r--r--textproc/xhtml-11/pkg-plist11
4 files changed, 53 insertions, 0 deletions
diff --git a/textproc/xhtml-11/Makefile b/textproc/xhtml-11/Makefile
new file mode 100644
index 000000000000..63798835b090
--- /dev/null
+++ b/textproc/xhtml-11/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: XHTML 1.1 DTD
+# Date created: 18 April 2003
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xhtml
+PORTVERSION= 1.1
+PORTREVISION= 1
+CATEGORIES= textproc
+MASTER_SITES= http://www.w3.org/TR/xhtml11/
+DISTNAME= xhtml11
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= W3C's XHTML 1.1 DTD
+
+RUN_DEPENDS= ${XMLCATMGR}:${PORTSDIR}/textproc/xmlcatmgr
+
+WRKSRC= ${WRKDIR}/xhtml11-20010531
+NO_BUILD= yes
+PLIST_SUB= XMLCATMGR=${XMLCATMGR} DTDDIR=${DTDDIR} \
+ CATALOG_PORTS_SGML=${CATALOG_PORTS_SGML}
+
+DTDDIR= ${PREFIX}/share/xml/${PORTNAME}/${PORTVERSION}
+XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
+CATALOG_PORTS_SGML= ${PREFIX}/share/sgml/catalog.ports
+
+do-install:
+ ${MKDIR} ${DTDDIR}
+ ${INSTALL_DATA} ${WRKSRC}/DTD/* ${DTDDIR}
+
+post-install:
+ ${XMLCATMGR} -sc ${CATALOG_PORTS_SGML} \
+ add CATALOG ${DTDDIR}/xhtml11.cat
+
+.include <bsd.port.mk>
diff --git a/textproc/xhtml-11/distinfo b/textproc/xhtml-11/distinfo
new file mode 100644
index 000000000000..605d62d2e51b
--- /dev/null
+++ b/textproc/xhtml-11/distinfo
@@ -0,0 +1 @@
+MD5 (xhtml11.tgz) = 00c3fe896f3d29419dbda4186aa98fe1
diff --git a/textproc/xhtml-11/pkg-descr b/textproc/xhtml-11/pkg-descr
new file mode 100644
index 000000000000..d65a7e274e9d
--- /dev/null
+++ b/textproc/xhtml-11/pkg-descr
@@ -0,0 +1,3 @@
+This package includes DTDs for the XHTML 1.1.
+
+WWW: http://www.w3.org/TR/xhtml11/
diff --git a/textproc/xhtml-11/pkg-plist b/textproc/xhtml-11/pkg-plist
new file mode 100644
index 000000000000..4762fdd9e1c2
--- /dev/null
+++ b/textproc/xhtml-11/pkg-plist
@@ -0,0 +1,11 @@
+share/xml/xhtml/1.1/VERSION
+share/xml/xhtml/1.1/xhtml11-flat.dtd
+share/xml/xhtml/1.1/xhtml11-model-1.mod
+@unexec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% remove %%DTDDIR%%/xhtml11.cat
+share/xml/xhtml/1.1/xhtml11.cat
+@exec %%XMLCATMGR%% -sc %%CATALOG_PORTS_SGML%% add CATALOG %%DTDDIR%%/xhtml11.cat
+share/xml/xhtml/1.1/xhtml11.dtd
+share/xml/xhtml/1.1/xml1.dcl
+share/xml/xhtml/1.1/xml1n.dcl
+@dirrm share/xml/xhtml/1.1
+@unexec rmdir %D/share/xml/xhtml 2>/dev/null || true