aboutsummaryrefslogtreecommitdiff
path: root/textproc/xhtml-modularization
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2016-05-24 22:32:49 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2016-05-24 22:32:49 +0000
commit963854440c8d5cb49ac23779c965d0f6fb408744 (patch)
tree097b956f7e23b0db264fe1d3cdeee8eafc050cd9 /textproc/xhtml-modularization
parentddf8b3e6be1c5e8bd6c6415891ec22c20f432245 (diff)
downloadports-963854440c8d5cb49ac23779c965d0f6fb408744.tar.gz
ports-963854440c8d5cb49ac23779c965d0f6fb408744.zip
Notes
Diffstat (limited to 'textproc/xhtml-modularization')
-rw-r--r--textproc/xhtml-modularization/Makefile61
-rw-r--r--textproc/xhtml-modularization/pkg-plist111
2 files changed, 125 insertions, 47 deletions
diff --git a/textproc/xhtml-modularization/Makefile b/textproc/xhtml-modularization/Makefile
index 79064c7bc155..540633dd5582 100644
--- a/textproc/xhtml-modularization/Makefile
+++ b/textproc/xhtml-modularization/Makefile
@@ -11,79 +11,46 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= W3C's Modularization of XHTML DTDs and docs
-RUN_DEPENDS= ${XMLCATMGR}:textproc/xmlcatmgr
+RUN_DEPENDS= xmlcatmgr:textproc/xmlcatmgr
USES= tar:tgz
RECDATE= 20010410
+OPTIONS_DEFINE= DOCS EXAMPLES
+
SUB_FILES= catalog.xml
NO_MTREE= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${RECDATE}
-PLIST= ${WRKDIR}/PLIST
dir_DTD= share/xml/dtd/xhtml-modularization
-dir_DOC= share/doc/xhtml-modularization
-dir_EXAMPLES= share/examples/xhtml-modularization
-dir_TEMPLATES= share/examples/xhtml-modularization/templates
-
-XMLCATMGR= ${LOCALBASE}/bin/xmlcatmgr
-SGMLCAT= ${PREFIX}/share/sgml/catalog.ports
-XMLCAT= ${PREFIX}/share/xml/catalog.ports
-
-XMLCAT_ADD= ${XMLCATMGR} -c ${XMLCAT} add nextCatalog \
- ${PREFIX}/${dir_DTD}/catalog.xml
-XMLCAT_RM= ${XMLCATMGR} -c ${XMLCAT} remove \
- ${PREFIX}/${dir_DTD}/catalog.xml
-SGMLCAT_ADD= ${XMLCATMGR} -sc ${SGMLCAT} add CATALOG \
- ${PREFIX}/${dir_DTD}/xhtml.cat
-SGMLCAT_RM= ${XMLCATMGR} -sc ${SGMLCAT} remove \
- ${PREFIX}/${dir_DTD}/xhtml.cat
.include "${.CURDIR}/contents.inc"
-# I'd much rather do this stuff in line with the actual installation
-# in do-install, but the PLIST must be generated in pre-install.
-pre-install:
- ${CAT} /dev/null > ${PLIST}
-.for f in ${contents_DTD}
- ${ECHO} ${dir_DTD}/${f} >> ${PLIST}
-.endfor
-.for f in ${contents_DOC}
- ${ECHO} ${dir_DOC}/${f} >> ${PLIST}
-.endfor
-.for f in ${contents_EXAMPLES}
- ${ECHO} ${dir_EXAMPLES}/${f} >> ${PLIST}
-.endfor
-.for f in ${contents_TEMPLATES}
- ${ECHO} ${dir_TEMPLATES}/${f} >> ${PLIST}
-.endfor
- ${ECHO} ${dir_DTD}/catalog.xml >> ${PLIST}
- ${ECHO} "@unexec ${XMLCAT_RM}" >> ${PLIST}
- ${ECHO} "@exec ${XMLCAT_ADD}" >> ${PLIST}
- ${ECHO} "@unexec ${SGMLCAT_RM}" >> ${PLIST}
- ${ECHO} "@exec ${SGMLCAT_ADD}" >> ${PLIST}
-
do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${dir_DTD}
.for f in ${contents_DTD}
${INSTALL_DATA} ${WRKSRC}/DTD/${f} ${STAGEDIR}${PREFIX}/${dir_DTD}/${f}
.endfor
- @${MKDIR} ${STAGEDIR}${PREFIX}/${dir_DOC}/images
+ ${INSTALL_DATA} ${WRKDIR}/catalog.xml ${STAGEDIR}${PREFIX}/${dir_DTD}/catalog.xml
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}/images
.for f in ${contents_DOC}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${PREFIX}/${dir_DOC}/${f}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}/${f}
.endfor
- @${MKDIR} ${STAGEDIR}${PREFIX}/${dir_EXAMPLES}
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for f in ${contents_EXAMPLES}
${INSTALL_DATA} ${WRKSRC}/DTD/examples/${f} \
- ${STAGEDIR}${PREFIX}/${dir_EXAMPLES}/${f}
+ ${STAGEDIR}${EXAMPLESDIR}/${f}
.endfor
- @${MKDIR} ${STAGEDIR}${PREFIX}/${dir_TEMPLATES}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/templates
.for f in ${contents_TEMPLATES}
${INSTALL_DATA} ${WRKSRC}/DTD/templates/${f} \
- ${STAGEDIR}${PREFIX}/${dir_TEMPLATES}/${f}
+ ${STAGEDIR}${EXAMPLESDIR}/templates/${f}
.endfor
- ${INSTALL_DATA} ${WRKDIR}/catalog.xml ${STAGEDIR}${PREFIX}/${dir_DTD}/catalog.xml
.include <bsd.port.mk>
diff --git a/textproc/xhtml-modularization/pkg-plist b/textproc/xhtml-modularization/pkg-plist
new file mode 100644
index 000000000000..f8be22d61f3c
--- /dev/null
+++ b/textproc/xhtml-modularization/pkg-plist
@@ -0,0 +1,111 @@
+share/xml/dtd/xhtml-modularization/VERSION
+@xmlcatmgr share/xml/dtd/xhtml-modularization/catalog.xml
+share/xml/dtd/xhtml-modularization/xhtml-applet-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-arch-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-attribs-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-base-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-basic-form-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-basic-table-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-bdo-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-blkphras-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-blkpres-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-blkstruct-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-charent-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-csismap-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-datatypes-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-edit-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-events-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-form-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-frames-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-framework-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-hypertext-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-iframe-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-image-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-inlphras-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-inlpres-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-inlstruct-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-inlstyle-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-lat1.ent
+share/xml/dtd/xhtml-modularization/xhtml-legacy-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-legacy-redecl-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-link-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-list-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-meta-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-nameident-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-notations-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-object-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-param-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-pres-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-qname-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-script-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-special.ent
+share/xml/dtd/xhtml-modularization/xhtml-ssismap-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-struct-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-style-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-symbol.ent
+share/xml/dtd/xhtml-modularization/xhtml-table-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-target-1.mod
+share/xml/dtd/xhtml-modularization/xhtml-text-1.mod
+@xmlcatmgr share/xml/dtd/xhtml-modularization/xhtml.cat
+share/xml/dtd/xhtml-modularization/xml1.dcl
+share/xml/dtd/xhtml-modularization/xml1n.dcl
+%%PORTDOCS%%%%DOCSDIR%%/Overview.html
+%%PORTDOCS%%%%DOCSDIR%%/W3C-REC.css
+%%PORTDOCS%%%%DOCSDIR%%/abstract_modules.html
+%%PORTDOCS%%%%DOCSDIR%%/abstraction.html
+%%PORTDOCS%%%%DOCSDIR%%/acknowledgements.html
+%%PORTDOCS%%%%DOCSDIR%%/conformance.html
+%%PORTDOCS%%%%DOCSDIR%%/dtd_developing.html
+%%PORTDOCS%%%%DOCSDIR%%/dtd_module_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/dtd_module_rules.html
+%%PORTDOCS%%%%DOCSDIR%%/goals.html
+%%PORTDOCS%%%%DOCSDIR%%/images/aqua.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/black.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/blue.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/fuchsia.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/gray.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/green.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/lime.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/maroon.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/navy.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/olive.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/purple.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/red.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/silver.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/teal.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/white.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/yellow.gif
+%%PORTDOCS%%%%DOCSDIR%%/introduction.html
+%%PORTDOCS%%%%DOCSDIR%%/logo-REC.gif
+%%PORTDOCS%%%%DOCSDIR%%/references.html
+%%PORTDOCS%%%%DOCSDIR%%/schema_developing.html
+%%PORTDOCS%%%%DOCSDIR%%/schema_module_defs.html
+%%PORTDOCS%%%%DOCSDIR%%/schema_module_rules.html
+%%PORTDOCS%%%%DOCSDIR%%/terms.html
+%%PORTDOCS%%%%DOCSDIR%%/w3c_home.gif
+%%PORTDOCS%%%%DOCSDIR%%/wcag1AAA.gif
+%%PORTDOCS%%%%DOCSDIR%%/xhtml-modularization.html
+%%PORTDOCS%%%%DOCSDIR%%/xhtml-modularization.pdf
+%%PORTDOCS%%%%DOCSDIR%%/xhtml-modularization.ps
+%%PORTDOCS%%%%DOCSDIR%%/xhtml.css
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/MODULE-qname.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inventory-1.dtd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inventory-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inventory-newprefix.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inventory-prefixed.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inventory-qname-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/inventory.xml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/myml-1_0.dtd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/myml-elements-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/myml-model-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/myml-noprefix.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/myml-prefixed.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/myml-qname-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-defaults.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-newprefix.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simple-prefixed.html
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simpleml-1_0.dtd
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/simpleml-model-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/template-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/template-qname-1.mod
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/templates/template.dtd