aboutsummaryrefslogtreecommitdiff
path: root/textproc/xlhtml/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-27 18:23:39 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-27 18:23:39 +0000
commit0fba8fa7c63a57b1afb70961ac2ea4d62737e8a5 (patch)
treea831653d1495a5216b47ab5a71bb8bb74f741e52 /textproc/xlhtml/Makefile
parentd0c8e27c75617a475bc647401a29183112669101 (diff)
downloadports-0fba8fa7c63a57b1afb70961ac2ea4d62737e8a5.tar.gz
ports-0fba8fa7c63a57b1afb70961ac2ea4d62737e8a5.zip
Notes
Diffstat (limited to 'textproc/xlhtml/Makefile')
-rw-r--r--textproc/xlhtml/Makefile26
1 files changed, 10 insertions, 16 deletions
diff --git a/textproc/xlhtml/Makefile b/textproc/xlhtml/Makefile
index ab0a7fc7d8f2..d6f20de789f9 100644
--- a/textproc/xlhtml/Makefile
+++ b/textproc/xlhtml/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: xlHtml
+# New ports collection makefile for: xlhtml
# Date created: 27 March 2000
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
@@ -6,10 +6,9 @@
#
PORTNAME= xlhtml
-PORTVERSION= 0.2.9.7
+PORTVERSION= 0.4
CATEGORIES= textproc
MASTER_SITES= http://www.xlhtml.org/
-DISTNAME= xlHtml-${PORTVERSION}
MAINTAINER= sobomax@FreeBSD.org
@@ -18,22 +17,17 @@ LIB_DEPENDS= cole.2:${PORTSDIR}/textproc/cole
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/cole"
-MAN1= pptHtml.1 xlHtml.1
-
-pre-build:
- @${RM} -f ${WRKSRC}/cole.h
- @find ${WRKSRC} -type f | xargs ${GREP} -l '\.\./cole\.h' | \
- xargs ${PERL} -pi -e 's|\.\./cole\.h|cole/cole.h|g'
+MAN1= ppthtml.1 xlhtml.1
do-install:
- (cd ${WRKSRC}/xlHtml && ${MAKE} ${INSTALL_TARGET})
- (cd ${WRKSRC}/pptHtml && ${MAKE} ${INSTALL_TARGET})
+ (cd ${WRKSRC}/xlhtml && ${MAKE} ${INSTALL_TARGET})
+ (cd ${WRKSRC}/ppthtml && ${MAKE} ${INSTALL_TARGET})
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/xlHtml
- ${INSTALL_MAN} ${WRKSRC}/xlHtml/README \
- ${PREFIX}/share/doc/xlHtml/README.xlHtml
- ${INSTALL_MAN} ${WRKSRC}/pptHtml/README \
- ${PREFIX}/share/doc/xlHtml/README.pptHtml
+ ${MKDIR} ${PREFIX}/share/doc/xlhtml
+ ${INSTALL_MAN} ${WRKSRC}/xlhtml/README \
+ ${PREFIX}/share/doc/xlhtml/README.xlhtml
+ ${INSTALL_MAN} ${WRKSRC}/ppthtml/README \
+ ${PREFIX}/share/doc/xlhtml/README.ppthtml
.endif
.include <bsd.port.mk>